S4 Oil Temp high

aragorn

"Stick a V8 in it!"
Staff member
Moderator
VCDS Map User
you can use diesel to flush the engine, ive done it myself and Siena has done it too...

My method was to drain the engine oil out, refill to the max line with derv and start the engine, (i then ran the engine at 2krpm for 10minutes, Siena's method seems to be to let it idle for most of the 10 minutes with short bursts up to 2k) do not load the engine up or attempt to drive the car in any way, just run it for the 10mins then shut it off and drain the derv out.

Refill with fresh oil and a new filter and run it for about 500miles, before changing it again. I would suggest cheaper oil for the 500miles after the flush.

Wether i'd do a flush like that on an S4 motor however is another story. Its quite aggressive, so you'd have to be pretty sure it needed it before doing it tbh! and i doubt magnatec in the engine for a short time would really cause any issues tbh, magnatec left in there for thousands of miles with neglected oil changes perhaps, but not just a top up for a few months imo.

I still think you should try to get a secondary guage on the engine, either instead of, or alongside the original guage and see what numbers you get from that
 

EnzoS4

Registered User
now thats a very good idea, but do I want to do this to an S4...

the temp is now almost normal..? just so wired. anyone flushed an S4 engine and used aragorn idea..

I put in about 1lr of magnatec which was in for about 4 months (4,500 miles)...

started looking to empty the wallet today on a RS6 (£21k)....Hmmmm....? no don't do...
 

mwarrey

Registered User
I can't believe adding a litre of magnetec is going to cause this in any way. I wouldn't recommend using a flush tbh, could cause more problems. I would of thought you would be better off changing the oil more frequently. But if your looking for an excuse to buy an RS6 thats a different story.
 

EnzoS4

Registered User
I can't change the oil more frequently than I am already doing. (every 6 months, and had about 7 oil changes in the last 3 months.)

I do agree that a flush is maybe not a good idea, both APS and Audi said the samething, but its something that the ecu and vag-com can't detect. the temp now seems fine, if I replace the oil it will go back up to 120c.

I'll see what happens at the next service.
 

EnzoS4

Registered User
well 6 mths on and just had the next service and...... the oil temp has stayed about 110, higher than originally but seems constant. also oil temp rises slightly when having abit of fun but not to 120... also good

so not sure what, why or how but seems better...

so THANKS TO ALL FOR YOUR COMMENTS AND HELP...
 

EnzoS4

Registered User
happy0194.gif
 

EnzoS4

Registered User
***UPDATE***

Cars been running between 110 and 120 for last 6 months, had a recent 6mth service and now the temp is down to around 100 and just above when having fun, but did go up alot higher when I was playing with an RS4 B7

anyway just an update its down 20c..? only difference is the oil, previously we used Shell but this time its Quantum. Just that 10c more and I'm back to normal.
 

Matt82

Registered User
i have a similar problem. i have implausible oil temperatures.

whilst the car is warming up oil temp is at about 70* but once i put my foot down ive seen 140*+ which i know will not be true. the temp will then drop when i drive round the next corner

is the oil temp sensor just to the right of the flywheel pulley?
 

aragorn

"Stick a V8 in it!"
Staff member
Moderator
VCDS Map User
afaik the oil temp sensor is on the front of the block, but the diagram isnt very easy to see.

It will likely be somewhere around the oil filter/cooler housing.
 

Matt82

Registered User
see, i had a sensor just to the right of the crank pulley, to the left of the aircon pump, but there was no wire on it and i couldnt find a wire near by

should have got some pics tbh
 
Top