1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S4 Avant back to the Dealer - MMI too smart for its own good?

Clean Oct 9, 2018

  1. Clean

    Clean New Member

    13
    18
    3
    MMI Owning Peeps,

    So, I have managed longer than I did with my last three brand new Beemers, but in true new-car fashion, the S4 Avant is on its way to my local Dealer’s Service Department, tomorrow.

    The reason?

    An MMI System released with way too many bugs in it. For your information, and comment, I have so far experienced the following faults, in order of frequency of occurrence:

    Failure to initiate Audi Connect in the car after following every single method documented anywhere on the Interweb.

    In Car Voice Commands almost never work, defaulting to Phone, with some error message. The Phone based Voice Commands (Siri, in my case) then fails to work.

    Intermittent failure of the programmable button on the Multi Function Steering Wheel (Astérix on the RHS that most of us use for Drive Select).

    Randomn changes to Air Con setting (Full or Eco), that at first glance appears to be related to Drive Select, but also has a life all of its own.

    Incompatibility between Car Play and MMI (have they really programmed the system to disable all Bluetooth connection functionality when the ph9ne is plugged in to charge?!?)

    Failure of the Nav System to switch between Standard and Google Earth Views, frequently, and in both directions.

    All of these have been seen multiple times, with the first three being daily, since ownership!

    User Experience rating somewhat compromised!

    I know software is always released and then patched, but there appears to be no OTA Patching taking place, as normally happens with devices with always on network connectivity eg any Smartphone, Windows Device or IoT device.

    Does every / any one have similar experiences, or more to add to the list?

    Thanks,

    Clean.

    *ps* How do I find my systems software version number, and what is the latest version, please?
     
    Thundercliffe81 likes this.
  2. Avatar

    Google AdSense Advertisement


  3. Thundercliffe81

    Thundercliffe81 Well-Known Member Team V8 Team Sepang Audi RS4 Audi Avant Owner Group

    2,215
    1,553
    113
    Yo.

    Software version is ummmm...ugh where is it. Sure it's in Audi connect then the sub headings to the right. At the bottom.

    I experienced every issue you have listed with my S4. Intermittently. I had the MMI unit completely replaced. And still had issues afterwards. Cars are too dependent on these systems. So how on earth are they going to drive themselves and be interlinked with the IOT (Internet of things), not to mention the impending and horrific 5G!

    I think the C7 A6/RS6 and D4 A8/S8 were the perfect blend of analogue and digital.


    Sent from my iPhone using Tapatalk
     
    Clean likes this.
  4. Kuku

    Kuku Active Member

    221
    130
    43
    Sounds like a fair issues there for you and hopefully Audi can sort ASAP!

    The CarPlay and MMI is a bug bear of mine as I usually have two phones connected through Bluetooth (work and personal).

    If you use CarPlay then as you’ve experienced MMI Bluetooth etc is all disabled.

    However if you go in to connection manager and ‘turn off’ Audi Smartphone Interface’ this will allow you to plug in the phone and let it charge without it kicking in to CarPlay and you’ll then have full Bluetooth MMI functionality.

    The GoogleMaps issue I’ve only seen from Standard to Google and usually is either due to a slow data connection or server offline - never seen this GoogleMaps to Standard but come to think of it I’ve never switched back - map always set to GoogleMaps.

    Good luck with the fix on the other items
     
    Clean likes this.
  5. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    9,119
    3,224
    113
    I haven't experienced many of the issues Clean has stated but there are many that are having issues between the latest version of the Apple OS and MMI that all owners appear to be experiencing. Apple broke this not Audi and they've released an updated version of the OSX as far as I understand.
    As for stating the MMI system has too many bugs in it, I'd like to see Audi's response to that one.
     
  6. Clean

    Clean New Member

    13
    18
    3
    So, I thought you would all appreciate the loop being closed.

    Audi Customer Service was excellent, even if they did make me trade down from my S4 to a Q3 for the day. :D

    Failure to initiate Audi Connect in the car after following every single method documented anywhere on the Interweb.

    Apparently, this is a common problem, they fixed it for me.

    In Car Voice Commands almost never work, defaulting to Phone, with some error message. The Phone based Voice Commands (Siri, in my case) then fails to work.

    This one foxed the entire technical team, and resulted in them contacting someone important in Audi Infotainment; turns out that a short press on the Voice Control Button brings up the MMI System, and a long press the Phone based system. Who knew it?

    Intermittent failure of the programmable button on the Multi Function Steering Wheel (Astérix on the RHS that most of us use for Drive Select).

    They could not explain this, sadly, so it is still a bug in the software that persists. It happened the day after my car was at Audi! Grrrrrrrrrrrrrr

    Random changes to Air Con setting (Full or Eco), that at first glance appears to be related to Drive Select, but also has a life all of its own.

    These are linked to Drive Select, and are there by design; I get the logic, but find the thinking flawed, personally.

    Incompatibility between Car Play and MMI (have they really programmed the system to disable all Bluetooth connection functionality when the ph9ne is plugged in to charge?!?)

    See my previous comment!

    Failure of the Nav System to switch between Standard and Google Earth Views, frequently, and in both directions.

    Apparently, this is down to data speed over the network; not convinced.

    My software is allegedly patched to the latest version; no update was done because none was available, apparently. Ironically, the maps show my local Audi Dealer in its old location, one it left over 18 months ago!

    So, all in all not a bad result, and the end to end user experience more than compensated for the inadequacies I still believe exits in the MMI System design / operation.

    ..................... And boy was I smiling when I got back into the lush cockpit of my S4 and listened to the pops, burbling and farting of that V6! :)
     
    Jcbmally likes this.
  7. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    9,119
    3,224
    113
    Unfortunately most of those answers have been documented in this, and other Audi forums.
    But appreciate the update..
     
  8. Clean

    Clean New Member

    13
    18
    3
    “Unfortunately most of those answers have been documented in this, and other Audi forums.
    But appreciate the update..”

    Sorry.

    I’ll get my coat.......
     
  9. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    9,119
    3,224
    113
    No offence was intended at all, but sometimes research can help. I did say I would be interested in Audi's response to the statement that the system was released with too many bugs in it when the system is performing in the manner in which it was designed.
    Certainly the case since I have owned Audi's and many other cars with a similar interface..
     

Share This Page