S4 4.2 temp gauge

Major-eyeswater

Registered User
Hi guys.

Picked up an s4 recently and working through some issues.
Temp gauge doesn't move - whether the car is driven or idling.
I've picked up.a temp gauge 059919501a

Where is the temp location and what's the procedure to replace?

Thanks in advance.
 

Major-eyeswater

Registered User
I've just connected the torque app and am getting a reading for the water temperature.
Would this mean the current temp sensor is ok?
 

stevey83

Registered User
You may have a faulty gauge then. If you have VCDS you can test the instrument pods to check all the needles will sweep.
 

pauldazzle

Registered User
VAG temp sensors have two seperate outputs, one to the ECU & the other to the temp gauge. It is common for one output to fail, & the other to still work.
 

Major-eyeswater

Registered User
Ahh understood paul.
I'm currently monitoring the temp with the torque app via the android head unit display.
Is the temp sensora faff to change?
 

pauldazzle

Registered User
It's easy to change on most VAG cars, but I don't know the location on the 4.2.
 

s4mark

Registered User
My S4 has a water temp sensor mounted into the rigid coolant crossover pipe that runs between both heads at the back of the engine. You can just see it sitting below the sai combi valves but access from the top of the engine is almost impossible. I just had my o rings for the said coolant pipe changed and was apparently easily accessible once up on a ramp and accessed from underneath. Temp sensor is cheap just remember to change the o ring at the same time
 
Top