s3 8l remote central locking. please help


Registered User
Hi all ive had my 1999 s3 8l for a year now and the remote locking has never worked.
Ive tried programming it myself several times with no joy.
So today I took it to an ex audi technician who has vcds. He plugged into the car. And the was one fault showing saying open circuit crash.
I have noticed now and then the interior light comes on as im driving.
He cleared the code all ok. He accessed the c/l ecu and it was programmed to 00266. Whereas it should be 15000 something. He tried reprogramming the ecu several times but kept going back to 00266.
He is saying its most probably the ecu has got wet and is shot?
Has anyone had this problem before?

I should add the car is hpi clear and there is no signs anywhere of the car ever being damaged.

Sorry its so long winded. Thanks in advance.



Registered User
I'd replace the central locking pump.

Reprogram and go from there.

The unit is in the offside rear boot area.

Grab the Audi part number, eBay if you any a second hand one, and grab a VAG technician that won't rip you off as the Stealerships will. He'll need to code to the keys.

Essentially, that pump controls all sorts of circuitry within the car.