1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S3 8L 2002 not detecting door being shut [emoji848]

Black Jul 27, 2018

  1. Black

    Black Member

    98
    12
    8
    Hi,

    I seem to be having an intermittent fault with my S3, I'll shut the driver door but the cluster will be showing the door open. Also when I lock the car after 20-30 seconds it will be flashing hazard lights like the alarm is about to go off, but no siren.

    What could be the cause of that issue where to start?

    Thanks
    Pat[​IMG]

    Sent from my SM-G950F using Tapatalk
     
  2. Avatar

    Google AdSense Advertisement


  3. Tj 0785

    Tj 0785 Well-Known Member Silver Supporter VCDS Map User Bronze Supporter Audi S3

    2,217
    564
    113
    Sounds like you need a new alarm siren if the hazards flashing it’s quite common problem and is on my to do list the other problem I can’t help you with
     
  4. leon13

    leon13 New Member

    23
    4
    3
    I have this trouble intermittently. I thought it was a switch in the door, so the car thinks that the door is still open.
     
  5. Warsuperior

    Warsuperior Active Member

    354
    38
    28
    Im not 100% sure if this is on a3/s3 but like mk4 golf and skoda had problems that the door wiring would break where door wiring links to chassis.
     

    Attached Files:

    Black likes this.
  6. Black

    Black Member

    98
    12
    8
    Checked the wires seem fine Next option?

    Sent from my SM-G950F using Tapatalk
     
  7. silestanix

    silestanix Member

    72
    20
    8
    Try door switch bud, had that issue first night I bought mine, was stiff and the previous owner didn't carry passengers often, I just gt80'd it, been fine since.
     
    Black likes this.
  8. Black

    Black Member

    98
    12
    8
    Where is it

    Sent from my SM-G950F using Tapatalk
     
  9. silestanix

    silestanix Member

    72
    20
    8
    Think it's like my old Mercedes, It's built into the door lock mechanism from what I assume, as I see absolutely no physical switch anywhere.

    I shielded above the door lock and door card with cardboard so I didn't get the spray everywhere, and just sprayed into the door lock mechanism with the gt80'd with the little red straw attached... It's been ok for a few weeks although inevitably I know I'll have to fix it... Which I've read is a PITA lol.
     
    Black likes this.
  10. Black

    Black Member

    98
    12
    8
    Still the same it seems intermittent after starting the car second/third time seems fine It's driving me mad.

    Thanks

    Sent from my SM-G950F using Tapatalk
     
  11. silestanix

    silestanix Member

    72
    20
    8
    Ah, sorry it didn't solve your problem man... Think mine is on the way out so gonna pay audi a visit tomorrow and buy the door latch and stash it away, once it gets irritating I'm gonna change it lol.
     
  12. Avatar

    Google AdSense Advertisement


  13. Black

    Black Member

    98
    12
    8
    Hi guys, Update had it plugged in today

    Any suggestions ? [​IMG]

    Sent from my SM-G950F using Tapatalk