Roof not finishing cycle

B6S4cab

New Member
I got the dreaded pollen filter housing leak and fried my CCM module. I got a matching part and (series number) however the roof goes through it’s full open cycle no problem. When it closes the soft close works and it latches but the windows stay at the halfway position I can put the windows up manually. But it says roof not secure.

if I switch off the ignition for about 20 mins and it’s fine and the “soft top not secure” warning goes off and it’s fine.

I have done the manual reset countless times and to no avail
has anyone on here had the same problem?? Thanks
 

norris_309

Registered User
No idea if this is relevant, but is there a re-sync or re-initialise procedure for your roof and/or windows? (apologise if that's what you've already tried/meant by a reset)
Only suggesting as the Mrs has a cooper s convertible & it's been a bit odd in that the sunroof part retracts fine but then pressing & holding the button a second time, should retract the whole roof, but for some reason the first time you try it, it doesn't do anything bar lower the windows a bit, you then open the windows & try it & it then works? very odd.
I then read that after changing batteries/battery going flat you need to re-initialise the windows to ensure it all works correctly. (i changed the battery quite a long time ago, but we rarely use the car, so it's been sat for 6 months with me sometimes sticking it on charge!)
When the roof doesn't work right I initially thought it was the roof playing up but, if you opened the windows first the roof was fine so it's more an issue with the window position.
I have just been out & done ours & 'touch wood' it's worked first time when i tried it. (will try again later as no doubt i've spoken too soon!)
But good luck with it
 

AdamsDad

Registered User
I got the dreaded pollen filter housing leak and fried my CCM module. I got a matching part and (series number) however the roof goes through it’s full open cycle no problem. When it closes the soft close works and it latches but the windows stay at the halfway position I can put the windows up manually. But it says roof not secure.

if I switch off the ignition for about 20 mins and it’s fine and the “soft top not secure” warning goes off and it’s fine.

I have done the manual reset countless times and to no avail
has anyone on here had the same problem?? Thanks
Check vagpro - "convertible god" loads of info on his website , not sure if still here ? or contact him direct...
 
Top