RNSE MkII - CAN causes battery drain


Registered User
I have a battery drain in my 56 plate A4 B7, Quattro, BUL, S-Line, Special Edition. I believe it had RNSE in it from factory (inc phone prep but not BT), however, when I bought the car it had a no-name media/ICE unit fitted (seller told me the original RNSE was duff & put in this substitute). I put in RNSE (genuine Mk II, 193G, H/W 05, F/W at 0650), which caused a battery drain overnight, around 10 hours with car locked. I measured a draw of 2.5 - 3A with a clamp meter & so I did what others have done on numerous posts & pulled fuses 1 at a time. My timing on pulling fuses to monitor current draw was rubbish so I didn't get to see it stop as I didn’t let the car sleep after locking. I wasn't sure if pulling a particular fuse would wake something else up causing false measurements, so probably not really a sound method of investigation.

Turns out, after an investigation by a non-OEM auto electrician, it's RNSE causing the infotainment CAN bus network to wake up & drain the battery. As I understand it (reading the Bentley manual) B6 & B7 platforms don't have a dedicated CAN module & it's the instrument cluster that hosts the CAN gateway electronics.

So, the sequence of events was that, after locking the car, the modules would eventually go to sleep after around 15-20 mins & only the alarm system was running (about 60mA). After around 10 mins, the RNSE was waking up & triggering the CAN infotainment bus in the instrument cluster but considering the current draw, it might have triggered the drivetrain & convenience buses as well, although, I didn't go into whether these buses were being activated or analyse the data on it. Monitoring the routine, all modules went to sleep after a certain amount of time-out (15-20 mins) & then RNSE repeated the routine & woke the modules up again after about 10-15 mins.

Does anyone know if the CAN electronics on RNSE is a plug in module/daughter board that can be replaced or reflashed? If not, I'm not sure what to do about it as I can't find anyone who will look at this kind of fault. Most repairs are screens, buttons & disc drives, etc. Any ideas what could be causing CAN on RNSE to come alive every 10 mins - incorrect coding or wiring? When RNSE wakes up, would monitoring the data on the CAN Hi & Lo lines tell me what it's trying to do or what message it's sending out? Could it be the gateway itself waking up just because RNSE is connected? I think RNSE & the instrument cluster are coded correctly.


Registered User
I once coded my RNS-E for 'aux in' without it having one and that caused the battery to drain on my S3 8L overnight.

Did you re-code the RNS-E when you installed it?...if not,maybe it's coded for 'aux in' and you haven't got one?

I'm not familiar with your car platform...do you have CAN H + CAN L going into the back of the RNS-E on your model?


Registered User
Thanks for your your reply, tgc. Interesting that you had a drain because of RNS-E. I’ll have another scan to see if the aux is enabled. Yeah, I noticed that VCDS thought that it had the navigation DVD drive in the boot (there isn’t one) so kept reporting that it was at fault. I’ve coded it out & need to check what that does to the battery drain. I'm wondering if the instrument cluster or RNS-E keeps looking for it when the car is locked. When RNS-E is disconnected, the battery doesn’t drain so everything stays in sleep mode when locked. It may be that it only looks for the non-existent DVD drive when it can detect that RNS-E is on the CAN network.

The CAN lines are both present in the Quadlock (pins 9 & 10, I think). When I use sat-nav function, the directions appear in the instrument DIS,Es radio & media track data, so if that data runs through the CAN lines (I’m sure it does) then the CAN lines must be working.

You’re probably right - I think it’s a coding thing, unless the CAN function in RNS-E is corrupt/defective. I couldn’t find any coding settings for RNS-E in VCDS, other than the instrument cluster. I’ve just heard that a guy at my work has CAN analysing equipment so will monitor RNS-E & see if it’s sending out spurious messages.



Registered User
With mine,I coded it for 'AUX IN' without having one plugged into the RNS-E and it drained the battery overnight.The next day I coded out the 'AUX IN' and it was back to normal.I had read a few random posts online with people stating that the RNS-E would keep 'looking' for the 'AUX IN' and not shut down fully,causing battery drain,if there was not one plugged in.

Have a look at my install...there's a link to soft coding the RNS-E with VCDS...


After coding it is always advised to do a 'hard' reset on the RNS-E by holding the on/off button until you hear a 'pop' from the speakers.

Good luck mate.


Registered User
Thanks for the info, tcg. That’s some detailed right-ups you’ve done :icon thumright: I’ll post the results....


Registered User
There is no AUX option on RNS-E. I’ve been checking the unit on the bench & it works fine. It doesn’t come on when it wants to or do random things so Im guessung whatever causes the drain is not radio functions. The only thing I can’t confirm yet are the CAN messages.

This morning, the battery was completely dead again (no dash lights, relay clicks, nothing) after 2 1/2 days of it sitting there unused. I’ve had RNS-E disconnected for months & it has been starting ok as I have used it most days. I plugged it in about 2 weeks ago just to check it was still working & disconnected it again after about 20 mins. Having had to use the starting pack this morning to get to work, the battery is probably knackered now & don’t imagine it will ever run at original strength again (long term desulfation required).

Months ago, the auto electrician worked out that the current drain was going through fuse 15 (instrument cluster). He removed the radio, pulled the fuse & the battery didn’t drain any more. What he couldn’t work or was which module/circuit was the culprit. Was it RNS-E, instrument cluster, coding, CAN error. Since I’ve had RNS-E disconnected for so long, I think I can rule out that being the cause. I think I need to have a CAN sniffer to monitor the messages on the Infotainment bus but not sure I’ll be able to interpret what I find.

VCDS still says I’m fault free so I think that leaves me with coding & CAN issues.

I could fit a kill switch for fuse 15 but that’s cheating! Does anyone have any suggestions how I proceed (apart from her indoors who said ’scrap it or sell it’ :sadlike:)


Registered User
I’ve managed to stop RNS-E drawing current with the key out (I replaced the radio board but it wasn’t that). No, I didn’t drop-kick it over the fence Turns out it’s an Infotainment CAN issue.

With fuse 15 (mini fuse 10A instrument cluster) still in, I removed fuse 39 (20A radio) & put in a meter in its place to measure the current. It was drawing 3.4A at startup (key out) & once the CD changer finished it’s startup routine, the current settled at 2.3A.

I broke the radio circuit, remove fuse 15 & tried again - same result. Thinking it was an external thing to the radio but not the instrument cluster, I then tried removing blocks C & D (external connections for CD changer & speakers) from the quadlock & weirdly, it shut itself down to <2mA after 1m 112s. Something external stopped the radio drawing current - no idea what triggered it.

However, that turned out to be a one-time event as I couldn’t replicate it again so, assuming that it is a fluke, I put blocks C & D back into the quadlock & replaced fuse 15 - still the same draw.

Next was CAN bus. Everything is now back to factory fit & I removed the high & low wires from the quadlock- pins 9 & 10. Closing the radio power circuit with the meter, I got the same startup routine & current draw as before but this time the current dropped off to about 1mA after about 25-30s. I tried again with the key turned to light up the cluster & I got the same result, so I’m assuming that nothing else other than the CAN Infotainment high & low wires control power to the radio. Only the power button on the radio can toggle power.

So, do I have a CAN hardware issue in the cluster or have I got bad coding somewhere? Could someone please check their coding to see if mine is right.

Instrument coding 0007408
Nav coding 0319157

RNSE mk2
Telephone (not used so coded out)
CD changer

TCG - I was wrong before & don’t have software 0650 - it says 0220 but managed to enable AUX by changing nav coding to XXXXX5X from 2. I don’t have any issue with the non-OEM bluetooth module I’ve just installed. Did you get the battery issue sorted with your AUX? The signal left, signal right & signal gnd are all connected to the Aux block (pins 6, 21 & 22) & the module is powered by tapping off pins 13 & 14 on block D (u14 DSP & DWA gnd) so it’s only on when the radio is on.


Registered User
Ok, I was having another look at this pita fault. For the last few weeks, I've had the can bus high & low wires out of the quadlock so that there's no power control from the key / door locking or any info on the DIS. I took them out as they were keeping the radio powered up (screen off but still drawing the current). I checked the coding today & channel 62 on the CAN Infotainment bus has changed from 23 to 5, but I took 2 off the value to code out the telephone months ago, not 18. Now that I've put the can bus wires back into the quadlock, I was expecting to see the usual current draw but it's all working now. I monitored the current on fuse 39 (Fluke in place of fuse) & after about 30s the current dropped off to 1-2mA.

Does anyone know what the ' +16 = Instrument Cluster (Standard - only coded with 2nd Component)' option is for? I can't find any info on it but it seems to have cured my current draw problem. I tried all the options one after the other, giving time to watch what happens (locking the car, then unlocking & lighting up the dash. Then with the key out & car open, then lock the car again). At every stage, the current drops off as it's supposed to. I'm going to have another look at this later as I'm finding it hard to believe that this has sorted it.



Registered User
Back to its old tricks again this morning so recoding the Infotainment bus didn't work. :wtf: The coding hasn't changed. I swore a lot then went to work. Thinking that maybe there was a dodgy connection or broken wiring somewhere, I took the cluster off this evening & resistance checked the CAN wires between the quadlock & the blue cluster connector (T32, pins 19 & 20), which all checked out ok. The only thing I can think of now is to replace the cluster in case there's a fault with it. VCDS reports that all is well with no faults on Info bus.

After a few tests again this evening, it's doing a thing I've seen once before, where after about 30 or 40s it drops from the 2.2A to about 0.25A then drops to about 20mA 1 or 2 seconds later, then it starts flicking back to 0.25A then 20mA. It flicks every second continuously. Something is pulsing & I can't see what's doing it. The current dropped to zero once when I took out pins 6 & 12 (Tel NF In + & -) but now I can't repeat it. One connector at a time, I've had the Fakra connectors off, then the C connector, then the B connector until it's only the CAN wires & the +12 & ground left connected, but it still does it. I'll see if I can get it to repeat the pulsing thing & then pull the CAN wires to see if it stops. If it does, then I can only think it'll be the cluster.

Anyone willing to post their coding for radio/nav & cluster to make sure I've got it right? My option sticker says I've got 7Q2. Audi won't tell me what radio unit the car came with & that I "would have to book it in" if I want that information, so they want to charge me just to say what radio it was.

Anyone heard of a cluster having a CAN fault?


Registered User
Anyone had a chance to look at their nav/radio coding for RNSE? Could do with the cluster coding & channel 62 (infotainment). Changing the cluster will have to be a last resort as I’ve been reading that it’s a costly option (recode immobilizer, etc at Audi so £££). Do you know anyone on ASN who could help with this?