RNS-E retrofitters, need a little help with speed signal

Ashy>>

Registered User
Evening all.

I retrofitted a RNS-E from a 2008 A4 cabriolet into my 2003 s3 at weekend.
Bought loom adapter from eBay along with the gps aerial and aerial adapter.

Fitting went well and I coded it in as an A6 with the addition of Bose.

Thought that was that as I had the Navigation locate my house straight away and it was showing in my clocks after I coded them.

Unfortunately it looks like I need the speed / gala wire from the dashboard as the Navigation doesn't track me when I'm driving, just updates when I stop at junctions . So I'm guessing it doesn't know I'm moving.
Another thing is the direction never changes on the compass but I'm guessing this is part of the same issue.

I know there are bits of guides knocking around and I've read that many my head is pickled, I just want a definitive picture / explanation from someone who has done this before of where to connect the speed wire from and where to connect it to.

Hopefully someone can help me out

Thanks Adam
 

Ashy>>

Registered User
IMG_20180422_204524_070.jpg
 
Your car has no CAN signal but these sat/nav are working with can !
All the problems woth retrofitting them in older cars are because of that.
7 years ago i found in Germany (ebay) can-simulator which is look like your quad connector but has additional can simulator and that resolve all my troubles in the A4 B5 with Rns-e !
My backlight on the nav weren’t on and every 30 mins the sat nav switch itself off.
The only trouble is the only place in the world is that ebay seller from Germany and they cost ~£50 .
I hope that will resolve your problem

IMG_1499.JPG



Audi S4 lover
 

Ashy>>

Registered User
Can works as it's the late facelift s3 so have already got the display in my MFD and backlight and adjustable illumination works perfectly. Just need a separate feed for the speed signal.

I pretty sure I knwk where to take it from but where I put it to is where I'm struggling
 

tcg

Registered User
I'm looking into this at present for my 2003 S3.With mine,and I would think it it the same as yours,so you need to tap into the GALA wire from the dash clocks.

The blue plug at the back of the dash clocks has a green/white wire in pin 31,that is the speed signal.You need to solder a wire to that one and connect it to the V.signal pin (B3) on your RNS-E.

I will do a write up on mine when it is done but won't be for a couple of weeks.
 

Ashy>>

Registered User
Was just in the middle of it when you messaged me.

Correct it's pin 31 on the blue connector behind the clocks and it goes to pin 3 on the b connection on the RNS-E.

It's working perfectly now.

That's a weight off my mind
 

AGB-S3

Registered User
I'm looking into this at present for my 2003 S3.With mine,and I would think it it the same as yours,so you need to tap into the GALA wire from the dash clocks.

The blue plug at the back of the dash clocks has a green/white wire in pin 31,that is the speed signal.You need to solder a wire to that one and connect it to the V.signal pin (B3) on your RNS-E.

I will do a write up on mine when it is done but won't be for a couple of weeks.

Did that ever happen ?
 

AGB-S3

Registered User
Ah .. Missed the hyper text link ..
thats some project - may be the phone 'sat nav in the cup holder is not so bad after all .. for now
in 2021 , one of the aftermarket devices look tempting ?
 
Top