Reversing lights constantly on and parking sensor constantly beeping

Slinger

Registered User
Has just happened this afternoon, anyone any ideas how to fix / whats causing it? My wife needs the car for her work and need to try and get it sorted tonight if at all possible. Damn car is starting to get on my nerves now after the drivers window regulator going at the weekend :(

thanks.
 

Cabbyfan

Registered User
might eb a silly question but is it a sticking selector switch in the gearbox ? The rear parking sensors are usually triggered by the reverse lights being on....
 

Slinger

Registered User
I suppose it could be but the sensors have been playing up recently giving a constant tone rather than beeping, it was always fine when first using the car but then started with the problem after a while of driving. There was a bit of a downpour this afternoon according to the wife and when she has come home this evening she told me that the reversing lights were stuck on and the parking aid beeper was constantly on.

Is there any way to disconnect the reversing lights altogether?
 

Mike B

Registered User
I suppose it could be but the sensors have been playing up recently giving a constant tone rather than beeping, it was always fine when first using the car but then started with the problem after a while of driving. There was a bit of a downpour this afternoon according to the wife and when she has come home this evening she told me that the reversing lights were stuck on and the parking aid beeper was constantly on.

Is there any way to disconnect the reversing lights altogether?
Take the bulbs out or maybe a fuse.Has the water flooded the battery chamber?
 

Slinger

Registered User
No there's no water there that I can see. I've now booked it in with the garage for first thing in the morning. I get really annoyed that such a reliable good car can be spoiled by such **** electrics.
 

quattro tony

Registered User
Hopefully its just a faulty reverse light switch, I wouldn't be too hard on the audi, there are cars with worse electrics and probs out there , ( french cars )
 

Turkster

W.Bro.Paul 2.0d Q5 Quattro

Woorlord

shifting to Hyperspace... .
VCDS Map User
Assuming you have manual gearbox it is a simple switch for the reversing lights / reverse sensors.
Auto boxes are a little more complicated as signal comes from Transmission control unit next to Engine ECU.

My bet is the switch - easy enough to test on manual - red/blue wire - T17f/Pin 9 [Orange Connector - A-pillar left]
 

Les dee

Registered User
Ive got the same problem but have been told that the gearbox on my A4 2.5 tdi 180 sport Quattro V6
will have to be "Dropped"to access the switch and remove from the Top of the gearbox.
Is this for real,thats a big job for a £10 switch.
 

T0m

Registered User
I was kinda hoping my switch was faulty as when i engauge reverse my front parking sensor activate and randomly beep telling me something is there when there is not, im going to swap out the control module to see if that solves it so fingers crossed.....
 

Woorlord

shifting to Hyperspace... .
VCDS Map User
As per post #9 test the switch for continuity - such a simple test before swapping out modules.
 

T0m

Registered User
My bet is the switch - easy enough to test on manual - red/blue wire - T17f/Pin 9 [Orange Connector - A-pillar left]
I will test the switch later but I need to know where it is ha ha is it a simple case of taking off the gear leaver surround and its there? Only issue I have is the problem with mine is with the front sensors only wouldnt the switch just engage the front and rear together then the module would control the fronts and rears depending on if there was anything there?
 

Woorlord

shifting to Hyperspace... .
VCDS Map User
I will test the switch later but I need to know where it is ha ha is it a simple case of taking off the gear leaver surround and its there? Only issue I have is the problem with mine is with the front sensors only wouldnt the switch just engage the front and rear together then the module would control the fronts and rears depending on if there was anything there?

There are a bank of connectors at the foot of the A-pillar (left) behind the kick panel.
red/blue wire - T17f/Pin 9 [Orange Connector]
Test for voltage which should be zero/(floating) when Neutral or any other forward gear selected and +12v when reverse selected.

Your problem does sound like a faulty parking sensor or control module.
 

pauldazzle

Registered User
Did this get fixed? I have the same problem on my car.
 

T0m

Registered User
Dunno fella havent actually tested it yet sorry, need to though as its getting on my wick now ha ha
 

pauldazzle

Registered User
I had a new reverse light switch fitted today, & it fixed the problem.:icon_thumright:
 

ASHIHARA

Registered User
How difficult was to replace the switch?,coz i have the same problem.
 

pauldazzle

Registered User
The switch is located on the drivers side of the gearbox. With the car on a ramp it took 2 mins to do. Reverse lights & parking sensors now work perfectly.
 

Jolepatrol

Registered User
My reverse lights would cycle on when I got water in my ECU box under the ECU. After I dried out the water it eventually stopped, but I too started having problems after a harsh rain.
 

Woody1*

Registered User
I have been reading this thread, I have an audi A6 2010 avant, manual, had the car jet washed on Sunday, then few hours later same problem reverse lights constantly on and the parking sensors wont turn of when driving, on a motorway it beeps passing big vehicles and the display shows the reverse camera as the car thinks its in reverse mode, could this be the same problem the switch?
 
Top