Q5 Retrofitted Virtual Cockpit - now audi connect doesnt work?

bob808

New Member
Alex from VAGCarCoding did a great job installing a Virtual Console I pickup up from ebay. When the install was done, we realised that despite by 2017 Q5 having tech pack, the MMI2 head unit didnt have the green connector for the virtual cockpit... Alex sourced one for me at a good price and all was working great, and I still had working online update and audi connect functionality... This is where I realised it wasnt connected to my account so (stupidly in hindsight) linked it to my 10 digit code... that didnt work so I did a factory reset... bingo and it now worked with my 10 digit code... The audi is now linked to me as the primary user, I could see i in the myaudi app and this is when my issues started!

Problem is, now no data component is working... if I try to enable satellite maps, it says there is no data service and to insert a sim or take it to a dealer. If I go to settings and online update it just says unavailable. Even if I put my own simcard in, it sees this but even if I then select satellite maps or online update I still get an error saying the service isnt available.

Any ideas what I did when I factory reset the MIB2 that has caused the issue and what I can do? I still have my old MIB2, could try putting that back in and seeing if it then works... although if I swap it over it will not show the maps on the VC as it doesnt have the green connector so isnt a great long term fix. I have tried to unlink the primary user, I keep getting emails saying its done, but the car isnt removing that link... a factory reset keeps it there also.
 

bob808

New Member
Just a quick update, I swapped back the head units and the old one still has online functionality... interestingly it offers google earth view rather than satellite view, but this does seem to work still, and the online update offers map downloads etc... so this does appear to be an issue with the head unit - any idea how I can hard-reset it to see if that works? Factory resetting it still remembers me as the primary user (the old head unit doesnt)
 

AlS3BE

Registered User
Sounds like Audi connect features and your subscription is linked to the device, most likely imei number in your old MMI unit and not to your myAudi account.
 

bob808

New Member
Yep… is that something that can be coded though or would Audi need to do it… will they likely even entertain this on a non factory retrofit?
 

AlS3BE

Registered User
Yep… is that something that can be coded though or would Audi need to do it… will they likely even entertain this on a non factory retrofit?
Imei number is stuck with a device and can’t be easily or legally changed over if it’s locked to that. It’s part of the 3G/4g modem.
it’s like a serial number. Doubt Audi can code it either as normally if your device fails they would replace it with like for like and the Audi mothership will be updated with the new device and all will work like old. You’ve done a retrofit so your device won’t be the same as the original so doubt they would entertain it.
Maybe something @DJAlix can sort out. As I said it’s only my hunch that it’s all locked to the imei number. Could be something else.
 
Top