1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Retrofit Rear View Camera to Audi A4 2017 B9

Mark Whitby Feb 22, 2019

  1. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    Evening all,

    Hoping someone can assist or point in me in the direction of where I can get some required information.

    I'm planning to retrofit the OEM rear view camera to my 2017 Audi A4 B9 (Saloon), I've found the camera and the loom, however I'm really struggling to find any information on coding to activate it within the system... I've got OBDEleven with the Pro license on it's way as I'll be using this to activate the Lane Assist.

    My car is the S-Line Black Edition 2.0 TDi (with AdBlue) and I really regret not getting the camera from day dot, I've got the front and rear sensors, but just feel it's missing the rear view.

    Does anyone have the coding instructions to get the rear camera working?

    Thanks in advance for any assistance.

    Mark

    Sent from my SM-N960F using Tapatalk
     
  2. Avatar

    Google AdSense Advertisement


  3. DaveM

    DaveM Member

    55
    12
    8
    Mark Whitby likes this.
  4. bluebarchetta

    bluebarchetta Member

    45
    17
    8
    I fitted mine using the k-electronic loom and coding dongle.

    It was not straight forward, the instructions didn’t quite work - the pins you had to connect too were different on a RHD car to the LHD instructions. Also I thought I’d be able to code it using my VCDS but I could not do the camera parameters - hence getting the k-electronic dongle.

    The CAN-bus control units you need to connect to differ if you’ve a petrol or diesel too... Mine (petrol) was the one under the rear seat and the navigation system which you get to by taking the glove box out.
     
    Last edited: Feb 22, 2019
  5. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    Thanks for your reply.

    Is there any chance you can share the instructions you have?

    Cheers

    Sent from my SM-N960F using Tapatalk
     
  6. bluebarchetta

    bluebarchetta Member

    45
    17
    8
    I’m sorry the instructions I’ve got are a combination of the copyrighted k-electronic instructions and lots of emails with their tech support.

    If you’ve not already bought the loom you could get it from k-electronic (or Kauftec etc) and get the instructions for a diesel saloon and their technical support.

    It took 3 weekends and various auto scans which I shared with them to get it working.

    I’ve fitted several cameras before but this was the hardest. I would not want to try without someone more competent than me.
     
  7. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    No problem, I've paid for access to Erwin today and downloaded everything for my car, I'm now very confident with the installation.

    Now just need to find the correct oem rear camera for my car.

    Sent from my SM-N960F using Tapatalk
     
  8. PhilM

    PhilM New Member Team Navarra Audi S4

    19
    22
    3
    Please do a write up!

    I’m hoping to find a B9 with it already from the factory - we shall see, there’s other spec more important!

    I retrofitted reverse cam to my B8 S4 and it was a piece of cake....hope this one isn’t too much harder!
     
    Jonny_T2002 and WesT-gefül like this.
  9. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    Will do my best to get pictures and do a write up which hopefully will aid anyone in future. Probably won't won't be for a few weeks, well at least until I've got the camera and loom

    Sent from my SM-N960F using Tapatalk
     
  10. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    I've finally finished the installation and all is working perfectly.

    Sadly didnt manage to take pictures as I went along as I was battling against the weather.

    But it was a particularly hard job, just fiddly and time consuming. But what helped was having the Erwin manuals for removing the necessary panels, with that they came of a piece of cake, so that was £8 well spend for an hours access (just downloaded everything).

    I brought my genuine camera with loom from an Ebay seller for a bargain £220, he coded it for my VIN so once I installed all I had to do was make two adaptations and add the control module to the gateway. In all it probably took me 8-10 hours but I was being overly cautious, if I was doing it again I'd have all the parts to hand and know how the panels come off, so reckon could easily half that.

    I was wanting to keep everything neat and as close to oem as possible so I installed the power into it's appropriate fuse location in the rear fuse box (require the VW fuse terminal to crimp on), and run the loom along the main wiring harness, so the only wires I ended up crimping were the PIN 12 and PIN 30 under the rear seat and for these I used so nice look dual connectors as pictured.

    I'm happy to provide guidance and assistance to anyone taking the task on, I would just recommend a dry day.

    Cheers

    Mark 20190309_082702.jpeg 20190309_082558.jpeg

    Sent from my SM-N960F using Tapatalk
     
    LukeHawk and cuke2u like this.
  11. Jonny_T2002

    Jonny_T2002 New Member

    2
    0
    1
    Hi Mark,

    Really appreciate this! If you’ve got info on the camera and loom part numbers and ANY other info on the installation process it would be really appreciated.

    I’ve got an A4 S-Line with the larger MMI and Cockpit, is that a similar setup to yours?
     
  12. Avatar

    Google AdSense Advertisement


  13. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    Check out my other post, it has all the links for the bits I brought.

    http://www.vwaudiforum.co.uk/forum/showthread.php?p=1103726

    Mine is the A4 2017 B9 S-Line Black Edition with Tech Pack so same setup with MMI screen and VC.

    Drop the Ebay seller a message win your VIN and he we confirm if the camera I linked to is the correct one.

    Cheers

    Sent from my SM-N960F using Tapatalk
     
    Kondax and Jonny_T2002 like this.
  14. Jonny_T2002

    Jonny_T2002 New Member

    2
    0
    1
    Legend! Thanks for your help. Any further info is hugely appreciated as I’m completely new to this :)
     
  15. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    Thanks for the info Mark. I quite fancy a project so I'll have to look into doing this. £210 for the camera is an absolute steal. I assume you have the lines adapt to your steering position on the camera overlay?
     
  16. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    Correct, provided the camera is coded your your VIN and your make the two code adaptations it shows the steering input with curved lines.

    Sent from my SM-N960F using Tapatalk
     
  17. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    Perfect. Thanks for the installation info, that will be a massive help.
     
  18. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    Just ordered all the pieces you mentioned Mark, I'll let you all know how it goes once I receive the camera
     
  19. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    Cool, drop me a message if you get stuck and I'll try my best to assist.

    Sent from my SM-N960F using Tapatalk
     
    Kondax likes this.
  20. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    Hey Mark, do you have a rough idea of where I can find the appropriate files regarding installing the camera on Erwin? Can't seem to find much relating to rear camera / reverse camera unless I'm looking in the wrong place

    Edit: downloaded the current flow diagram relating to the rear view camera, think I might be able to figure it out..
     
    Last edited: May 14, 2019
  21. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    There isn't a installation guide fro. Them just wiring diagrams, but just download everything they have on you vehicle so you can refer to it if needed, I found the wiring diagrams and the panel removals the most useful... oh and the car handbook for the correct fuse location if you are wiring into the cars fuse box (I'd recommend this as keeps it neat and looks professional)

    Sent from my SM-N960F using Tapatalk
     
    Kondax likes this.
  22. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    Yeah thanks, I think I managed to find everything I needed. Camera is scheduled to be delivered Friday, so hopefully I'll be able to install it over the weekend. Just to confirm, fuses are 7.5A?
     
  23. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    I used 5 amp and no issues

    Sent from my SM-N960F using Tapatalk
     
    Kondax likes this.
  24. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    Apologies for the questions, this is my first time taking on such a project haha.

    If I'm correct, the below photo is J533 (the controller underneath the rear seat?), and that I need to splice into B670 CAN HIGH and B671 CAN LOW (pins 12 and 30 on the plug)? Or should I make the connection in the A-Pillar?

    The camera is due to be delivered until Friday, but I thought I'd take the time to dig through the car to get a rough idea of where things will be going

    [​IMG]
     
  25. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    Yeah correct that's the controller directly under the centre rear seat towards the back. Those pin numbers sound right but just double check the wiring diagrams from ErWin, do a search for J533 or rear reversing camera. It'll confirm the pin numbers and also the colours of the cables to all you to double check.

    Also will you're doing the wiring its wise to disconnect the battery just to be safe.

    I spliced into the the cables under the seat as tiring to find them anywhere else will be like a needle on a hay stack as they are bunched in the loom and other cables are similar colours.
    I also carefully cut back some of the loom tape to allow me to splice in to the cable a little bit away from the large plug as it's all very tight.

    But just take your time and don't rush and just triple check everything :)

    Sent from my SM-N960F using Tapatalk
     
    Kondax likes this.
  26. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    Perfect! Thanks a ton Mark. I'll let you know how I get on at the weekend.
     
  27. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    Seems as though the coding instructors didn't come with my camera Mark, do you happen to have your copy laying around somewhere that you could take a photo of?
     
  28. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    11,077
    4,306
    113
    Kondax likes this.
  29. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
  30. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    Did you purchase the camera from the link I posted and ask the seller to code it to your VIN?

    That's what mine was and then after the install I just did the two adaptations and all worked.


    Sent from my SM-N960F using Tapatalk
     
  31. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    I did but it didn't come with coding instructions
     
  32. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    These are the adaptations, just do the two 5F adaptations and apply them.

    What are you using to make the changes? OBDEleven?

    If you've made the two adaptation and you still aren't getting the steering input, are you certain you provided your VIN to the seller and ask for the camera to be pre coded for your car?

    If not you will most likely need to calibrate it, but you will need someone with VAG-COM I believe Screenshot_20190518-175343_Adobe Acrobat.jpg

    Sent from my SM-N960F using Tapatalk
     
  33. Avatar

    Google AdSense Advertisement


  34. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    Looks like those adaptions are already what I've done, but I'll have to double check the long coding. I did it with VCDS.

    Yeah, I definitely provided my VIN. I'm fairly certain the camera would show an error if it wasn't pre-calibrated.

    The steering input shows up on the sensors overlay, just not the camera. I couldn't find anything in the 6C channel that would change it though.
     
  35. Mark Whitby

    Mark Whitby New Member

    24
    9
    3
    Double check the coding as mine has the steering input in the camera and the sensors view which is on the right of the screen.

    Might be worth checking the connections to the CAN HIGH and LOW, not sure if they could cause the issue if the connections arent fully made.

    Can you see the Camera Module in VCDS?

    Sent from my SM-N960F using Tapatalk
     
  36. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    I'll have to check tomorrow, I'm knacked from today haha.

    I can check the connections but I'll doubt there will be any issues there. If they weren't made properly I assume the camera wouldn't work at all. I used the same T shaped joiners as you.

    Yeah, camera module shows in VCDS
     
  37. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    Hmm yeah something is definitely up with the camera. The picture quality is absolutely shocking and doesn't even begin to resemble any stock installations in terms of quality. I highly doubt it's a signal degradation issue as that shouldn't cause low resolution and the wiring to the MMI unit has no kinks or sharp bends. Also, the reverse camera lines not working with the coding as you mentioned.

    I'm having doubts over whether or not the camera is actually OEM or a Chinese knock-off. I'm starting to believe it's the latter.

    I'm going to take a look at the coding again today, but this resolution is definitely an issue. It's not like I can return it now that it has been fitted either. I wonder if I can just find a different camera unit that will work with the existing wiring I've ran.
     
  38. Kondax

    Kondax Active Member Team Glacier Audi S4 Black Edition

    538
    181
    43
    Another bug with the rear view camera that I'm noticing: the CarPlay view is no longer working after the reverse camera comes up - clicking on CarPlay doesn't do anything. Audio still works if it was already playing through CarPlay though.
     

Share This Page