1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Replacing steering wheel buttons

davidbir Nov 26, 2017

  1. pinut

    pinut Registered User

    31
    4
    8
    did u reset your MMI after selecting that?

    when u press the (*) button, the MMI will display the mode accordingly...

    btw it seems like you are using a previous gen cable... thats why you cant see the description..
    am i correct to say that you are using the hex-can cable?
     
  2. Avatar

    snack-media
    Advertisement


  3. Niklas_SP1

    Niklas_SP1 Registered User

    13
    0
    1
    Yes, I did reset the MMI by pressing the NAV/MAP (or CAR) + RADIO + "big knob" buttons in the console. But I will try do it the hard way by releasing the battery. I have had reset issues before when the modem and SIM card for the Audi Connect service stopped working, and had to do it by the battery.

    You are right about the cable. I have had my unlimited HEX cable for a while and should buy a new cable since I cannot access module 46 (central convenience) with my old cable. The module 17 accepted the code, so that was a plus. But it would have been nice if it shows what part I was coding...
     
  4. pinut

    pinut Registered User

    31
    4
    8
    let me get to my car tomorrow morning and show u the entire VCDS screen that i see...
    its midnight now at my part of the world...

    LOL
     
  5. pinut

    pinut Registered User

    31
    4
    8
    as promised, this is how it look like...
    refer to the attached pictures...
     

    Attached Files:

  6. Niklas_SP1

    Niklas_SP1 Registered User

    13
    0
    1
    Thank you. I will have to see if it will appear after resetting the MMI by removing the battery.
    I do not have the label file 8W5-920-770-A in my VCDS installation 20.4.2. And I downloaded the latest just some days ago. **EXP** means that you are using some "experimental" label file.
    Could you send the file 8W5-920-770-A.clb (or what its called) to me?
    You should find it in the folder C:\Ross-Tech\VCDS\Labels\User
     
  7. pinut

    pinut Registered User

    31
    4
    8
    exp is only available if u are using the newer ross-tech cables... the hex-net version...
     
  8. Niklas_SP1

    Niklas_SP1 Registered User

    13
    0
    1
    No luck for me with the * button. I have checked the coding, and for the unit 17 (Instrument) byte 10 bit 7 is set to "ticked" (as shown in previous picture). And I now have released the battery to make sure te MMI is resetted. But still no meny is showing.
    I may dig into this deeper later on. Maybe upgrade my VCDS cable before continuing.

    Thank you for all your help.
     
  9. pinut

    pinut Registered User

    31
    4
    8
    what is your mmi player part number?
     
  10. Niklas_SP1

    Niklas_SP1 Registered User

    13
    0
    1
    The "instruments" (address 17) that we are coding is 8W5 920 771 A.
    The "information electr." (address 5F) is 8W0 035 183 L. And has subsystem 1 (display unit) 8W0 919 604, and subsystem 2 (multimedia operating unit) 8W0 919 614 N.
    For 5F I get an error saying that [New feature! Extended UDS fault detail is only supported by current gen. interfaces]. So I guess my old VCDS cable cant manage this unit.

    I also can see that the CAN gateway (address 19) holds a subsystem called Multi function steering wheel control module. Maybee something should be looked at in that mudule.
    * Edit: The subsystem module has identified the new buttons and displays the new part number 8W0 951 523 F (not D as the stock buttons with fewer buttons).
     
    Last edited: Aug 5, 2020
  11. pinut

    pinut Registered User

    31
    4
    8
    8W0 035 183
    this is the exact same part number as my current player...
    mine is just missing the L.

    i have the same display unit and multi-media operating unit as you...

    so that is why i am curious as to why you cant enable that while i can....
     
  12. Avatar

    snack-media
    Advertisement


  13. pinut

    pinut Registered User

    31
    4
    8
    8W0 035 183
    this is the exact same part number as my current player...
    only minus the L

    your display unit and multimedia operating unit is exactly the same as mine...

    from your edit, i guess you got it working?
     
  14. Avatar

    snack-media
    Advertisement


  15. Niklas_SP1

    Niklas_SP1 Registered User

    13
    0
    1
    No, I didnt. I just saw that VCDS and the car has aknowledged the button-sets.

    I will try to reset back to stock value and try again. I have downloaded the latest VCDS software from Ross-Tech.
    I am a little blind without the lable files in my VCDS installation. Just seeing bytes and bits and no explanation what they are.
     
  16. Bulldog

    Bulldog Registered User

    846
    663
    93
  17. Archer-Stirling

    Archer-Stirling Registered User

    26
    21
    3
    Fitted and worked perfectly
     
    Bulldog likes this.
  18. Niklas_SP1

    Niklas_SP1 Registered User

    13
    0
    1
    Hi. Me again. I have not tried to fix the * button yet sice I probably need a newer VCDS cable for that module. But I have done the thing that was the goal for changing the button-set in the steering wheel. To enable the map between the gauges.
    And enabling the Navigation made the Nav button in the steering wheel have its function. So only the * button is not working.
     

    Attached Files:

    Last edited: Sep 26, 2020
  19. jefaz07

    jefaz07 Registered User

    27
    5
    3
    How did you get your map in between the instrument dials to be the same as the MMI?


    Sent from my iPhone using Tapatalk
     
  20. Niklas_SP1

    Niklas_SP1 Registered User

    13
    0
    1
    I coded the 5F module (Information Electronics) according to this picture.
    But... you must have the "plus" buttons on your steering wheel so you can choose to show the map in the left menu, as picture
    map-button-left.jpg in my latest post were showing (Karta = Map in Swedish).
     

    Attached Files:

  21. pinut

    pinut Registered User

    31
    4
    8
    your mmi comes with navigation enabled from the factory?
     
  22. Niklas_SP1

    Niklas_SP1 Registered User

    13
    0
    1
    No. But it had the Connectivity package (connect safety and service, smartphone interface) and the Technical package (phone box for wireless charging, and outside antennas for phone and GPS) so it was prepared for navigation in the hardware. Even the display showed MMI Navigation (before updating) when starting the car, and the upper left button in the center console said Nav/Map (instead of just Car if you dont have those packages). Here in Sweden we dont have the "prestige" and so on models. Just a base Audi and then the first byer chooses from a lot of (expensive) packages.
    But as in true Audi fashion even with the button and the MMI showing the Navigation text at startup it still wasn´t activated if you didn´t buy the car with the cockpit and big MMI screen. So I went to the Audi dealer and got it activated for a huge amount of money. The price was $1100, but I got a discount because they ordered the wrong software from Germany, so I "only" payed $900.
    And Yes, I know that I could use my phone as navigation since I have the smartphone interface (Android Auto and Apple CarPlay). But I still wanted the real Audi navigation activated.
     

    Attached Files:

  23. pinut

    pinut Registered User

    31
    4
    8
    have u got the * button working?

    if not do give this a try..

    Adjustments to information electronics 1
    Car_Function_Adaptions_Gen2:
    menu_display-MFL_jocker_over_threshold_high: activated
    menu_display_jocker: activated
     
  24. Niklas_SP1

    Niklas_SP1 Registered User

    13
    0
    1
    I finally got around to try this. And it worked.
    Thank you!
     

    Attached Files:

Share This Page

Do Not Sell My Personal Information