Rear Washer not washing - trying to identify fault.

Jonfun

2016 A4 Avant B9 190 Quattro S-Line
Hi All

As the title suggests I'm at a bit of a loss with this one, and hopeful one of my fellow B9 owners could shed some light.

My rear wiper washer isn't jetting water as it should, I've removed the cover from the wiper arm and washer jet and still with these removed when activating the washer the water doesn't jet out of the bolt as I hoped it would.

I've also removed the inner boot covers behind the rear lights to inspect for water, and also removed the waring triangle to inspect the tailgate ... and cant see any obvious evidence of escaped water.

The pump is functioning when I push the stork forward so I know it's trying, but it's justnot making it way to the rear wiper.

Might there be any other common issues with these, or likely that the hose is split elsewhere on the vehicle? ..the water is surely going somewhere.

I'd really appreciate any support on this one.

Thanks all
Jon
 

AlS3BE

Registered User
Most likely some crud is blocking the pipe somewhere from washer bottle to rear jet.
ive also had in the past cheap screen wash coagulating turning into a gel like consistency along the pipes and pump.
maybe try flushing it through with warm water
 

pagenotfound

Registered User
Funny, had the same earlier in the month. Hadn't washed the car for a while due to a hosepipe ban and car went in for MOT. Garage does complimentary healthcheck and finds rear wiper jets not working and offers to fix for £120. I say no thanks, I'll take a look myself instead. Find that fluid is coming out of the reversing camera nozzle so know that no blockage in the pipe. Found a syringe and flushed out the nozzles on the wiper then got the mrs to activate the washers while I put a finger over the camera nozzle just to get maximum pressure and all was good. Some crud got blasted out of the wiper jets and no further issues. Took 5 mins and 4 mins of that was finding the syringe.
 

AlS3BE

Registered User
Funny, had the same earlier in the month. Hadn't washed the car for a while due to a hosepipe ban and car went in for MOT. Garage does complimentary healthcheck and finds rear wiper jets not working and offers to fix for £120. I say no thanks, I'll take a look myself instead. Find that fluid is coming out of the reversing camera nozzle so know that no blockage in the pipe. Found a syringe and flushed out the nozzles on the wiper then got the mrs to activate the washers while I put a finger over the camera nozzle just to get maximum pressure and all was good. Some crud got blasted out of the wiper jets and no further issues. Took 5 mins and 4 mins of that was finding the syringe.
Never thought about using a syringe.
good tip:icon thumright:
 

Jonfun

2016 A4 Avant B9 190 Quattro S-Line
Thanks all for the comments,

Unfortunately I dont have a rear facing camera and I'm kind of out of ideas.

Got the car booked in at the dealer on Thursday to see if it can be sorted under my 'All Component' Extended warranty, no doubt they'll say it's not covered or some $h1T .. but worth a go, and hopefully if it is something obvious (to them) they will just sort it for me.

Will follow up later in the week.

Thanks again.
 
Top