Rattling front end - strut or wheel bearings?

PanamaS3

Registered User
Wondering if anyone else has experienced their front strut bearings and/or wheel bearings going (maybe after a pothole hit?). Had heard/read somewhere from an aftermarket shop that it was common for the front strut mount bearings to go early on these cars....can't understand why.
I hit a big pothole 2 years ago which gave me a puncture but didn't dent the wheel. After fixing the tyre I had no problems....but I have always had a slight rattle from the front end over uneven road surfaces. I decided at some point I was going to replace all the suspension and in the mentime the rattle got worse. I replaced my shocks and springs 9 months ago and at the same time all the mounts and bearings because I kept hearing a rattle at the front end. It never went away and recently got a lot worse so I had it into the garage and the front right strut bearings had to be swapped back to OEM (from the 034 Street density ones I put on with new suspension). Now....2 weeks later and I am hearing the rattle again (in fact it never really went just was a lot quieter after changing strut bearings). So now I'm thinking it might be combination of wheel bearings and some problem causing the strut mounts to go.....sorry for such a long description, advice/help needed please!

I went to the doctor with a steering wheel attached to my crotch and the doctor said "well well....what have we got here then?", and i said "I dunno doctor, but its driving me nuts!"
 

PanamaS3

Registered User
EDIT: I had front strut mount and bearing put back to OEM. Seemed great at first but still hearing the rattle over small bumps.
 
Top