1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Radio 56 - No response from controller!

Nick Clarke May 23, 2015

  1. Nick Clarke

    Nick Clarke Member

    37
    3
    8
    Hi guys,

    I have an a3 8l facelift and I have just put in a symphony 2 a4 radio in it as I couldn't find a decent a3 one. I have just gone to recode it with my vcds cable and it won't seem to communicate with it. Strange as it is working as it should (can bus working correctly) other than it turns off when the engine is turned off, not when the key is removed.

    May be a separate issue (and probably is) but I recently had the car remapped at AMD Essex and this is the first time I have used VCDS since then. It now won't seem to communicate with any of the controllers unless the engine is running? But will not communicate with the radio at all as previously stated.

    Any thoughts as to why this might be?

    Nick.
     
  2. Avatar

    Google AdSense Advertisement


  3. Nick Clarke

    Nick Clarke Member

    37
    3
    8
    Anyone??
     
  4. B5NUT

    B5NUT Well-Known Member TFSI Owners Group VCDS Map User Audi A6 Audi A3 Audi Avant Owner Group quattro S tronic S-line owners group

    4,365
    938
    113
    A4 units expect diagnostic via k-line, and may not respond to diagnostic via can-bus. May be worth plugging the unit into an A4 and see if you can recode the unit for an A3 (diagnostic via can-bus)
     
  5. Stashio

    Stashio New Member

    6
    0
    1
    All Concert II radio's use k-line so the chances are you need to move yours to a different location on the plug that goes in the back of the radio. I had to move mine to different location recently as I changed my Concert II to RNS-e.

    It needs to be in C7 - chances are it isn't (or is loose) which is why VCDS isn't communicating with the radio. Swap it over and it'll work great - you'll need to do some dective work to figure out which location it's in currently through.

    Here's the guide I used for RNS-e - you'll want the original k-wire location obviously: http://web.archive.org/web/20130601...b7-a4-diy-symphony-ii-rns-e-installation.html
     
  6. aqibi2000

    aqibi2000 Active Member

    368
    52
    28
    CAN not K-Line
     
  7. ch1z64

    ch1z64 C'mon you's bhoy's in Green TFSI Owners Group Silver Supporter Team Sprint Audi S3 Manual

    2,178
    444
    83
    If i mind right in the blue block there should be a grey wire which i think is in pin 5 which is the K- line . But check the pin diagram on top off your head unit and you should be able to see what pins are in which bocks and what there there for and if you need to move any .
    Unplug quadlock press down on blue block clip slide out off quadlock then look at the front off blue block and you will see numbers just check they pins correspond with the diagram on top .
     
  8. aqibi2000

    aqibi2000 Active Member

    368
    52
    28
    CAN is used to sleep or wake the head units not K Line☺️

    You need to put a fixed 12v into the Quadlock DI SENS, and UB+. Make sure CAN is connected and the ground. That’s it. Done.
     
  9. ch1z64

    ch1z64 C'mon you's bhoy's in Green TFSI Owners Group Silver Supporter Team Sprint Audi S3 Manual

    2,178
    444
    83
    Op is talking about his vcd's not commnicating with module 56 not about when it switches off , well thats my understanding off his original post or have i missed something .
    :redface new::redface new:
     
  10. aqibi2000

    aqibi2000 Active Member

    368
    52
    28
    Think I've misinterpreted his post lol

    To me he has wired power to it incorrectly (he has incorrectly connected IGN Switched 12V) hence why it's switching off via Engine off - Audi uses CAN message to send a message when key removed to put H.U to sleep.

    If wired Correctly to the Quadlock where the CAN isn't working, it would remain switched on 100% of the time as it is only powered from a Battery + feed.
    1. So firstly he needs to address the incorrect Power connection.
    2. Confirm if CANH and CANL are correctly connected and in the Gateway Module that Analog Radio is enabled.
    • Have you tried the VCDS cable with the car on Ignition? What happens when you try?
     
    Last edited: Mar 27, 2018

Share This Page