1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Q7 Q7 heater issues

sean mckenzie Oct 24, 2018

  1. sean mckenzie

    sean mckenzie New Member

    12
    1
    3
    Hello recently just discovered my q7 heater isnt getting hot and only blowing out tepid air rather than hot air so its annoying the last few mornings when its been abit icey on the windscreen

    Its a 2008 3.0d sline quattro

    Iv put it down to my thermostat even though i havent had any over heating issues or anything odd , it happily stays on 90

    Has anybody else on this forum had this issue and what way did you tackle it?:thumbs up:
     
  2. Avatar

    Google AdSense Advertisement


  3. Tashfeen

    Tashfeen S4 - the smile per mile machine! Team Glacier TFSI Owners Group Team V6 VCDS Map User Supercharged Team Scuba Audi S4 Audi A3 Black Edition quattro

    5,046
    10,648
    113
    Not me personally but a few threads elsewhere with similar issue. Blower motor it appears is the main issue here

    https://www.audiworld.com/forums/q7-discussion-112/aux-heater-problem-2878027/

    https://www.audiforums.com/forum/audi-q7-66/heating-problem-179885/




    Sent from my iPhone using Tapatalk
     
    Sandra likes this.
  4. sean mckenzie

    sean mckenzie New Member

    12
    1
    3
    How can you be so sure its the blower motor?
     
  5. sean mckenzie

    sean mckenzie New Member

    12
    1
    3
    My heater stays working full blast whether it be 5mins or an hour and still only blows out tepid air , im sure if it was the blower motor wouldnt the heater blower die down after 10 20 seconds as described......
     
    Tashfeen likes this.
  6. Tashfeen

    Tashfeen S4 - the smile per mile machine! Team Glacier TFSI Owners Group Team V6 VCDS Map User Supercharged Team Scuba Audi S4 Audi A3 Black Edition quattro

    5,046
    10,648
    113
    A friend has a 2009 Q7 with exactly the same issue where the heater wasn't working. His is diagnosed with the blower motor. It also appears to be an issue on a lot of other Audi variants as well for example A4 B8s.


    Sent from my iPhone using Tapatalk
     
  7. sean mckenzie

    sean mckenzie New Member

    12
    1
    3
    My heater is working tashfeen, its just not blowing warm air.... this is why i think its something to do with me thermostat failing ??
     
  8. Tashfeen

    Tashfeen S4 - the smile per mile machine! Team Glacier TFSI Owners Group Team V6 VCDS Map User Supercharged Team Scuba Audi S4 Audi A3 Black Edition quattro

    5,046
    10,648
    113
    My apologies as I didn't read the post properly. If it the thermostat then you are right that you'll have either engine overheating issue or it will run cooler with a check engine light. Are your coolant levels OK? It can also be flap motor not moving. I'd suggest you take to an indy to have a diagnostic and find out the exact reason.


    Sent from my iPhone using Tapatalk
     
    sean mckenzie likes this.
  9. sean mckenzie

    sean mckenzie New Member

    12
    1
    3
    If a thermostat is stuck in the closed position it will never allow coolant to circulate fully and that leads to no heat im not a mechanic but i just know basic things your right im going to get a indy to have a look
    I also thought the flap thing but id have to have some bad luck for all of them to be jammed lol il be back soon with an answer lol hopefully its not expensive
     

Share This Page