1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Problems with Magnetic ride / suspension

kaspar Sep 18, 2018

  1. kaspar

    kaspar Member

    100
    20
    18
    hi

    Im having problems with my magnetic ride on my S3.

    Last year i changed the stock springs to the H&R lowering springs, and everything was good as soon as the springs had settled. until about 2-3 months ago.

    I got my Wagner IC installed. The next day driving the car home from the shop. (all they did was change the IC) it felt like the suspension wasnt working / absorbing anything. bad / uneven roads is REALLY bad, its bad for me as a driver, but even worse for passengers. especially for passengers in the back seats.

    Im still wondering how changing the IC, can effect the suspension? :huh:

    I went to audi a few weeks back. hoping a magnetic ride calibration would help. it felt like it did, for about 10 minutes, then it was back to being undriveable again.

    Today i went back to them, in hope for some clarification. All they did was drive my car for a few minutes, then determined that it drove like it was supposed to, and nothing was wrong. from what i know, they havnt worked on a S3 with magnetic ride before.

    Do anyone know the procedure when calibrating the magnetic ride on a S3 8p?

    I for a fact know that something is wrong, and my cars suspension is nowhere near how it used to be.

    I did consider going back to stock springs front & back. just to see if it would solve my problem.

    let me know if you need any info about the car.

    i need advice, so i can get my S3 back, and drive like it used to :sorry:
     
  2. Avatar

    snack-media
    Advertisement


  3. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter VCDS Map User Team Sprint Audi S3 Manual

    3,860
    823
    113

Share This Page

Do Not Sell My Personal Information