PRNDS Flashing: Audi A3 3.2 V6 DSG HELP!!!

scott_johnson

Registered User
Chaps,

I need someones expertise to help rectify an ongoing problem.

My car is currently with Andrew from Autograph Cars (site sponsor).

As stated in the title, the car has a gearbox fault and flashes 'PRNDS' and has no drive / selects neutral intermittently. It will drive for 2 minutes then do the same thing.. Turn the ignition off and on and will solve the problem for another 2 minutes!

The Mechatronic ECU was sent off for testing and came back with NO FAULTS!

Does anyone know what else it could be? I've been told there's a switch under the gear lever that can go faulty?

Andrew was going to explore the oil pressure to the clutches next...

Im tearing my hair out with this and has already cost me £££'s to be back at square one!

Any help is hugely appreciated!!

Thanks in advance

Scott
 
Last edited:

Jason-3.2

Registered User
Try cleaning the switch, bits of fluff and dust get under the gear selector causing it not to know which position its in. If cleaning the area doesn't help look at changing the switch just to rule that out.
 

scott_johnson

Registered User
Anyone else have the same issue?

Ive searched high and low for answers and everyone seems to have different issues / symptoms.

How likely is it that the gearbox itself is faulty?

It was due a gearbox oil change at 40k. This wasn't done until I bought the car at 68k. Should this cause any problems?
 

Paullie

Banana Menace!
VCDS Map User
Hi there, I've heard of this problem with the mechatronics unit being stuck in N and flashing PRNDS and looking at some stuff online it looks like it could either be in need of a re-flash of the DSG ECU or it could be caused by a faulty temperature sensor. I believe Audi America did a recall and also extended the warranty of the DSG units. Unfortunately there was no such action by VW/Audi in the UK. Have a look at this page, it's very informative with regard to the DSG.

VW Audi DSG S-tronic FAQ with common DSG problems, the sensor recall, and video reviews


I found this just about half way down.

Temp sensor recall

"On Aug 2009, VW started a recall on 2009 and 2010 DSG on the temperature sensor. Models affected are built between August and September 2009. A faulty temperature sensor can result in illuminated warning lamps in the dashboard and the transmission may shift into neutral. It appears that both sensors below are in the same assembly. This is probably responsible for some of the flashing "PRNDS shift light" incidents."

Hope this helps. :wub: Paula xx
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
The microswitch under the lever when in park can cause issues as above, it will present a fault log usually, so scan & check for error, if so then its a new gear unit needed, about £400 for the part, pita to remove/fit.
 

stephen mackay

Registered User
I read you said the mechatronics tested ok.
These sorts of thing can happen if the temp sensor in the box is faulty.

02E927770M 02E927770M[

yes ive read that too .......problem started when i jump started someone and blew a fuse next to the battery ....Put a new fuse in, car runs ok exept when in manual techtronic..Where its not reponding up and down the gears correctly.

Had the system checked/diagnosed .......came back as faulty microswitch
 
Top