1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Pioneer head unit - static when connecting iphone/ weak FM signal

Tatey35 Nov 18, 2018

  1. Tatey35

    Tatey35 2011 A3 2.0 TDI Black Edition

    45
    27
    18
    Hi all

    Yesterday I had a new pioneer SPH-DA230 DAB+ headunit fitted to my 2011 A3 by DynamicSounds. It's a black edition will full bose set up. I had it fitted as I didn't feel comfortable doing it myself and didn't want to be without a radio if things went wrong... however still got a few issues.

    It was fitted with this kit from dynamic sounds: https://www.dynamicsounds.co.uk/aud...scia-steering-bose-retention-fitting-kit.html

    I'm currently experiencing 2 problems, that I hoped someone with more knowledge might be able to help with!

    1. Iphone connection creating static - The primary reason I wanted the head unit was for Apple Carplay.

    However, when plugging in my iphone 8 via a lightning cable to the usb adapater, I suddenly get a large amount of interference/static through the speakers, which is really making it unusable as I can hear it over any music/radio played.

    The static stops when removing the phone from the cable. I've tried a different lightning cable and phone both with no difference.

    Anyone know what is causing this?

    As I understand it the SPH DA-230 only has 1 usb connection in the back, so I can't try another usb port.


    2. DAB radio is a bit patchy (probably due to the location I live and the internal glass mounted aerial) - I can live with the fact that DAB won't be perfect and wasn't expecting it to - but my FM radio is currently worse than it was before.

    From a bit of research, it looks as if the fitting kit bundle might have used been a single fakra to single din adapter for the FM aerial? But my if my car is a 2011, it probably has the dual fakra connection?

    If I swapped it for the following adapter... would it help the FM signal?
    https://www.dynamicsounds.co.uk/connects2-ct27aa86-universal-twin-fakra-to-iso-antenna-adaptor.html


    I'd really appreciate any input as my knowledge around this is very limited! This is the first time ever changing a headunit. Thanks!
     
  2. Avatar

    snack-media
    Advertisement


  3. maxpayne

    maxpayne Registered User

    1,021
    219
    63
    Have you spoken to Dynamic Sounds?
    They should really own up and fix any issues as fitters and provider of the the fitting kit!
     
  4. Tatey35

    Tatey35 2011 A3 2.0 TDI Black Edition

    45
    27
    18
    Not yet, as there closed sundays.

    I’m going to ring tomorrow, but I wanted to understand the issue a bit more, so I actually know what I’m talking about when I ring them!

    It’s also a decent drive to dynamic sounds so if there’s something I can try myself first that would be preferable. Had it installed by them as I was in the area over the weekend and heard good things.
     
  5. maxpayne

    maxpayne Registered User

    1,021
    219
    63
    Did you manage to sort out the issues at the end?
    Ironically I’ll be installing a Pioneer CarPlay unit myself soon enough!
     
  6. Tatey35

    Tatey35 2011 A3 2.0 TDI Black Edition

    45
    27
    18
    Yeah so managed to fix the static - signal was being over-amplified so any input that creates noise was really noticeable. Just had to adjust the screws on a box that is part of the connects2 wiring harness. This got rid of the static - still ever so slightly there but not noticeable to anyone else or when I'm driving.

    DAB signal I think I'm just going to give up on - it works in the city but anywhere outside it just drops out to often. From what other people have said doesn't look like i'll get it any better without an external aerial.

    FM Signal - It's not as bad as I originally thought but not perfect. Having finally got time to take the unit out, turns out they installed a single fakra connector...

    2.jpg


    So I've ordered a dual fakra to din connector which will hopefully sort it. Will update you when I've got it installed.

    Apple Carplay and Waze works a dream though so problems were worth it.
     
  7. donovan2123

    donovan2123 Member VCDS Map User

    155
    19
    18
    Did you just have system muted or volume on 0 and turn screws until static/white noise disappeared?

    Was it all the screws or just one in particular

    Sent from my SM-G960F using Tapatalk
     

Share This Page

Do Not Sell My Personal Information