1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Permanent failure | faultcodes S4 B9

Rogier140 Jan 1, 2019

  1. Rogier140

    Rogier140 Active Member TeamMisano Team V6 Team Sepang Audi S3 Audi S4

    173
    77
    28
    Hi all,

    I drive a audi S4 B9 (2017). It is an full option car from Germany.
    The car had of and on fault issues with several systems. Also during driving sometimes a drivetrain failure pops up. When restarting the car or leave it for a day the faults were gone.

    I went to the dealer to adress these issues. They said the have no record of others having simulair issues.
    They updated the Canbus software. That resultet in permanet failure of all the systems, even when restarting.

    Are some of you having the same with the B9 platform ?

    [​IMG]
    [​IMG]
     
  2. Avatar

    Google AdSense Advertisement


  3. Rogier140

    Rogier140 Active Member TeamMisano Team V6 Team Sepang Audi S3 Audi S4

    173
    77
    28
    Vagcom scan

    [​IMG]
    [​IMG]
     
  4. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    11,824
    4,784
    113
    From the look of those warning lights I'd say the car should not be driven. Call out Audi Assist, I'm assuming you have this in Germany, and have the car recovered to a dealership. Then refuse to accept it back until all issues are resolved...
     
    WesT-gefül likes this.
  5. WesT-gefül

    WesT-gefül Well-Known Member Bronze Supporter

    820
    272
    63
    Crazy. Hopefully you get this sorted.
     
  6. Rogier140

    Rogier140 Active Member TeamMisano Team V6 Team Sepang Audi S3 Audi S4

    173
    77
    28
    Crazy indeed. I got the car like this from the dealer without warning.

    I needed to disassemble the aftermarket alarm first before they go further. The alarm wasn’t connected at the Canbus at all....

    It is going back to the dealer tomorrow again.

    Im from Holland btw
     
  7. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    11,824
    4,784
    113
    You are sure it's not the aftermarket alarm causing this then?
     
  8. Rogier140

    Rogier140 Active Member TeamMisano Team V6 Team Sepang Audi S3 Audi S4

    173
    77
    28
    No installed by a pro and used one like this on an other car. It does not even have any connection to canbus. It only uses power.
     
    Last edited: Jan 1, 2019
    cuke2u likes this.
  9. Dippy

    Dippy Well-Known Member Team Monsoon Audi S5 Black Edition

    1,784
    1,256
    113
    No dealer ever has any record of any fault ever happening on any other car. Audi's are perfect. If you car has a fault then the fault is yours.

    Seriously though in your place I'd be considering rejecting the car.
     
  10. RJ-8V

    RJ-8V Active Member Team Daytona Audi A3 S-line owners group

    633
    161
    43
    Solved already?

    Al opgelost? Stuur me anders even een PM.
     
  11. Filipão

    Filipão Active Member Audi S4

    173
    95
    28
    Rogier, I've had 3 times the "Differential" fault combined with an "Electrical".

    Goes away when restarting.

    My car same as yours, with Ingolstadt plates (from factory).
     
    Last edited by a moderator: Jan 5, 2019
  12. Avatar

    Google AdSense Advertisement


  13. WesT-gefül

    WesT-gefül Well-Known Member Bronze Supporter

    820
    272
    63
    Not always a great idea to put up your VIN publicly, but it’s your car.
     
    cuke2u likes this.
  14. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    11,824
    4,784
    113
  15. WesT-gefül

    WesT-gefül Well-Known Member Bronze Supporter

    820
    272
    63
    True. It’s on the glass. Same reason most of us remove our number plates from photos.
     
    cuke2u likes this.
  16. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    11,824
    4,784
    113
    Quite...
     
  17. Dippy

    Dippy Well-Known Member Team Monsoon Audi S5 Black Edition

    1,784
    1,256
    113
    So who knows of a genuine risk to publicising license and/or VIN?
     
  18. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    11,824
    4,784
    113
    https://www.google.co.uk/search?sou...i10i30j0i13i10i30j0i13i30j0i22i30.wINwOoLsKnQ

    I read an article where a owner had been sent tickets for all kinds of things amounting to thousands of pounds, just because his plates had been cloned. It is well known that car thieves can cloned VIN number and matching number plates and put them on identical vehicles.
    https://www.google.co.uk/search?ei=...3i13i21j33i160j33i10i21j33i10i160.a2fyJb_jLuA

    It may never happen, but there is no harm in just being cautious.
     
    WesT-gefül likes this.
  19. Sandra

    Sandra Administrator Staff Member Administrator TeamMisano TFSI Owners Group Audi S3 quattro Platinum Supporter S tronic Audi Main Dealer

    31,185
    14,079
    113
    Vin number removed
     
    cuke2u likes this.
  20. Rogier140

    Rogier140 Active Member TeamMisano Team V6 Team Sepang Audi S3 Audi S4

    173
    77
    28
    Well I got the car back from the dealer. They updated the controller software and all faults cleared.
     
    cuke2u likes this.
  21. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    11,824
    4,784
    113
    Fingers crossed it's sorted, time will tell...
     
  22. Filipão

    Filipão Active Member Audi S4

    173
    95
    28
    Thank you all, specially @Sandra
     
  23. Sandra

    Sandra Administrator Staff Member Administrator TeamMisano TFSI Owners Group Audi S3 quattro Platinum Supporter S tronic Audi Main Dealer

    31,185
    14,079
    113
    You welcome
     
  24. Filipão

    Filipão Active Member Audi S4

    173
    95
    28
    Lady and Gents. and specially @Rogier140:

    Today I had the same, out of the blues at aprox. 50mph diff + electrical fault = 2 first pictures.

    Pulled over and idling was at 1000rpm = 3rd. picture.

    Switched off ignition for 1 second, then switched on and all faults gone. Idling back to normal 600rpm = 4th picture.

    2019.01.07 IMG_8600.jpg 2019.01.07 IMG_8601.jpg 2019.01.07 IMG_8605 .jpg 2019.01.07 IMG_8606 .jpg
     

    Attached Files:

  25. Rogier140

    Rogier140 Active Member TeamMisano Team V6 Team Sepang Audi S3 Audi S4

    173
    77
    28
    Opgelost en is inmiddels wet terug op de “normale” manier....
    Bij starten alles foute boel .... even later herstarten en probleem is weer weg .....
     
  26. RJ-8V

    RJ-8V Active Member Team Daytona Audi A3 S-line owners group

    633
    161
    43
    Ben dan benieuwd welk software update zij uitgevoerd hebben. Toevallig een lograpport van je auto?

    A3 8V Facelift Limousine
     
  27. Rogier140

    Rogier140 Active Member TeamMisano Team V6 Team Sepang Audi S3 Audi S4

    173
    77
    28
     
  28. Rogier140

    Rogier140 Active Member TeamMisano Team V6 Team Sepang Audi S3 Audi S4

    173
    77
    28
    Nee helaas . Ze hebben eerst een canbus update gedaan waardoor ik permanent de foutmelding had. Afgelopen week hebben ze een update gedaan op het regelapparaat waardoor de foutmeldingen weer verwijderd konden worden en alles weer met elkaar communiceert. Nu heb ik eeer de normale situatie dat met regelmaat foutmeldingen optreden en weer weg zijn bij een herstart .
    Werk je bij een dealer ?
     

Share This Page