1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

P0016 code

Lee1976pr Nov 4, 2019

  1. Lee1976pr

    Lee1976pr New Member

    9
    2
    3
    help me please guys.

    My car drove to work perfectly this morning but when I left to come home it felt like it took longer to start and like it had a misfire. I thought it was a
    N injector as I have done a couple of them now. After driving for a few mins it felt better. I got nearly home and popped into the shop and when I came out it took forever to start and had no go in it whatsoever and was running really badly. I then took the uncomfortable journey home at 5 mph (normally a w min trip from the shop, it took me half an hour).

    When I got home I plugged my cheep obd reader and it threw up P000a then changed to P0016 camshaft position sensor.

    Is this an easy fix or is the car now dead?

    It is a 2007 Audi A3 1.8 tfsi.
     
  2. Avatar

    snack-media
    Advertisement


  3. Grey_Man

    Grey_Man Member

    40
    29
    18
    If it’s only the camshaft sensor that’s gone, it will just need replacing, if your camshaft is out of alignment, then that could be costly.


    Sent from my iPhone using Tapatalk
     
  4. Lee1976pr

    Lee1976pr New Member

    9
    2
    3
    Thanks Grey_Man.

    Hope it is just the sensor. Is it a job I could take on myself? Where is it located? I’m not afraid of getting my hands dirty. I’ve worked on many cars in the past including engine out jobs on much older cars but this is my first Audi so I’m not too sure about all the modern things on it.
     
  5. Grey_Man

    Grey_Man Member

    40
    29
    18
    Never done one myself, have a look on YouTube some decent vids on it there.


    Sent from my iPhone using Tapatalk
     

Share This Page

Do Not Sell My Personal Information