Non starting B7 - linked to instrument cluster?

Rosco2010

Registered User
Hi folks,

Just had to rejoin as couldn't for the life of me remember my log-on details!

Used my 2007 A4 2.0 TDi Avant at weekend with no problems, and just went out today and won't start.

Initially the remote central locking worked to open the car, then when I put ignition on, I noticed nearly all of the dash lights weren't coming on. Tried to start and car fired up, then died after a few seconds.

Tried disconnecting battery but hasn't helped, in fact the remote central locking is no longer working!! I notice the radio is in 'safe' mode also.

Is this pointing to an immobiliser fault? Have done a few searches and appears that there is a common issue within the instrument cluster although more seen on A3's? I have also seen that there are place you can send the cluster off to, to be repaired?

Any feedback, advice or similar stories welcome!

Thanks
Ross
 

Rosco2010

Registered User
I haven't mate, I did think the current battery was sounding a bit tired but a heavy duty jump pack today made no difference.

I'm up in Falkirk, Scotland.
 

Jasesapphy

Active Member
VCDS Map User
I had the same on BMW tried a jump pack made no difference,
Put on a new battery all was fine
Can you just borrow one and check basics first
 

aragorn

"Stick a V8 in it!"
Staff member
Moderator
VCDS Map User
The immobiliser is in the instrument cluster. If its not powering up you'll get the start-cutout symptom.

Check fuses, and check the footwells for water.
 

Rosco2010

Registered User
Cheers Jase will give it a try.

Aragorn - all fuses seem ok and no signs of water or even damp in foot wells. We have had very heavy rain here recently but inside of car is bone dry.

It's pointing to the immobiliser unit within cluster. Removed clocks last night and think I've found a local guy to take a look.
 

@udi A3

Well-Known Member
VCDS Map User
Bosch clusters in a4s are very finicky. They are easy to program a second hand set in though.
 

Rosco2010

Registered User
Thanks for your reply - I assume you mean by programming that it is 'aligned' to the car ie ecu and keys etc?
 

Rosco2010

Registered User
Just thought I would update this, in case it helps fellow owners.

Turned out there was 2 x cracked solder joints on the canbus pins within the instrument cluster. A chap I know repaired these, and then all was well. He also ran VAGCOM to make sure all errors codes were cleared and no other ones present.

He said it was a common fault and fixed plenty in his time. Good to know if you have a similar issue.

Thanks for all the help.

Rosco
 
Top