1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New oil pump?

CroftyOriginal Aug 2, 2018

  1. CroftyOriginal

    CroftyOriginal Member

    50
    3
    8
    Iv read a few thread on this but my cars been running fine, its on 91k miles, a bit ticky but I know thats normal on the 2.0 TFSI, I went to get a stage 1 and on the 4th gear pull the car threw up an oil pressure light, which obviously they aborted the re map, I thought it could be the oil pressure switch so I changed that and it solved it, been diving around for a week with no issues so I went back to get the remap done, which again the 4th gear pull threw up the oil pressure light again, I know the oil pumps are a bit of a problem but before I got spending God knows how much on a new oil pump, is there anything else I can check or do before splashing out?
     
  2. Avatar

    Google AdSense Advertisement


  3. Metalsmurf

    Metalsmurf Member Team Dolphin Grey TFSI Owners Group Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    62
    24
    8
    Oil pick up pipe?

    Sent from my SM-G955F using Tapatalk
     
  4. CroftyOriginal

    CroftyOriginal Member

    50
    3
    8
    I gonna bite the bullet and get it booked in and see whats going on. Im hoping its just the pick up though.
     
    Metalsmurf likes this.
  5. CroftyOriginal

    CroftyOriginal Member

    50
    3
    8
    So turns out you cant actually buy just the balance shaft for the tfsi, which means its going to be the £1200 whole oil pump assembly.... But then I found the KMB balance shaft delete kit which is £378, would that be a better way to go?
     
  6. Metalsmurf

    Metalsmurf Member Team Dolphin Grey TFSI Owners Group Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    62
    24
    8
    I would just delete it if I were you, apparently the vibration aren't that bad.

    Sent from my SM-G955F using Tapatalk
     

Share This Page