1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

New A7 review 4 months in....disappointing.

Wippers Mar 24, 2019

  1. Wippers

    Wippers Active Member

    118
    63
    28
    Ok so I’ve had the A7 50TDI now for four months and covered 5k mileage. Having owned many Audi models over the last 19 years this one is definitely the worst for a number of reasons. although there are some redeeming features.

    These are the bad bits first:

    1. The pre-sense has a mind of its own and kicks in on open roads with no obstacles to be seen. Doesn’t feel safe.

    2. The gearbox is woeful. Absolutely awful. I really don’t know what Audi we’re thinking when they passed this as acceptable. Horrendous lag when pulling out of junctions and cogs down when you don’t want it to. Mine clunks into first sometimes with a huge jolt too.

    3. I expected the creaks and rattles to be ironed out by now but I get quite a few.

    4. The satnav doesn’t appear to know what the number 1 is choose matter how I write it on the lower touch screen.

    5. The satnav has reset itself without warning losing all my saved addresses. No idea why.



    And the good bits:

    1. The interior is beautifully designed with all the functions very easy to use and intuitive. The temperature touch slider works really well and doesn’t distract from the driving.

    2. The B&O sound system is a huge (and I mean huge) improvement on the Bose system I had in my previous A7. Plenty of bass too.

    3. Although not specific to the A7, the virtual dashboard with Google Maps is excellent and really easy to view whilst driving.


    The car has been into more than one Audi dealerships to sort out the faults with varying results. Still not got everything sorted yet.
    It’s quite sad but I’m already looking forward to getting into a new car in a couple of years. Not sure after 19 years of Audi ownership that it will last into the next choice.


    Sent from my iPhone using Tapatalk
     
    koolkul and h1r4 like this.
  2. Avatar

    snack-media
    Advertisement


  3. Alan Wylie

    Alan Wylie New Member

    3
    0
    1
    You seem to have had more than your fair share of problems. I also have the same model and although I have experienced one incident when the pre-sense kicked in for no apparent reason and from time to time, I get various electronic error messages relating to the lighting system,i’m More than happy with the car. It really is well put together. The one negative is indeed the gearbox. The lag is annoying and often results in faster accelerating than you need as my right foot tries to ‘encourage’ movement. I’m currently enquiring about upgrading the ECU to try and resolve the issue.
    Good luck with your issues.
     
  4. Wippers

    Wippers Active Member

    118
    63
    28
    Thanks Alan. Let me know how you get on with the ECU for the gearbox issue. I've had a control ECU replaced for the pre-sense issue so hopefully that will resolve the problem but it's unerving driving waiting for it to happen again. I expected better from Audi to be honest. My last A7 was a far better car in all but the interior.
     
  5. h1r4

    h1r4 Active Member

    303
    178
    43
    You're not on your own there, mines been 6 times to Audi and 4 times its stayed there for rattles and creaks! Which has been escalated to Audi UK (also 4 months in)

    It's a very nice car but it's also very disappointing aswell. It's meant to be on of their top cars and with the problems you've stated and I've had it doesnt feel like one.
     
    Wippers likes this.
  6. Wippers

    Wippers Active Member

    118
    63
    28
    I agree. It’s a nice car ruined by the woeful gearbox and pre-sense problems.
    Mine’s also been bumped whilst in the deee car park. Only a small few scuffs but it’s now for to go back I again to have this sorted.


    Sent from my iPhone using Tapatalk
     
    h1r4 likes this.
  7. cuke2u

    cuke2u Well-Known Member TFSI Owners Group S-line owners group saloon Audi A4

    12,187
    4,986
    113
    It would be a gearbox tcu update that will fix the lag, however it's mote point, some can live with the lag, I could. Set the presence to late and the issues will mostly vanish and be less than intrusive and you'll get used to it.
    It is a life and car saver...
     
  8. h1r4

    h1r4 Active Member

    303
    178
    43
    I have a tcu on my A7, it helped but not a significant amount.
     
  9. Wippers

    Wippers Active Member

    118
    63
    28
    I have the pre-sense set at it lowest and it’s still kicked in a few times.
    I’m hoping Audi will up with a software fix for the gearbox and sometime soon. I’m just not enjoying driving the car which is a first for me with Audi.


    Sent from my iPhone using Tapatalk
     
    h1r4 likes this.
  10. cuke2u

    cuke2u Well-Known Member TFSI Owners Group S-line owners group saloon Audi A4

    12,187
    4,986
    113
    Does yours have the zf8 gearbox, eight speed? I thought some owners of other Audi models with the same gearbox were stating that there was a gearbox update.
    Pre-sense will always kick in sometimes, but it isn't perfect and it cannot replace that of a human brain, however it may only make the audible warning if it senses you are in control. However, in my experience, it is definitely a car saver and I'd much rather every car on the road had it.
     
  11. h1r4

    h1r4 Active Member

    303
    178
    43
    I have the Zf8, my cars been sat in Audi the last two weeks. They haven't mentioned a software update for the gearbox
     
  12. Avatar

    snack-media
    Advertisement


  13. gtiller

    gtiller Active Member TeamMisano Audi S3 A7 Owner Group

    179
    41
    28
    @Wippers I'm six months and 12k miles in on the same spec car.

    Your summary applies exactly to me too... other than the fact that my drivers side window also rolls down on a semi regular basis as well as everything else.

    Gearbox is the most upsetting aspect, as I know how good the ZF8 can be. To me, the lag ruins a car that could otherwise be outstanding to drive.
     
  14. Wippers

    Wippers Active Member

    118
    63
    28
    Yes this is the 8 speed box. My previous A7 had the 7 speed which was fine. I had the car in to Audi a week or so a go and it had a software update but this hasn't done anything. It's still poor. The pre-sense is a great idea in principle but I believe it's been rushed into the cars before the technology is good enough. It's one thing showing a red warning light or alarm alert but heavily applying the brakes on a clear open road makes for very nervy driving.
     
    h1r4 likes this.
  15. Wippers

    Wippers Active Member

    118
    63
    28
    Mine's apparently had a software update for the gearbox but it's made absolutely no difference.

    Thankfully not had any window issues (yet) but I agree that the lag riuns what could be a really good car (apart from the pre-sense problem).
     
    h1r4 likes this.
  16. cuke2u

    cuke2u Well-Known Member TFSI Owners Group S-line owners group saloon Audi A4

    12,187
    4,986
    113
  17. lpjn

    lpjn New Member Team Daytona S-line owners group A7 Owner Group

    23
    12
    3
    Hey! You should try DTE’s pedal box, it attaches to the wiring on the acceleration pedal and doesn’t touch the engine, so don’t worry about warranty voiding.

    I also have a 50 TDI and am giving it a go later this week after being recommended by a friend
     
  18. Wippers

    Wippers Active Member

    118
    63
    28
    I've heard mixed reviews about the pedal boxes so will be interesting to see how well it works.
     
  19. cuke2u

    cuke2u Well-Known Member TFSI Owners Group S-line owners group saloon Audi A4

    12,187
    4,986
    113
    A tcu tuning box has also given positive results for those who find the lag unbearable..
     
  20. A7Vorsprung

    A7Vorsprung Member

    31
    19
    8
    I can tell from experience that the pedal box will solve the lag issue.
    No matter what people say to explain why it shouldn't, trial proves them wrong.
    I've used it for a year in a jaguar diesel. Whenever I switched to stock by the pedal box button, I wonder how was I able to drive the car that way.
     
  21. koolkul

    koolkul Member Team Ibis Sportback TFSI Owners Group Team V6 S-line owners group A7 Owner Group

    50
    10
    8
    Totally agree on all those issues, except gearbox issues as I have the 55TFSI with 7 speed box.
    The note about it not recognising the figure 1 made me chuckle.. I regularly get warnings that central locking has failed, handbrake has failed, presense not working due to visibility issues- these all disappeared after turning the car off then on again. Mostly these appear to be software glitches.
    Also annoying is when I have gearbox in economy mode and it resets to drive mode every time is turn the ignition off - non of theses issues in my previous generation A7.
    Still love the car though.


    Sent from my iPhone using Tapatalk
     
  22. DaveW

    DaveW Well-Known Member Team Floret Silver S-line owners group Audi A6 Audi Avant Owner Group

    1,345
    622
    113
    Happens on my A6 C8 40Tdi as well...
     
  23. h1r4

    h1r4 Active Member

    303
    178
    43
    Wippers do you have a dash rattle by any chance like mine?
     
  24. A7Vorsprung

    A7Vorsprung Member

    31
    19
    8
    I have a question. Would the a7 with driving assists drive into a wall or would it stop?
    I parked my car facing a wall. The auto hold was engaged. I started checking the menus and settings, then I though that I was in P rather than D, so started revving, then the parking sensors started beeping, I managed to press the break pedal before I touch the wall. Would the car stop had I not pressed the brake pedal?
    I've seen a video in YouTube about the A8, and it stops itself before obstacles.
     
  25. Sheroo

    Sheroo New Member

    14
    2
    3
    I've had the fuel flap solenoid issue, got it replaced under warranty. Got the 55 as well so no lag issues, also been lucky with the rattles so far. I get the odd glitch but seems to disappear when switched on/off.
     
  26. Wippers

    Wippers Active Member

    118
    63
    28
    I get an annoying clicking noise from the centre speaker cover under the windscreen but other than that not too bad.
     
  27. Dam0

    Dam0 New Member

    20
    12
    3
    have you taken your A7 in for an update recently? I had a few of these issues and an update certainly cleared the random error messages. I still get pre-sense randomly popup up for no reason though.
     
  28. koolkul

    koolkul Member Team Ibis Sportback TFSI Owners Group Team V6 S-line owners group A7 Owner Group

    50
    10
    8
    Hey Dam0, not recently, I kind of gave up taking it back for these irritating issues because if the dealer could not reproduce them they just wasted a day and handed the car back to me so it was really just a wasted effort. My pictures of the errors did not count. Sometimes they agreed but could not do anything about it. So unless it is a major issue I won’t bother but will just bring those other things up as I take a pic when it happens. I even had the boot come down on my head when I had been told the boot would not open if I was close to the car!?!
    I would imagine these are software glitches that should easily be sorted with an update, not sure the dealers understand the huge difference in the amount of software in the new A7 vs the old one. Hey ho, still a nice car


    Sent from my iPhone using Tapatalk
     
  29. gtiller

    gtiller Active Member TeamMisano Audi S3 A7 Owner Group

    179
    41
    28
    Had pre sense stop the car twice on the way to work in the week.

    SCARY!!!!

    Both occasions I was driving into bright sunshine, doing about 15-20 mph in traffic.

    I’d only experienced pre sense beeping and flashing at me prior to that!!!
     
  30. cuke2u

    cuke2u Well-Known Member TFSI Owners Group S-line owners group saloon Audi A4

    12,187
    4,986
    113
    Set to late?
     
  31. gtiller

    gtiller Active Member TeamMisano Audi S3 A7 Owner Group

    179
    41
    28
    Yes, I turned off as much of the assistance as I could! LOL
     
  32. Edward L

    Edward L New Member Team Daytona A7 Owner Group

    19
    5
    3
    Thanks Wippers, really useful to share feedback -I am a new poster here, now on my 3rd A7. 1st was Glacier White 2015 S-Line 3.0 TDi, 2nd a Floret Silver 2017 Black Edition 3.0 TDi - last week I bought a 2018 new Model A7 in Daytona Grey which has done about 14k miles.

    Responding to your specific points
    1 Pre-sense - no issues. Has come on a couple of times but only when navigating through congested back streets.
    2 Gearbox - have read a lot of adverse comment about this, I am quite impressed with it. I generally drive in Efficiency Drive Select mode and even then find acceleration terrific. If I need a bit more urgency, I just bring the gear lever back to Sport and boy does it go.
    3 Dashboard rattle - absolutely awful! Driving me mad and potentially a reason to return it
    4 Sat Nav - fine, but Voice Control very poor compared to previous A7. In "old" A7, just used to say "Online destination Duck Pub Taunton" or whatever, and it would always find it. This one, very difficult to just give a voice command and get it to search Google. Have tried lots of permutations "Google Search Duck Pub Taunton" for example, generally only looks nearby (I am in Surrey, not somerset) so doesn't find it
    5 Satnav reset. I get this and fine that it has logged me out of myAudi, so it doesn't know who I am and loses addresses. I sign back in to myAudi in the car and all is well - but it keeps happening!
    6 probably the biggest issue I have is motion noise from what seems to me as driver to be somewhere on the passenger side. It doesn't sound like wind noise, more like tyre roar. My car is on Yokohama Advans - previous A7's have been on Pirelli P Zeros which always seemed to be very quiet. But I don't know if this tyre related, it is just noisy - anyone else have this?

    Good bits :

    1 Yes, very nice. Not sure about the slab of air vents (particularly when this sees to be source of rattles) but in general, very nice. Love the extended lighting pack at night, spectacular and really special. Very comfortable seats.
    2 B&O - agreed, terrific upgrade from Bose in previous Black Ed.
    3 Virtual dashboard - not impressed really. Thought it would be far more configurable than it is. Not sure what real advantage it delivers.
    4 Adaptive Cruise - quite something. In conjunction with the SatNav, it can pretty much get me home without me touching accelerator or brake. Very clever, a glimpse of the future for sure. Not sure about AAC on the motorway as left to it's own devices, you will never overtake the slowest vehicle in front! Needs a bit of getting used to.

    My car has Audi Key Connect - Audi specialise in having really confusing names for their features, but this is the one where you can authorise Smartphones (through the myAudi app) to transfer a digital key. You then use your Smartphone to open (by holding the phone by the door handle) and start the car, no physical key required at all. This is a good feature except Audi UK say it was a "launch edition feature and is not supported in the UK" - they seem surprised that I have got it working.

    Not sure the car quite has the presence of the original A7 (my previous two cars) which I think is a design classic.

    Some of my findings so far - very concerned about motion noise and rattles - albeit from time to time, both magically disappear!

    Kind regards

    Edward
     
    Last edited: Apr 28, 2019
  33. Avatar

    snack-media
    Advertisement


  34. Edward L

    Edward L New Member Team Daytona A7 Owner Group

    19
    5
    3
    Should have said, my new one is a 3.0 TDi - have read some comment about engine noise compared to previous model shape. Noise is different, possibly a bit noisier, but actually I have no issues with it, I think it is just different. Absolutely superb engine.

    I also read adverse comment about the ride of the new A7 - mine is on 20" wheels, regular suspension. Again, when I first got it, felt it was not as good as previous A7, but have got used to and becoming a fan of it. Seems perfectly supple to me.
     
  35. DaveW

    DaveW Well-Known Member Team Floret Silver S-line owners group Audi A6 Audi Avant Owner Group

    1,345
    622
    113
    There's people on the A4/A6 forums who have tried and tried to get this working without success (A6 C8 in my case). Did this just work straight away for you, or is it pretty much down to it not being implemented in the UK?
    Thanks,
    Dave
     
  36. Edward L

    Edward L New Member Team Daytona A7 Owner Group

    19
    5
    3
    It does take a bit of setting up of myAudi and the Car in a sensible sequence - but then yes, it worked for me. You need to link the car to the app, then authorise a User within the app, then generate a (six digit I think) security code in the car which generates the digital key in the phone. I am using a Galaxy S8.

    I am pretty good at tech, but setting the car up nearly drive me to tears!

    It works well - in this new tech era, it means I can now go shopping without car keys or credit cards as the car opens, starts and shuts using NFC in the phone, and pay for things using Google Pay. All a bit scary.

    Reading about Audi Connect Key, it talks about having additional cards that you can give to, for example, a valet parker.
    https://www.audi-mediacenter.com/en/technology-lexicon-7180/infotainment-7183

    However, I don't have such a card, have asked the dealer I bought it from who is silent. Audi UK, who generally seem to know less about their cars that drivers do, say the feature is unsupported and dealer would have to order cards from Germany! Just plain daft.
     
  37. DaveW

    DaveW Well-Known Member Team Floret Silver S-line owners group Audi A6 Audi Avant Owner Group

    1,345
    622
    113
    The bit that seems amiss for me, is the generation of the PIN within the car. I recall something on the net stating there is a menu option in car -> settings and service -> connect key? This menu option does not show in my vehicle. Could possibly clarify this part of the process as this is the key (pun intended!) to getting this working.
    Many thanks,
    Dave
     
  38. Edward L

    Edward L New Member Team Daytona A7 Owner Group

    19
    5
    3
    Have just taken these snaps in my car - do they help?
    20190428_112021.jpg 20190428_112042.jpg
     
    DaveW likes this.
  39. Edward L

    Edward L New Member Team Daytona A7 Owner Group

    19
    5
    3
    The bit I want to get working now is the Key Card for Audi connect key! Anyone know where I can get the cards - they can only be bits of plastic with a chip, no different to a credit card I would think
     
  40. DaveW

    DaveW Well-Known Member Team Floret Silver S-line owners group Audi A6 Audi Avant Owner Group

    1,345
    622
    113
    That's a massive help @Edward L
    I'm pretty sure that's the missing menu option I referred to, but will check on mine to see if it's there.
    Thanks,
    Dave
     
  41. Edward L

    Edward L New Member Team Daytona A7 Owner Group

    19
    5
    3
    Also have this - I tend to drive in Efficiency mode, initially it say E1/2 etc when showing gears, when you switch off it says D1/2 but with the word EFFICIENCY. I think it still drops the revs, so it may be a display issue rather than functional issue
     
    DaveW likes this.
  42. DaveW

    DaveW Well-Known Member Team Floret Silver S-line owners group Audi A6 Audi Avant Owner Group

    1,345
    622
    113
    As I thought, this option is not on my menu, thanks for checking anyway @Edward L

    20190428_115440.jpg
     
  43. gtiller

    gtiller Active Member TeamMisano Audi S3 A7 Owner Group

    179
    41
    28
    I drive in Efficiency.

    When I get back in the car, it still says Efficiency, but the Gear display drops back to D instead of E

    I have to cycle back through the modes to get the E back again.

    I do a 150 mike commute (mainly motorway) each day and can say that Efficiency D is around 5 miles per gallon less than Efficiency E


    This software bug has always been in Drive Select (S4, A6 and S3 all did the same, noticeable most with Dynamic, where S drops back to D in the same way)

    It’s sloppy code, and I’m surprised they haven’t addressed it after all this time.
     
    DaveW likes this.

Share This Page