1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

New A4 MMI - Sending location from MyAudi app to car issue

WarwickBoy Nov 24, 2019

  1. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    Hi guys,

    I now have my new "2020" S4 Avant and first impressesions of the car itself are really good but I'm struggling to understand the Sat Nav, I can't see to enter simple post codes and streets so we have been using Google Maps on our phone. I'm off to read the manual and also try Car Play and Waze.

    I've managed to register with the myAudi app, but I can't work out how to send an address found in the app, to the sat nav. Does anyone know how you register to do this? The 'Send to Car' option/ability seems to be missing/unavailable.

    upload_2019-11-24_15-23-33.png

    From the https://my.audi.com/ web site I seem to have all features on, specifically in myCarManager and myRoute as show below. I think somehow you have to enable something that replaces Share with "Send to car" in the app, but can't work out how to do so.

    Any help appreciated.

    upload_2019-11-24_15-24-53.png
    Cheers,

    WarwickBoy
     
  2. Avatar

    snack-media
    Advertisement


  3. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    12,761
    5,208
    113
    WarwickBoy likes this.
  4. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    Thank you cuke2u that makes sense. I'm then asked for a 'from manufacturer' account ID. Do you know where I find this.

    upload_2019-11-24_17-15-8.png

    Looking at an older thread here ( https://www.audi-sport.net/xf/threads/google-maps-destinations-to-audi-connect.297915/ ) it suggests it in somewhere in https://myaudi.audi.com however the only mention of Google I can find is Google Points of interest and there is no mention of entering a username :-(


    - Goto https://myaudi.audi.com
    - Login & Click on Audi Connect picture
    - scroll to find 'Destination Entry by Google Maps' and click it
    - enter a username into the text box (it can be anything unique, but I used my google username) and press OK
    - Goto https://www.google.co.uk/maps/sendtocar
    - Click Add
    - Select Audi
    - Enter the same username you entered in the myAudi website in the Account ID box.
    - Enter a display name and click OK
     
  5. Fozzie1960

    Fozzie1960 Active Member TFSI Owners Group Team Tango saloon quattro Audi A4 S tronic S-line owners group

    314
    178
    43
    The account ID is the email address you use to log into myAudi.
     
    cuke2u and WarwickBoy like this.
  6. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    I have now managed to get the Google Maps site to list a car and state "Your destination has been sent". The next question is where do you find this send address?

    I think the answer, according to the A4 manual is "Received destinations and tours" (4 below)

    upload_2019-11-24_18-30-11.png

    Unfortunately I don't see Received Destinations and Tours in my Audi car, despite having registered it with a My Audi account and having the My Audi app on the phone in the car, and connected. I know the phone is connected as the mobile phone works, but I'm not sure it is allowing the car to use its data connection.

    General Question about Audi Connect services that rely on data
    I have not registered any specific data plan for the eSIM in the car. Do I need to register (and pay for) for a data plan to be associated the car. Or can I simply let the car connect to my iPhone and use the data connection there, as a I have a very generous data plan.

    Could this be the reason I'm not seeing Received Destinations and Tours in my car?

    upload_2019-11-24_18-35-44.png

    Any advice on whether you really need to sign up to a in car data plan to use Audi Connect services, or is a supported option to simply connect the car via bluetooth to your phone and use the phone's SIM and data connection for data.

    I'm new to the Audi MMI system. Having come from a BMW it does seem less intuitive but perhaps I'm not understanding it properly :dizzy:
     
  7. Soot1e

    Soot1e Active Member Team Daytona Team Navarra Audi S4 Audi Avant Owner Group

    330
    176
    43
    @WarwickBoy have you successfully used the set up wizard on your MMI? Whenever I enter my email address and MyAudi password I constantly get “You could not be logged in. Please try again later” and on the app on my iPhone next to Your Equipment at the bottom of the page there is an exclamation mark with arrows around it and a server error message displayed.

    I contacted Audi Customer Relations why I could not be logged on to be told there was a global fault with the MyAudi/MMI system, on two occasions one week apart I was told it was still down. I will try later today to see if there has been progress.
     
  8. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    12,761
    5,208
    113
    From memory, in my car, the destination was in Audi contacts...
     
  9. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    Hi guys,

    The saga continues. :frowning:

    I have my first experience of Audi Customer services today. I explained my issue and asked a couple of questions. I'll share what I was told in italics, as I'm not convinced by all the answers!

    1. Question 1 - Why can't I log in via the setup wizard?
    ""Services have been coming and going in the last few days. Your account is set up correctly on the back end. May sure you log in via the MMI". I was told.

    I'm initiating my login via the Setup Wizards. I'll see if there is another way to get to this, but I keep getting the error "You could not be logged in, please try again later"

    2. I'd love to send Sat Nav destinations to my car from Google Maps and via the iPhone app MyAudi, but I can't see Received Destinations and Tours?

    "Sir, some of the services depend on your Tech Package. This is not one of the Services you ordered when you ordered the car. It's done in the factory"

    Can I retro-enable it?
    "Not sure. You'll have to speak to your dealer"

    I'm a bit wary of this advice. I have an S4 Avant, Black Edition with Comfort and Sound pack and MMI Navigation Plus with MMI touch". The only thing I did not specify was the option for "Driver Assistance Pack - Tour" and that does not mention this feature.

    Can anyone verify what option is needed to send Sat Nav locations to the car, something I'd really like to do. Or am I looking in the wrong place. Where to addresses sent from Google Maps or the My Audi app appear. By the way, when I do Share a destination from the app, via Share and then selecting My Audi I get "Cannot Send Destinations None of your vehicles support sending destinations", whereas when I use Google maps on a PC at least I get the message "Your destination has been sent"

    I will speak to the dealer, but if any of you on here can offer input on these questions and this issue, this is much appreciated!

    I don't see this option in my Navigation in the car
    upload_2019-11-27_18-45-51.png

    Audi My App message
    upload_2019-11-27_19-1-1.png

    When using Google Maps on a PC
    upload_2019-11-27_19-0-37.png
     
  10. Soot1e

    Soot1e Active Member Team Daytona Team Navarra Audi S4 Audi Avant Owner Group

    330
    176
    43
    @WarwickBoy, Just tried a send to car navigation route and I get the same as you. I have the driver assistance pack so I think we can rule that out as an issue. Another call tomorrow I think!
     
  11. Fozzie1960

    Fozzie1960 Active Member TFSI Owners Group Team Tango saloon quattro Audi A4 S tronic S-line owners group

    314
    178
    43
    Not sure whether helps or not. I have an MY17 with tech pack, I'm not totally sure but I understand all the features of the tech pack are now standard or separate configurable options. Attached is a screen shot from myAudi account. All of the services listed are included with the Audi Connect licenses.

    59E05EB1-33DB-4CA4-94D8-5BB6A5809C2C.png
     
  12. Avatar

    snack-media
    Advertisement


  13. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    12,761
    5,208
    113
    Although the mmi system is different on your to MY2020 models, hopefully the principle is the same :)
     
  14. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    Thank you cuke2u. I think you are right.

    I did a couple more test.
    1) Deliberate entry of an incorrect username.
    This results in an appropriate message and probably shows the car is communicating with the central servers.

    upload_2019-11-27_22-15-54.png

    2) Entering the correct username and password this evening I now get a different message

    upload_2019-11-27_22-17-15.png

    So I'm not sure whether the user is set up correctly.
    1) The car continues to prompt to use the setup wizard to personalise the car (and displays this icon)

    upload_2019-11-27_22-18-55.png


    However I assume that if you had set up the car correctly this would not be displayed. I have my key user assigned:
    upload_2019-11-27_22-23-3.png

    All I want for Christmas is the ability to send sat nav locations from my iPhone to my Audi :notworking:

    Tomorrow I'm going to set up an additional authorised user using a gmail account and see if this works (as well as following up with my dealer) :)
     

    Attached Files:

  15. Fozzie1960

    Fozzie1960 Active Member TFSI Owners Group Team Tango saloon quattro Audi A4 S tronic S-line owners group

    314
    178
    43
    It might be worth deleting your account in myAudi and starting from new.
     
  16. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    12,761
    5,208
    113
    I would be surprised if it makes a difference, as long as the MMI account and the Google send to car email addresses are the same then it will work. The issue seems to be the connection from the car to the Audi servers...
     
    WarwickBoy likes this.
  17. Fozzie1960

    Fozzie1960 Active Member TFSI Owners Group Team Tango saloon quattro Audi A4 S tronic S-line owners group

    314
    178
    43
    I don't think it will either, but when you're desperate. @WarwickBoy are Google Maps an option in the Map Options on the sat nav?
     
    WarwickBoy and cuke2u like this.
  18. Peter123

    Peter123 Active Member TFSI Owners Group Team Navarra Audi Q5 Navarra Blue Classic S tronic S-line owners group

    504
    83
    28
    Have a look through the following thread....
    https://www.audi-sport.net/xf/threads/send-destination-to-car.407060/#post-3514910

    The process for your vehicle WILL be different to mine (Q5 2.0 TFSI Sline), but worth looking through to see if you can get any hints:

    For new users who have never done this, let us go from the basics. Not teaching anyone to suck eggs, but many do not seem to understand that three (3) conditions need to be met, and a set of procedures must be carried out for each of the 3 conditions for it to work correctly. I only use android, so this is written for this operating system. I am currently using a Samsung S10+ that does not have any memory issues and works flawlessly daily with the procedure written below.
    1. An account needs to be set up on the Audi server (I used my PC) as follows:
    https://my.audi.com/
    When setting up the account the user needs to use an email address with a simple and as short as possible password. This is because it will be used several times during the setup of the next 2 conditions.
    2. Down load and install the myAudi app on your mobile. Login into it using the above details from the creation of the account. This links the app with the account.
    When using the app always send destinations to the car. Do NOT use the share link. See Note 1.
    3. When in the MMI in the car, select using the Menu,
    Audi Connect (wait for it to load it can take a long time).
    This brings up a long list including Weather, Fuel prices, Train information and many more including the very item you need, shown as myAudi contacts.See note 2. Do not use Special Destinations.
    In the contacts, you will see the destinations sent to the car. Select the one you need and press the main MMI select button. This is when the system works out the route and in my case, it gives me 3 route options in different colours.


    Note 1. If you use the share link, naturally you will link to other apps on the phone including Waze or Google Maps. In my opinion, if you wish to use them, then it is best to use them directly and not use the Audi system.
    Note 2. Sometime during this procedure, you will need to log in using the account details created on the Audi server login or create a PIN for subsequent logins. The PIN number can be setup/changed on the server.
    Note 3. I carried this procedure on my November 2017 (67 plate) Q5 2.0 TFSI Sline in July/August 2018 with the help of Audi customer services and use it most days. They will help if you are stuck.
    Note 4. The app can be used to reorder/renumber and even delete the list of destinations you have sent to the car/server
    Note 5. You can now login to your account at https://my.audi.com/ and go to
    myAudi destination input and find a route and also send it to the car.
     
    WarwickBoy and cuke2u like this.
  19. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    Thank you to Peter123 for the helpful response. I'll scrutinize that and the links sent through later and see if I can work things out.

    As Peter states, "The process for your vehicle WILL be different to mine", and I think the 2020 A4 is one of the first to have a new MMI. I've booked into my dealer the week after next and they have agreed to take me through the setup process again hopefully resolving any issues. Hopefully they will get me up and running.

    Scoot1e - as another 2020 A4 owner, if you do actually get a breakthrough and get things working, and have any advice, please do share. I'll share an update after my visit to the dealer.

    P.S. I don't think it is now possible to log into login.myaudi.com and find a map there to send a location to the car from. Certainly I don't see such a map in my myAudi portal on my PC. But perhaps it is car specific?
     
  20. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    12,761
    5,208
    113
    I think the mmi system in the new A4 is probably similar, if not the same, as the systems installed within the Q3, the a6,7&8. At the very least the interface does look similar to the Q3 loaner I had recently...
     
  21. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    For Scoot1e and any other 2020 A4 owners with the same issue, something interesting happened today. When I started the car it indicated it was installing Audi connect web services:
    upload_2019-12-6_17-53-10.png
    And now, my app offers a calculate route option
    upload_2019-12-6_17-53-52.png
    and it even says Route was successfully sent to vehicle

    upload_2019-12-6_17-54-25.png

    However I can't seem to access the route from the car, which still does not have a "Received destinations and Tours' menu item in navigating to get to the route. This feels like progress :)

    upload_2019-12-6_17-57-2.png

    Any thoughts?
     

    Attached Files:

  22. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    12,761
    5,208
    113
    Are you definitely sure that's the right place to be looking? On pre 2020 cars I seem to remember it is in myaudi contacts. With the mmi having been overhauled unfortunately my manual I have is out of date...
     
  23. Soot1e

    Soot1e Active Member Team Daytona Team Navarra Audi S4 Audi Avant Owner Group

    330
    176
    43
    @WarwickBoy. Got the same Audi Connect banner as you this morning and on my iPhone I had the calculate route come up. Thinking Audi were heading in the right direction (no pun intended) I attempted to log into MyAudi. After a lengthy period of the cursor swiping left right left it still came up with Unable to log on. Please try again later and the icon for the connect services had gone as had the calculate route on the phone.

    I contacted Audi Customer Services who as usual do not know what the problem is and as their system was down to see if I had contacted them before, they told me to call again on Monday. I was then asked if my car was a 2020 A/S4 as apparently very few cars will connect to MyAudi!!

    To all of you good folk with pre 2020 models, thanks for the input but it seems the new Touch screen System is the problem.
     
    WarwickBoy and cuke2u like this.
  24. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    Thank you for your post Soot1e. Hopefully Audi will solve this issue as more and more people get this new system (which I note is now in the Audi new A4 Allroad which came first in a Top Gear review this month against the Land Rovery Discovery (SUV) and BMW 320xd Touring).
     
  25. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    12,761
    5,208
    113
    My only suggestion would be to cross check with owners of the Q3 or A6 models that have the same systems....
     
  26. DaveW

    DaveW Well-Known Member Team Floret Silver Audi A6 Audi Avant Owner Group S-line owners group

    1,415
    654
    113
    On my A6 C8, I have the "received tours and destinations" button, I press that and it shows everything sent from the myAudi app.
    I think it could be an issue with the MMI software?

    To answer an earlier question, I don't think your car can use your iPhones data, as I dont think iPhones support the required bluetooth profile (RSAP - remote SIM access).
     
    WarwickBoy and cuke2u like this.
  27. Soot1e

    Soot1e Active Member Team Daytona Team Navarra Audi S4 Audi Avant Owner Group

    330
    176
    43
    @WarwickBoy. Today’s situation first of all. App does not have calculate journey showing, car has lost the data services icon which was showing briefly over the weekend and initially Bluetooth disconnected.
    After turning off ignition, locking car then re-entering, Bluetooth now back online. Attempt to log in to MyAudi via set up wizard brings the usual You could not be logged in. Please try again later screen. Audi digital services called and I explain my woes. Was I using latest app, are you using correct password, etc etc were questions put to me yes to everything. I was then asked if using My Audi pin taken from vehicle settings. You need to use that on 2020 A/S4 models. Cannot find it via app as it’s in area which shows a server error on my iPhone. Told to try this instead of password. Eventually get the pin by firing up the PC, does it work....... course not!!
    Second call and this time walked through process from ignition on to set up wizard to log in attempt to get same You cann........later! My problem is now being passed on to the technical department for them to sort out. The key is MyAudi, if not logged in you will not get your destinations sent to car but nothing said about the loss of calculating the journey. Keep you posted on future progress.
     
    WarwickBoy likes this.
  28. Soot1e

    Soot1e Active Member Team Daytona Team Navarra Audi S4 Audi Avant Owner Group

    330
    176
    43
    Received an email from connect services today, seems a software update is required which is still being worked on. Told to register with dealer for them to contact me when available.
     
    WarwickBoy and cuke2u like this.
  29. DaveW

    DaveW Well-Known Member Team Floret Silver Audi A6 Audi Avant Owner Group S-line owners group

    1,415
    654
    113
    Makes you wonder how much testing they perform (or not!)
     
  30. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    12,761
    5,208
    113
    They test, but then they also **** things up when it comes to the server the MMI is supposed to be communicating with. Simple name change and nothing will connect...
     
    WarwickBoy likes this.
  31. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    Thank you Scoot1e for your two updates. I’ll call Audi Customer Services tomorrow and hopefully they will acknowledge the issue and also put me on the dealer waiting list. From what you understand and given the Audi dealer will contact you, does the fix require a dealer visit (rather than an over the air update).

    I have a dealer visit booked for later this week which I will cancel if the update is not ready and no chance they can fix.

    thank you again.
     
  32. Soot1e

    Soot1e Active Member Team Daytona Team Navarra Audi S4 Audi Avant Owner Group

    330
    176
    43
    Here is the content of the email I received today. I am assuming it will be a dealer update. I spoke with my dealer today and let them know why I could not connect to MyAudi. The reaction was “Why the hell are they (Audi) not telling US about this”. Would have been better if there had been some indication as to when the update will be forthcoming.

    Thank you for contacting Audi connect services.



    Our technical department reviewed your request and they suggest that a software update is in the works that will resolve this issue. To be notified when the software update is available please contact your preferred partner so they can contact you as soon as the update is available.


    Please, do not hesitate to contact us for any assistance you may need. We are available 24/7 and can be reached either by calling 0800-2792884, or by contacting this email.

    We wish you safe journeys in your Audi.
     
  33. Avatar

    snack-media
    Advertisement


  34. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    I spoke to Audi Connect customer services. They acknowledged there were some general issues with MMI that they are looking to resolve with some "further updates", but in order to see what my issue was, they would need to check status/licences/features on the back end. Unfortunately (as seems to be very common with Audi) "our servers are down at the moment so we can't do those checks".

    I was of course patient and hope that in 2 days time when I call back, they can at least do the back-end checks on my system, and assess whether my issue is the same, and whether the update that Scoot1e mentions is also the way forward for me.

    Safe journeys everyone!
     
  35. Soot1e

    Soot1e Active Member Team Daytona Team Navarra Audi S4 Audi Avant Owner Group

    330
    176
    43
    Latest update regarding myAudi access on 2020 S4/A4. Speaking with one of the techs in my dealers this morning about myAudi log in problems. Outcome is a bulletin was issued by Audi saying myAudi disabled on all 2020 models until a software upgrade is issued, when????
     
  36. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    12,761
    5,208
    113
    All i can say is that, with pre 2020 models, it is still working fine...
     
  37. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    Hi guys,

    A short update for Soot1e (and anyone else still following the thread). Now Audi Connect is finally back up!

    I had a call with Audi Connect just now (0800 279 2884) to discuss my S4 not featuring the "Received Destinations and Tours" menu item under Navigation in the MMI (as detailed in the Audi Owners Manual for the A4, manual on page 205 as "applies to vehicles with navigation system" and explained that I am unable to use the myAudi app on iPhone to send locations to the car.

    Frustratingly the Audi Connect engineers persisted in telling me "your car does not have the "Destination entry through myAudi app" as part of it's specification. My car is an S4 Avant Black Edition with Comfort and Sound Pack, and does have "Navigation System" and I'm pretty sure it has "Audi connect infotainment"

    1. Is there a definitive way I can check whether my car has "Navigation System" and "Audi Connect Infotainment"?

    I took him through my Audi Code configuration and I asked "If this feature is part of something I have not specified, what did I not specify"? Frustratingly he as not able to tell me. Surely if this was a feature from an option, I should be told what option this comes with.

    I thought I would post this update here, and ask whether any other 2020 A4/S5 owners have got this "send location to car" working, or indeed an acknowledgement that it should work?

    Kind regards,


    WarwickBoy
    --

    This is a screen shot from the Audi Owners Manual for the A4, which explains that these features apply to vehicles with navigation system.

    upload_2019-12-23_17-4-50.png

    This is a screen shot from the Audi Owners Manual for the A4, which explains that these features apply to vehicles with navigation system and Audi connect infotainment?

    upload_2019-12-23_17-11-36.png
     
    Soot1e likes this.
  38. motty225

    motty225 Active Member Audi S4

    132
    65
    28
    Unlikely but is it possible it has been dropped since the s4 became diesel? It works fine on my 68plate s4 as I used it today, but obviously I don't have the touch screen, also if it has been dropped then why put it in the book like you say
     
  39. cuke2u

    cuke2u Well-Known Member TFSI Owners Group saloon Audi A4 S-line owners group

    12,761
    5,208
    113
    Did this not be the difference between sd based navigation and the the tech pack versions?
     
  40. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    All I know is that I have the following:
    JE3 - Audi Connect Infotainment Services (36 month subscription)
    7UG - MMI Navigation Plus with MMI Touch

    The description for the latter is below. When you specify a new A4 via the configurator now, ( https://www.uk.audi.com/uk/web/en/models/a4/a4-avant/equipment.html# ) there is no concept of a Tech Pack.

    As I said to Audi Connect "What should I have specified that I did not to get "Received Destinations and Tours". Tumbleweed.

    I should really let this go. It's a great car, and I'm sure I can use the in car sav nav functions :)

    upload_2019-12-24_14-5-5.png
     
  41. jds_sg

    jds_sg Active Member Team Daytona Audi A4 S-line owners group

    161
    52
    28
    No, with the SD card non-tech pack pre-2020 cars you could still send destinations to your car using the myAudi app, as well as from Google Maps, I used it all the time with my 2016 B9.
    The difference with the tech pack, which I have now in a 2019 model, is that there are more functions in the app, like car status, locking unlocking etc., which were not available in non-tech pack cars. The sending destinations thing seems the same to me.
    I can't believe this functionality would not exist in the MY2020 cars...
     
  42. L_G

    L_G Active Member Sportback Team Daytona Team V6 Audi S5

    251
    102
    43
    From what has been written here I understood those changes happen with the introduction of the 'SOS' module in MY18
     
  43. WarwickBoy

    WarwickBoy Active Member

    225
    78
    28
    Finally an acknowledgement from Audi that there is an issue, and the promise of a fix.



    We hope that our email finds you well.

    Following an update from our colleagues from the technical department be kindly informed that for Audi A4 vehicles of model year 2020, all Audi connect services which require a myAudi login, are temporarily disabled.

    When the update resolving the issue is released you will be informed accordingly, and you will be able to use the service without an issue.



    Glad our persistence has paid off

    Hopefully it won’t be too long until it is up and running as designed!
     
    cuke2u and Soot1e like this.

Share This Page

Do Not Sell My Personal Information