My new 06 plate A3 keeps going into limp mode...

Paul Stephens

Registered User
Hi all, firstly apologies if I've posted in the wrong place, I'm a newbie and just need to get some help from you experts...

I've just bought an Audi A3 2.0 tdi (06), got it remarkably cheap as it's had a new engine replaced at 162,000 miles about 6 weeks ago. Its had timing belt, clutch, pads done etc all as an engine change requires (allegedly) was replaced with an engine with 72000 miles on. Great I thought, test drove it, lovely, not a knock, not a noise, drove excellent.

I got it home after doing the deal and went on a drive and it started fine, got onto motorway, got past 4k revs, limp mode/cutout/ power zero, slowing to about 40mph...holy ship.

So I pulled over and restarted, straight away, pulled through and drove sensibly home - no issues, not a problem, changed the gears well etc.

Took it out today, test it really before I do a long journey.

Started, got to 4k revs in 2nd - cut out. Reignited whilst driving - continues fine. Start again, change gear to 3Rd, gets to 3k revs - cuts out. Reignited again, continues fine. Start again, go through gears with less revs up to 80mpg, cuts out totally again, reignite the car powers up to 90 etc....

Basically if I drive conservatively and don't go above 80 there's no issues however when I high rev or hit a certain speed it cuts to limp mode/ cuts out but restarts once the car has been totally stopped or reignited mid journey - I'm baffled as to whether it's Ecu or what it is?

Could anyone please help with this - has anyone experienced it before??

Many thanks

Paul
 

Ruhel

Never seen a fuel needle go down so fast!
VCDS Map User
Do you have anyone local with VCDS to check what errors are present?
 

Paul Stephens

Registered User
Cheers fellas I've got it booked into an Audi specialist to take a look but was hoping to not fork out...think I'm going to have to though, nothing on the dash changed at all, not even a flicker.....

How bad is an over boost? And more importantly how expensive to fix? haha
 

Ruhel

Never seen a fuel needle go down so fast!
VCDS Map User
Cheers fellas I've got it booked into an Audi specialist to take a look but was hoping to not fork out...think I'm going to have to though, nothing on the dash changed at all, not even a flicker.....

How bad is an over boost? And more importantly how expensive to fix? haha
Cant you return it? Any warrenty?
 

Ruhel

Never seen a fuel needle go down so fast!
VCDS Map User
Have a look at the VCDS map for anyone close to you. You'll have more of an idea of whats going on with the error codes.
What area are you from if you don't mind me asking?
 

Spiezels

Registered User
I had the same about 3 months after buying mine. 08 plate so same engine.

New turbo fitted at about £800 and it's fine, had it over a year since and it's been great, also have my own OBD2 reader just to check for faults and it's been clear since.

Imagine this will be similar so expect to pay out £500-£900 depending on what you get put in!

 

Spiezels

Registered User
Aha sorry mate!

I had it bad tbh, I was away with work when the London VAG garage I took it to rang to tell me the issue so I said fix it while I'm away.

Get back, speak to the garage I bought the car from and he said he'd do it under warranty!!! But it was too late, I'd already paid.

FML
 

Part-Timer

Registered User
Had this problem with mine, paid £150 for turbo stripping and rebuilding with my mechanic. Get the turbo thoroughly cleaned once off the car, you call also bin EGR whilst there.

doing the mr muscle oven cleaner turbo clean, in my opinioun its not even half the job, I wouldn't bother with that
 

Part-Timer

Registered User
Majority of garages will just say you need a new turbo when most likely it will be just clogged up and need cleaning, guaranteed!
 
Top