MMI still blowing fuses

Eastmidsdude

2014 A6 2.0tdi Black Edition
Right I thought I’d sorted this problem. Basically when the screen retracts into the dash it seems to blow a fuse every now and then but it’s happening more often now.
its also started blowing the fuse without the screen unit plugged in. As soon as the fuse touches the terminals it sparks and blows. In my own mind this is a short however I’m useless with electrics. I’ve striped the look at the back of the head unit as far as I can get. Probably 40cm and there’s no breaks in the wiring.
My question is if I run a wire off the back of the fuse to the thin 2 wire plug on the back of the unit will this rule out the wiring? I have to say I’m a bit stumped. Does the wire go straight from the back of the fuse to the screen? Or is there some other unit somewhere? And if so where?
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
Check if it's a shared fuse 1st then rule out other systems in that circuit, if it's single use, then yes try a temp ground/live to see if bypassing helps.
 

Eastmidsdude

2014 A6 2.0tdi Black Edition
How do I find that out? Not got a wiring diagram for it. Another thing I’ve noticed over the last couple of days though is the back lighting behind the instrument cluster flickers every now and then. Not sure if this is related though....?
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
Sounds like a short, can't really do much via the net per se, I would try to find schematics to check the fuse & systems in use via, it's one of those faults I'm afraid to say that could take minutes or hours.
 

Eastmidsdude

2014 A6 2.0tdi Black Edition
I would of said it was a short myself too. The fuse that’s blown doesn’t seem to be controlling anything else as everting else on the car works perfectly apart from the MMI. Reckon I’ll get one of the lads at work to do a test on it and see what they say. Sounds like a short to me just didn’t know if anyone else had the same issue.
Does anyone know where to get the wiring diagrams from on the net??
 

Eastmidsdude

2014 A6 2.0tdi Black Edition
Think I’ve found it. Read through the wiring diagrams and it was pointing to the J794 unto which I eventually found out to be the CD slot/ SD card slot unit. So pulled that out and found this behind it. And a corresponding burn mark on the top edge of the unit. I’ll get a new length of wire spliced in at work and hopefully that’s the end of this saga. I’ll let you all know if this fixes it
 

Attachments

  • 9A12EE61-4ADD-4850-968F-75DC1079D948.jpeg
    9A12EE61-4ADD-4850-968F-75DC1079D948.jpeg
    246.3 KB · Views: 171
M

mickyh7

Guest
Thats a lot of heat for a substantial wire!
Well done for spotting it - But...
How did it get current?
Whats next ?
Good Luck.
 

Eastmidsdude

2014 A6 2.0tdi Black Edition
I suspect it’s been rubbing here
 

Attachments

  • 63E227A4-6393-404A-ABA9-FBCF6304DCE7.jpeg
    63E227A4-6393-404A-ABA9-FBCF6304DCE7.jpeg
    311.6 KB · Views: 133
Top