1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice
  1. ChetK2017

    ChetK2017 Registered User

    3
    0
    1
    Hello All

    I've got a 63 plate A6 with tech pack (if it matters), which has been very well behaved since I bought it a few years back, I started the car this morning to find the MMI screen not popping up, pressed the volume button which made the screen pop up after a short delay however, the MMI title showed and then the screen went back in. The controls by the gearbox are unresponsive, it seems to be stuck in initialisation.

    Can anyone point me in the right direction to how it can be sorted? The controls on the sheering wheel work fine but MMI cant be controlled, car chugs along OK but cant use the MMI for NAV, Car Setup, RADIO etc.. Could it be that a manual reset is required? if so how do you do this on a 63 plate? Not sure if its a fuse as there seems to be power to the unit.

    Any feedback is greatly appreciated. Thanks Chet
     
  2. Avatar

    snack-media
    Advertisement


  3. The Black Panther

    The Black Panther Adventurer !

    430
    112
    43
    View this and discuss further on here before doing anything.



     
  4. ChetK2017

    ChetK2017 Registered User

    3
    0
    1
    Hi, thanks for the feedback & happy birthday for Sunday!!

    I tried this out on the A6, there is no Setup button on my console, I tried all combinations but could not reset the MMI. I will check with a specialist and see what comes of it.
     

    Attached Files:

  5. Rhyso

    Rhyso Registered User

    1,818
    485
    83
    Swap setup for the menu button on your car

    So Menu, MMI controller and the top right key
     
  6. ChetK2017

    ChetK2017 Registered User

    3
    0
    1
    Thanks again for the pointers, I tried the reset and its did make the MMI pop up and attempt a reset, but still no resolution. I tried to do this whilst also starting the car up and it did initialise the Sat Nav to a point it showed a map, then the screen went back in and that was the end of that. Called a few garages and they mentioned it could be a software issue linked to the camber system and dare I say it, I might have to take it to a dealership :( for a software update, I assume it wont be a complimentary job.
     
  7. IGM

    IGM Registered User

    41
    4
    8
    where are you from? might be worth seeing if you can get the car scanned ?
     
  8. RAF_S7

    RAF_S7 Well-Known Member Gold Supporter

    1,940
    1,063
    113
    This isn't a software issue, since all was working fine before hand.

    The C7 MMI is quite a complex beast, and it uses fibre optic cables to join up (daisy chain) each of the separate modules which make up the system. This includes the MMI screen. Any failure of a module in the chain, or a problem with the fibre can result in the next module in the chain not working or showing strange symptoms. A blown fuse on one of the modules has a similar effect.

    A Vagcom scan may help pinpoint where the problem is. Failing that, starting at the back of the car, check that none of the fibre optic connectors have worked loose/become pinched/too tightly curved. The fibre is the orange (sometimes yellow) cables, inside some black tubing. Unplug, then plug back in, see how far that gets you :racer:

    If that doesn't help, check your MMI component fuses. They should be listed in the handbook.
     
  9. Los_Cuentos

    Los_Cuentos Registered User

    17
    21
    3
    Also had this issues. Bluetooth module inside the MIB was faulty.
     
Tags:

Share This Page

Do Not Sell My Personal Information