MMI blowing fuses

Eastmidsdude

2014 A6 2.0tdi Black Edition
Hi all. Hoping someone will help me with this. I have a 2014 PFL A6. I drove to work yesterday perfectly ok and got in the car to go home and the screen wouldn't come up. Turned off and on a few times and nothing. Had a look at it when I got home and the 7.5 amp fuse on the passenger side was blown. Put a new fuse in and it blew straight away with the car switched off totally. Only thing that was on was the interior lights.
Has anyone had this before? Seems strange it was OK one minute and then faulty the next. No screen and no radio/telephone at all now. At a bit of a loss to be honest as I'm not too good at the electrical diagnostics.
 

Eastmidsdude

2014 A6 2.0tdi Black Edition
Yeah it is the one where my finger is in this piccy. Think it said infotainment in the owners manual or something like that. Basically the stereo
IMG_7489.jpg
 

B5NUT

Well-Known Member
VCDS Map User
There are two infotainment listed in the manual, one for the display the other is the main module/CD changer.
 
Last edited:

B5NUT

Well-Known Member
VCDS Map User
I would start by removing the MMI module in the dash and see if their is a trapped wire or one that is shorting out on the back. If not and your 5F module is dead then your in a world of pain, as you will need to buy a new/replacement unit, have it coded to the configuration of your car and then have component protection removed, which can only be done by someone with a licensed copy of ODIS or an Audi dealer.

Or the less time consuming option is just go to Audi and have your pants pulled down and given a proper spanking:sex: as a new unit + labour would be the best part of £2,500, and Audi won't touch used modules, so you won't be able to buy one off ebay and get them to perform the coding & remove CP, they are just not interested.
 
Last edited:

Eastmidsdude

2014 A6 2.0tdi Black Edition
Hmmm sounds bad. Saw a video earlier on how to remove the MMI unit. Didn’t seem too bad. Never heard of component protection before. What’s that?
 

B5NUT

Well-Known Member
VCDS Map User
Security protection for VAG group electronics components, stops people just selling on stolen parts, as if VW/Audi were notified of a stolen car all the parts are blacklisted on their servers and if someone attempts to remove CP on a stolen component it is refused by Audi's servers.

If CP is enabled on the main MMI module (5F) then you won't get any sound or navigation, and CP is automatically activated if it detects the chassis number has changed, and it does this check every time the system is switched on, also there is no hacks or work around available.
 

Eastmidsdude

2014 A6 2.0tdi Black Edition
Let’s be hoping it’s a trapped wire then. Strange how it went all of a sudden though. Last week the screen did switch off then straight back on again
 

Eastmidsdude

2014 A6 2.0tdi Black Edition
Right everyone. I appear to have cured this issue. However the slightly annoying thing is I don’t know how.
So tonight I removed the screen. I followed a YouTube video but it was way over the top in terms of what needs removing. Basically you need to remove the plastic trim above the screen and then the vents and the screen. The black plastic trim under the vents I don’t think needs removing as this has to be fitted back on before the vents.
So I undid all the plugs. Tried it back in without the screen motor plugged in and it didn’t work at all. So plugged it all back in and tried it and it worked fine. Not driven it since though but switched it on and off a few times and it seemed ok so here’s hoping it’s all sorted
 
Top