1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MMI 3g nav not reading disc

bennymac Jun 6, 2019

  1. bennymac

    bennymac Member

    40
    5
    8
    Hi everyone
    My son has a 2011 A4 Technic quattro with what we believe is the Audi MMI 3g navigation. All has been well for a couple of years but recently the navigation wont show up beyond the searching for satellites page.
    It doesn't seem to be reading the disc anymore, I have tried the other discs he has and it is the same result so we suspect the laser has become faulty on his unit.

    I was wondering if anyone could offer some advice on whether they had the same issue and of course if it really was the laser that needed replacement.
    We are fairly competent people and would like to try to replace the laser if we can source one.

    Can anyone offer some assistance ?
     
  2. Avatar

    Google AdSense Advertisement


  3. s8craig

    s8craig Well-Known Member VCDS Map User

    1,841
    65
    48
    If its searching for satelites it could be a faulty gps receiver. have you tried removing the fuse for thenavigation unit to properly reset it, not just a 3 finger reset.

    I have seen 3G units lose satelites and a proper power cycle has cleared it.
     
  4. bennymac

    bennymac Member

    40
    5
    8
    I haven’t tried to reset with the fuse out but I did remove the unit from the car to get the part number.
     
  5. s8craig

    s8craig Well-Known Member VCDS Map User

    1,841
    65
    48
    Well if you've removed it to get the part number did you disconnect the quadlock connector, hence removing power
     
  6. bennymac

    bennymac Member

    40
    5
    8
    Yes took it out completely so that presumably would have been a full reboot too.
     
  7. Boundy

    Boundy New Member

    17
    18
    3
    Can you not just copy map data to an SD card an run it from there?
     
  8. bennymac

    bennymac Member

    40
    5
    8
    Doesn't seem to have that functionality i'm afraid, I found a company that can repair it for a little over £300 but then I found a laser on UK ebay for £9.50 so when it arrives this week I will have a go at changing it.
     
  9. Boundy

    Boundy New Member

    17
    18
    3
    I have a 3g basic in my A4 S line and maps run just fine from an SD card, dump the whole contents onto a 16gb full size SD formated to fat32 and see how you get on. I even had the option to copy map data to SD from within the sat nav menu
     
  10. bennymac

    bennymac Member

    40
    5
    8
    Well we tried a replacement laser but no luck, I put the map disc onto an SD card but it wont read it. We read that Audi needs to enable this function so in the end I have purchased a second hand dvd player with the same part number. It seems to work but with limited functions so presumably it needs to be coded or matched to the car. Can someone confirm how this is done as I have messaged a couple of VCDS users in my area.
     
  11. Boundy

    Boundy New Member

    17
    18
    3
    I would put the original dvd drive back in, update the firmware using the thread on the A5oc forum and run the map from an SD card
     
  12. Avatar

    Google AdSense Advertisement


  13. bennymac

    bennymac Member

    40
    5
    8
    Is there any chance that you could talk me through how to do that ?
     
  14. Boundy

    Boundy New Member

    17
    18
    3
    Hi, this is the guide I followed. I recommend reading all of the thread, stap in its a bit long winded.
    I deviated a little from the instructions because I only had 1 SD card.

    I updated the firmware first.
    Then I reformatted the card and run the script.
    I then formated the card again and put on the map and it worked a treat.

    You should then end up with the latest available firmware with TMC traffic with 2019 maps and PoI running from an SD card, leaving the drive free for cds.

    https://www.google.com/amp/s/www.a5...l-q/113473-mmi-3g-basic-navigation.html?amp=1
     
  15. bennymac

    bennymac Member

    40
    5
    8
    Did you need vcds when you did the install ?
     
  16. Boundy

    Boundy New Member

    17
    18
    3
    I used obdeleven, as you need to activate the green menu
     

Share This Page