min oil light (yellow) coming on and off

Dan burns

Registered User
got a 2006 a4 2.0 tdi avant,lovely car!!!!! 6 weeks or so back the min oil light came on so i checked the dip stick and everything all good. later when i got back in the car it went out and came back on after a few miles. next day i brought to the mechanic and he poopped the computer on it (snap on one) no faults showed up. up on the ramp it went to check for any loose wiring on the oil level sensor and no issues,he checks the oil and says its a tiny bit low but nothing to worry about,none the less he topped it up a tad. so off i go with the light out and a few mile again its back on. straight up to tps and bought a new sensor £87 all in. next day the light goes out by its self and stays out for a few weeks and now its back on. oh while it was out i brought the sensor back for a refund as i thought it was all good again (silly me). has any one encountered this issue and please could you let me kn0w.
ive heard a few people say they changed the oil filter and that was it sorted,hope its as easy as that.
 

TonyMoneo

Registered User
Same thing happened to me, thought replacing the oil level sensor would fix it. At the moment I just take out the dipstick and put it back in (that keeps the light off for a while). Will replace the sensor with the next service. Did you get an OEM sensor?


Sent from my iPhone using Tapatalk
 

Dan burns

Registered User
yes tps supply oem parts only
Same thing happened to me, thought replacing the oil level sensor would fix it. At the moment I just take out the dipstick and put it back in (that keeps the light off for a while). Will replace the sensor with the next service. Did you get an OEM sensor?


Sent from my iPhone using Tapatalk
 
Top