MIB2 and bang and olufsen

Boj27

Active Member
hi guys,

Just finished the retrofit of my MIB2 last week.

I’ve noticed I have the sub woofer control in my MMI....now from doing some reading in these forums, it seems that 2017 facelift cars with bang and olufsen seem to be hit and miss on whether they have the subwoofer control available at all....which leads me into my next dilemma. I am missing the bass and treble functions in my new MMI, and my coder says he needs to parameterize my bang and olufsen amp. I am wondering whether this is such a good idea, could I risk losing my sub control if I do this, while regaining my bass and treble functions? I’d rather have my sub control than an extra 2 or 3 units of bass....

I’ve heard this sub woofer missing is an Audi issue. Has anyone gotten anywhere with it yet?

I also would like to know if it’s possible to completely code out Audi connect, as in remove it from the swivel menu all together. Is this possible and does anyone know the byte and bits that need changing, or adaption channels that need deactivating?

Cheers
 

Khufu

Registered User
The latter is possible. When I 1st got my MMI2 it was missing and i messed about with the adaption channels in the 5F module to get it to appear. Sadly im not sure how i managed it.
 

DJAlix

VAG Car Coding™ Limited
Site Sponsor
VCDS Map User
Gold Supporter
VAG Can Professional
ODIS (Offboard Diagnostic System)
hi guys,

Just finished the retrofit of my MIB2 last week.

I’ve noticed I have the sub woofer control in my MMI....now from doing some reading in these forums, it seems that 2017 facelift cars with bang and olufsen seem to be hit and miss on whether they have the subwoofer control available at all....which leads me into my next dilemma. I am missing the bass and treble functions in my new MMI, and my coder says he needs to parameterize my bang and olufsen amp. I am wondering whether this is such a good idea, could I risk losing my sub control if I do this, while regaining my bass and treble functions? I’d rather have my sub control than an extra 2 or 3 units of bass....

I’ve heard this sub woofer missing is an Audi issue. Has anyone gotten anywhere with it yet?

I also would like to know if it’s possible to completely code out Audi connect, as in remove it from the swivel menu all together. Is this possible and does anyone know the byte and bits that need changing, or adaption channels that need deactivating?

Cheers
Should VAG-Tec not be configuring all this for you?

Also, might be an idea to keep all the related posts with the same thread instead of opening up new ones for every issue / question. Is like 5 or 6 now ranging from the information gathering through to the “successful” retrofit, now this...
 
Last edited:
T

T-800

Guest
Should’ve just gone to you in the first place Alex......
 

Boj27

Active Member
Should VAG-Tec not be configuring all this for you?

Also, might be an idea to keep all the related posts with the same thread instead of opening up new ones for every issue / question. Is like 5 or 6 now ranging from the information gathering through to the “successful” retrofit, now this...

I haven’t had chance to go down and see him yet but potentially losing the subwoofer option is scaring me a little and if there’s a possibility of that happening I’d rather not have it played with at all!
 
Top