1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Massive IT Failure Affects All Audi 2020 A4 vehicles

WarwickBoy Jan 6, 2020

  1. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    Audi have experienced a IT failure affecting all services associated with the myAudi login in 2020 A4 models vehicles, and while they are working on a fix have temporarily disabled all Audi Connect services which require a myAudi login, rendering functions such as navigating favorites, location sending to car from the myAudi mobile app and other personalisation MMI features unusable for owners of 2020 A4 vehicles.

    New Audi owners started to report issues with the myAudi login and associated services upon delivery of their new cars in November 2019 and Audi are still working on a resolution. Audi Connect a have provided the following updates to users who have reported issues via Audi Connect (0800-2792884):

    "Following an update from our colleagues from the technical department be kindly informed that for Audi A4 vehicles of model year 2020, all Audi connect services which require a myAudi login, are temporarily disabled.

    When the update resolving the issue is released you will be informed accordingly, and you will be able to use the service without an issue.
    "

    As of 6th January 2020, the services are still disabled.

    Affected user, Warwick Boyle from the West Midlands in the UK said "I collected my new Audi S4 Avant Black Edition with Comfort & Sound in late November avoiding potential Brexit related price hikes. And the Audi Connect services have not worked since I collected the car. I'm a new customer of Audi, coming from BMW whose online/in-car services worked seamlessly. In a brand new £45,000+ premium vehicle one has an expectations that services like this will just work, and my perception of Audi pre-ownership were that Audi were market leaders in the technology space. My experience with Audi over the last 2 months has taught me otherwise. I'm hoping that they will fix these issues such that the in-car services work as advertised".

    When we contacted Audi UK about this issue, we were told "We are working on a resolution to the Audi Connect services affecting 2020 A4 vehicles, and cannot comment on individual cases". Audi customers affected by such issues were requested to raise a technical case so as to receive updates on when the problem is resolved.
     
    Soot1e and Zippytoo like this.
  2. Avatar

    snack-media
    Advertisement


  3. cuke2u

    cuke2u Well-Known Member

    12,792
    5,216
    113
    Fame at last, for all the wrong reasons though ;-) Unfortunately, whether the car was free or you pay a lot of money for it, IT issues happen and they can be far reaching. These days everyone just 'think' everything will work so when their online banking goes down they get all over excited bitch about it on some social network site about it not realising there are IT guys out there busting their guts trying to resolve things.

    It maybe the case that it is a contract provider's hardware affecting this, not directly Audi, who knows, it's complex these days...
     
    Bryant1998, SiPie and WarwickBoy like this.
  4. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    All fair and valid points. Hopefully the issues are being focused on :thumbs up: An outage for a few days I can tolerate, but after 6 weeks of issues I'm starting to lose patience. While I do very much recognize in terms of the car overall these are relatively minor and the issues are probably "first world problems" (i.e. not important in the scheme of things), it's annoying when things don't work as advertised. :smile new:
     
  5. cuke2u

    cuke2u Well-Known Member

    12,792
    5,216
    113
    I agree and share your frustration, I am a IT technician, if you've not already guessed it, by the way and we also are equally affected by outages of one kind or another, then bear the brunt of it from customers. I can only second guess what the issue is and I'd like to be able to roll my sleeve's up and have a go at resolving it...
     
  6. Eurostar

    Eurostar New Member

    10
    2
    3
    Just to concur with your findings. Have been using MyAudi to communicate to the car successfully until a couple of days ago.
    Now, on starting the car, I get message "The Selected user has not been used in this vehicle . . . switch to the guest user account"
    Also the 2020 maps have been made available on the MyAudi site and have tried to update the car's maps but without success - it cannot see the map update on the USB drive or online. May be related to the current issues.

    Any indication when there will be a resolution to the issues.
     
  7. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    Interestingly, having been flagged to the availability of map update by Cuke2U (I think, thank you) I also tried the map update. I posted my experience in the thread here https://www.audi-sport.net/xf/threads/2019-maps.381894/page-3#post-3533022

    Basically having inserted a USB key (FAT32 formatted) with the files indicated into the USB (A) slot under the parking camera button, I did not see the device recognised.

    Has anyone with a 2020 A4 got the map update to work?

    My spider senses tell me this is not related to the MyAudi outage, as the map updates appears to be basically a file upload from USB to the car (but I may be wrong).

    I think I will have a chat with Audi Connect about this on Friday. I drive the new section of the A14 quite often and would like to see this as a road, rather than open fields

    I've learned our friends in the US pay $400/year for MyAudi services. At least we get them for free. According to someone on another popular Audi forum without Audi Connect you cannot use the following.
    1) satellite view on the nav
    2) online Google Search for navi destination
    3) Send directions to car navi from phone app
    4) live traffic data on the navi
    5) weather, news, flight times, or pretty much anything under the Audiconnect menu

    I think 1) and 4) still work for me despite "all Audi connect services which require a myAudi login, are temporarily disabled" but I'm going to double check this tomorrow.
     
  8. cuke2u

    cuke2u Well-Known Member

    12,792
    5,216
    113
    Is the usb stick no more than 32gb?
     
  9. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    It was exactly 32GB and I noted the update takes up 15.5GB on a 32GB drive. I should perhaps try a different USB stick. If I choose the UK map update (rather than Europe) will this smaller update just update the UK maps but not take away the Europe ones. If so, perhaps I'll experiment with a different 8Gb drive I had.

    I formatted the drive as FAT32. I trust that is the right format?
     
  10. cuke2u

    cuke2u Well-Known Member

    12,792
    5,216
    113
    I use a 32gb SD card in a USB adaptor and it works fine, so can't see any reason why yours isn't being picked up. By all means try another though. I also always update the lot as it doesn't matter if you turn off the car mid update as it just continues from where it left off...
     
    WarwickBoy likes this.
  11. Eurostar

    Eurostar New Member

    10
    2
    3
    The system is looking a bit brighter:
    I now get details of the car's mileage, locked status etc and warnings (it wants washer fluid) on PC & Mobile.
    It still shows the engine as "5-cylinder SI engine 2.3 l" under "Government Grant and Charging" instead of "V6 3.0 l . . . "

    No Satellite or Data Connection as Yet

    regards
     
  12. Avatar

    snack-media
    Advertisement


  13. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    I spoke to Audi Connect on Friday, and finally had a sensible conversation with a nice lady called A********a. She apologised for the convenience and confirmed that the issue with sending locations to the sav nav on 2020 A4/S4 cars which relates to the fact that all Audi connect services which require a myAudi login, are temporarily disabled.

    - The issue is being investigated
    - The fix will require a MMI system update and this will require a dealer visit
    - There is no ETA on the fix, but she hopes it is soon as she has many conversations with affected Audi owners each day

    The wait continues but I was re-assured from my call on Friday.
     
  14. Filipão

    Filipão Active Member

    213
    115
    43
    That's been fixed here in sunny Portugal.
     
  15. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    Cool. Please can you send a screen shot of what features are enabled on the Navigation sub menu after the fix is applied. Here in then UK we only get the attached :-(
     

    Attached Files:

  16. Eurostar

    Eurostar New Member

    10
    2
    3
    Please note following (part) reply from Audi Digital Services and reiterates WarwickBoy's original post :

    'After looking into this issue, kindly be informed that Audi S4 vehicles (model year 2020) are experiencing login disturbances. Some of the Audi Connect services which require a myAudi login, including the map updating service, are also currently deactivated. In order to activate these functions, a software update is required. Kindly bear in mind that this update is not yet available. Please keep in touch with an authorized Audi dealer, with regards to the aforementioned update. '
     
    Soot1e likes this.
  17. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    It would be good to make a note of all the things that we are loosing during the long period we wait for an update (useful when making a complaint). My starter for ten based on my observations and information provided here is
    - Ability to send location and route information from myAudi app to the in-car sat nav
    - Ability for last location list, home and work locations and favorite locations to be remembered (after a period of time this resets to none)
    - Ability to update maps (very annoying when your routes involve a new road such as the new A14 and the sat nav traffic routing tries to send you another route).

    Is there anything else that is broken while we wait, and wait, and wait, and wait for this update?
     
  18. Eurostar

    Eurostar New Member

    10
    2
    3
    One other 'facility' I use is Google's SendToCar which is failing currently.
     
  19. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    I posted this thread on 6th January, and I've had no updated from Audi on my technical case. I'm assuming others such as Soot1e have not yet had any update from Audi.

    We have lost
    - Ability to send location and route information from myAudi app to the in-car sat nav
    - Ability for last location list, home and work locations and favorite locations to be remembered (after a period of time this resets to none)
    - Ability to update maps (very annoying when your routes involve a new road such as the new A14 and the sat nav traffic routing tries to send you another route).
    - Ability to use Google's SendToCar which is failing currently.

    I wonder if a cheeky letter to Auto Express compliant section might help. I often wonder whether, as they no doubt get loads of test cars from Audi, whether they would follow up such a complaint. I might give this a go if they don't provide a half decent update to my technical case by the 6th February.

    Thanks for listening guys and girls!:smileycat:
     
  20. Soot1e

    Soot1e Active Member

    334
    178
    43
    I contacted VWFS with a view to reject the car as it had been faulty from day one and I was getting really peeved to see the on screen messages of “make this car your own” and the set up wizard popping up every time I switch on the ignition. VWFS replied that they would look into this but on the same day I received an email with this:

    Kindly be informed that we do not have any specific dates yet announced for the update. Nevertheless, we are expecting it soon, as it set to be resolved with the highest priority from our technicians. We would therefore highly recommend, to keep in touch with your Audi partner starting from February.

    Due to this I cancelled my request to VWFS but if nothing is forthcoming by the end of February I may consider the reject route once more.
     
  21. Nabeel Ahmed

    Nabeel Ahmed New Member

    12
    3
    3
    @WarwickBoy / @Soot1e I’m still also in a similar boat. Although Audi Connect customer service had told me to book the vehicle in to my dealer and have the dealer phone them. Dropped it off yesterday and I think I’m just being fed a load of rubbish now. Dealer isn’t keen on contacting Audi Connect and I’ve been told that the diagnostic is going to take time as “it’s a very complicated car”. I’m giving them today to come back with something sensible as without a loan car too it’s just not good enough. Audi Connect haven’t mentioned anything to me about the software update though. Watch this space?!


    Sent from my iPhone using Tapatalk
     
  22. Eurostar

    Eurostar New Member

    10
    2
    3
    Following recent correspondence with Audi Digital Services, they sent me this note:

    'Unfortunately, we haven't been provided with an estimate in regards to the release of the software update. We do know that the patch is being worked on with the highest of priorities, as it is affecting a significant number of vehicles, and we kindly ask for your patience until the issue is resolved. The moment we receive news of a release date, we will notify you immediately.'
     
  23. A4B9

    A4B9 Well-Known Member

    513
    253
    63
    vorsprung durch technik...
     
  24. cuke2u

    cuke2u Well-Known Member

    12,792
    5,216
    113
    Unfortunately I doubt if Audi can fix what they didn't break and I bet they never guarantee these features anyway, they'd be foolish if they did. Hardly 3rd world stuff though is it? Merely my opinion but I wonder what we used to do when driving around using paper maps that was missing countless numbers of new roads and send to car was giving your partner a map and asking them to direct you to xyz. There is this assumption end users have of technology that we must live in this utopian world where all of it works perfectly all the time. Judging by the number of owners that can't even be bothered to read a manual or lift a bonnet then blame the manufacturer for when the engine blows up, ecoBoost engines here, and complain on social media, such as they did yesterday when the extremely minor search bar stopped working in win10. There is an unhealthy dependency I feel of their own making and the inability to adapt it seems. I guess it is easier to type into Twitter than work things out for themselves.

    No offence intended towards anyone here, just my observation..
     
    Last edited: Feb 6, 2020
  25. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    Thank you for your contribution cuke2u. I agree with you to some extent in general with IT issues, but with respect the the specific issues with Audi's 2020 MMI affecting new owners I have to disagree and will explain why.

    From the day cars could be ordered with different options, there was a single manual for each model, and based on the options you selected, you would have access to some features such as sunroof, enhanced navigation, heated steering wheel etc. If you had paid for features such as this, and then the car you were delivered did not have them, you would rightly want this rectified. This is no different.

    I specified and paid for a vehicle with "Audi Connect Infotainment" and yet features outlined in the manual that are fully described (Received Destinations and Tours) that I consider very useful have not been delivered. Additionally I would consider an ability to update maps (which are now available) to be significant in a £45,000 car. Do Audi expect me to not have map updates for 4 years?

    What is also disappointing is Audi's customer services, and handling of the issue. Scoot1e, Nabeel Ahmed and many other 2020 A4/4 owners have exactly the same issues, and Audi give inconsistent advice. I have been told by Audi Connect that there is no point in going to the dealer until a fix is released. "When the update resolving the issue is released you will be informed accordingly" (via Audi Connect technical case). It seems Scoot1e has been told "highly recommend, to keep in touch with your Audi partner starting from February." whereas Audi Connect have told Nabeel to go to a dealer for diagnostics. If I were a betting mad I'd say there is zero chance of Nabeel's dealer visit resolving the issues (if they are the same as mine). I hope I'm wrong Nabeel. Please do let us if any issues are resolved.

    For others suffering issues, I clarify the issues I have
    - Ability to send location and route information from myAudi app to the in-car sat nav (feature outlined on page 206 of the manual (Loading received destinations and tours)
    - Ability for last location list, home and work locations and favorite locations to be remembered (after a period of time this resets to none) (described on page 205 of the manual under "Selecting a Destination"
    - Ability to update maps (feature outlined on page 211 and 212 of the manual ("Importing a map update to your MMI using USB Connection)
    - Ability to use Google's SendToCar which is failing currently.

    If others can clarify they have the same issues, that would be helpful.
     
    tickedon, Eurostar and Soot1e like this.
  26. Soot1e

    Soot1e Active Member

    334
    178
    43
    As previously reported in this and other threads, my problem is I cannot log in to MyAudi in the car via the set up wizard and it always displays “You could not be logged in. Please try again later”.

    On my phone using the MyAudi app, when I select a destination, a pin will mark the destination on the map but no route is calculated. Sending a route to the car is impossible as there is no route to send!

    Also on the app if I try to “Discover all the details of your Audi” in the Your equipment section I get the message “Server error. The server sent an invalid response.

    It is very frustrating when dealing with Connect Services, that some agents are aware of the 2020 A/S4 problem and others are keen for you to contact the dealer. Maybe they should talk to each other!!
     
  27. Eurostar

    Eurostar New Member

    10
    2
    3
    Technology advances, no doubt with hiccups, else we would still be living in caves. Windows 10 has had issues over the years with search and obviously still having them – technology will never be 100% right. I can’t imagine being driven in a fully automated car without the latest map!

    Anyway, when I bought the S4, apparently, with the latest systems that Audi provide. I expect maps to be updated regularly. Certain aspects of this technology are linked to maps e.g. efficiency assist, speed control, matrix light controls. It costs; in three years, I will have to buy the map updates. Strangely you cannot download over the internet as my previous A6 did but you now need a USB stick.

    Now my rant; On the other hand, I’m not sure why I would want to unlock the car from my computer or mobile but this facility will allow me to do so. I cannot remotely start the car (as far as I’m aware) but can get the temperature right. You get a lot of information e.g. warning can be viewed on my mobile. So, one wonders what information is available to Audi about your car and your driving – also what can be done remote to your car. So, have a good password if it ever works.
     
  28. Nabeel Ahmed

    Nabeel Ahmed New Member

    12
    3
    3
    @WarwickBoy I got my car back from Audi yesterday evening. I can confirm I am facing all of the issues you are but mine was also stuck in a constant set up loop and the setup kept failing. (I was able to log in to myAudi). I couldn’t also access the news and weather apps.

    The setup loop issue has been resolved and I can now see the news and weather. I still have the issues mentioned around maps, destination memory etc...

    From my understanding the dealer told me there was a bulletin issued to dealers about the set up loop and myAudi login. They’ve effectively done a full reset on the vehicle and reflashed the software (existing version). So you’re assumption on rectification was indeed correct.


    Sent from my iPhone using Tapatalk
     
  29. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    Hi Nabeel.

    I'm very pleased that the setup loop issue has been resolved for you. I had that when I first had the car. It is probably totally unrelated, but shortly after I changed password from something very long with various symbols, to something quite short with only a couple of symbols it logged in, and now I do get news and weather (which I did not get before). Perhaps a dealer visit is worth it for Scoo1e?

    But I think, as seems to be consistent with you, and me (and probably Scoo1e) that the following are still issues:
    - Ability to send location and route information from myAudi app to the in-car sat nav (feature outlined on page 206 of the manual (Loading received destinations and tours)
    - Ability for last location list, home and work locations and favorite locations to be remembered (after a period of time this resets to none) (described on page 205 of the manual under "Selecting a Destination"
    - Ability to update maps (feature outlined on page 211 and 212 of the manual ("Importing a map update to your MMI using USB Connection)
    - Ability to use Google's SendToCar which is failing currently.

    I'm an iPhone user and the myAudi app never even gives an option to send to car

    upload_2020-2-7_16-31-34.png

    Grrr:

    upload_2020-2-7_16-32-46.png
     
  30. cuke2u

    cuke2u Well-Known Member

    12,792
    5,216
    113
    Agreed, if Audi perhaps had been more willing to compensate you for the lack of this feature by offering you, say, and perhaps at least, servicing for free as an example, it might have eased your pain. Dealerships can be better at reacting than head office but it still could be done...
     
  31. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    I also get what you describe. Had not noticed this before.
     
  32. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    In the mobile app when one clicks on this:
    upload_2020-2-8_18-13-41.png
    This happens:
    upload_2020-2-8_18-14-1.png

    Within the my.Audi.com web site there is a similar feature.

    upload_2020-2-8_18-15-26.png
    Which when clicked indicates:
    upload_2020-2-8_18-15-55.png
    However in the car, it indicates a key user is enabled;
    upload_2020-2-8_18-22-11.png

    upload_2020-2-8_18-22-34.png
     
  33. Avatar

    snack-media
    Advertisement


  34. thorpemark1

    thorpemark1 Member

    31
    4
    8
    Have just picked up a UK 2020 A4 Black edition, I can sign in set the key user, send destination to the Nav, etc . but it keeps logging me out when I get back in the vehicle . with a message "The selected user has not been used in this vehicle for a while Please enter the myAudi user data again."
    Anyone have any idea if this is related to the above issues. ?
     
  35. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    Welcome to your new 2020 A4 black edition. Happy driving. The issue you mention is one many have experienced.

    Please can you share the following information to help troubleshooting.

    General Information
    - Car Model and key features (2020 Audi S4 Avant, Comfort+Sound, Black Edition)
    - Car Delivery/Collection Date (November 2019)
    - Did your dealer tell you there was an issue with the MMI software on collection of your car? (No)
    - Have you raised any issues/technical cases with Audi Connect? (Yes)

    Known Issues
    - Do you see 'Received Destination and Tours" and in the MMI under Navigation? (No)
    - Can you send a destination/route to the car from the MyAudi mobile app (if yes state which mobile platform (iOS/Android) (No)
    - Can you send a destination to the car from Google maps? (No)
    - Can you log in to MyAudi via Set up Assistant? (Yes)
    - Can you log in to the car as a key user? (Yes)
    - Do you see map update in http://my.audi.com on your browser on your PC/macOS/preferred client (Yes)
    - Can you update new maps in your car using USB method (No)

    Information to Share (from Settings/Version Information) relating to software versions and map versions (Please share a screen shot if easiest)
    - Software (3174)
    - HMI build version (release-31.7-1913-SNAPSHOT-26.03.2019-15:48:41)
    - Navigation Database (V03959806QK_P0220_EU_2019.05)
    - Media Driver (CL31_MIB3H_AU_ER_G45S_1901302PROD-1)
    - Gracenote database (Region=Europe - Version=4)
    - Hardware (H8W2035043)
    - Settings - Software version (MHI3_ER_AUG45S_P3174)

    The information you descrive has been experienced by users with the following version:
    - Software (3174)
    - HMI build version (release-31.7-1913-SNAPSHOT-26.03.2019-15:48:41)

    However some users with the following version don't have the issues
    - Software Version 3248
    - MMI Software version 32.9-1928-SNAPSHOT-04.09.2019-13:41:01

    If you can share this will help us work out what is required to fix.
     
  36. thorpemark1

    thorpemark1 Member

    31
    4
    8
    Thanks will gather all these details later on today .. Misses has decided to take the car this morning (I've not even driven it yet !! :) ) delivered yesterday .
    I have sent destinations and they have been received by the MMI , they show as a notifications in the menu (once I have logged in again) , not sure iv'e seen the headings Received destinations and Tours
    Vehicle status in the App, + looking unlocking) only seems to update or work when the car ignition is on , or shortly after leaving the vehicle . after a while this stops working , until going in to the vehicle again .

    anyway, I'll get all the relevant info later , thanks for help !
     
    WarwickBoy likes this.
  37. thorpemark1

    thorpemark1 Member

    31
    4
    8
    Updated with My details

    General Information
    - Car Model and key features (2020 Audi A4 Saloom, Comfort+Sound, Black Edition)
    - Car Delivery/Collection Date (March 2020)
    - Did your dealer tell you there was an issue with the MMI software on collection of your car? (No)
    - Have you raised any issues/technical cases with Audi Connect? (No)

    Known Issues
    - Do you see 'Received Destination and Tours" and in the MMI under Navigation? (yes)
    - Can you send a destination/route to the car from the MyAudi mobile app (if yes state which mobile platform (iOS/Android) (yes)
    - Can you send a destination to the car from Google maps? (No)
    - Can you log in to MyAudi via Set up Assistant? (Yes)
    - Can you log in to the car as a key user? (Yes)
    - Do you see map update in http://my.audi.com on your browser on your PC/macOS/preferred client (No)
    - Can you update new maps in your car using USB method (No)

    Information to Share (from Settings/Version Information) relating to software versions and map versions (Please share a screen shot if easiest)
    - Software (3248)
    - HMI build version (32.9-1928-SNAPSHOT-04.09.2019-13:41:01)
    - Navigation Database (V03959807AJ_P0260_EU_2019.11)
    - Media Driver (CL32_MIB3H_AU_ER_G45S_1902711PROD-1)
    - Gracenote database (Region=Europe - Version=5)
    - Hardware (H8W2035043)
    - Settings - Software version (MHI3_ER_AUG45S_P3248)

    The information you descrive has been experienced by users with the following version:
    - Software (3174)
    - HMI build version (release-31.7-1913-SNAPSHOT-26.03.2019-15:48:41)

    However some users with the following version don't have the issues
    - Software Version 3248
    - MMI Software version 32.9-1928-SNAPSHOT-04.09.2019-13:41:01
     
  38. Andy101

    Andy101 Active Member

    332
    97
    28
    Had this once, just hit the home symbol - you don't need to log in again.
     
  39. thorpemark1

    thorpemark1 Member

    31
    4
    8
    Will try this. Thanks.
    It also seems once ignition is off for more than a few a minutes , I lose the ability to update the status and lock / unlock via the my Audi app.
     
  40. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28
    I'm not aware of a specific fix for the log in issue. I did initially have that problem, but it went away. Soot1e had that specific issue for a while. I changed my myAudi login password from something very long, to something that was only 8 characters, and it worked better but I can't honestly link that to the problem going away. Might be worth trying if you have a long password. Sorry I can't be of more help.
     
  41. thorpemark1

    thorpemark1 Member

    31
    4
    8
    Ok that didn’t work.
    Vehicle status updates shortly after ignition off and I can lock / unlock with in a few minutes of ignition off. However then the car can’t be reached. I get a technical error when trying anything.
     
  42. thorpemark1

    thorpemark1 Member

    31
    4
    8
    Had an over the air Navigation update today.
     
  43. WarwickBoy

    WarwickBoy Active Member

    226
    78
    28

Share This Page

Do Not Sell My Personal Information