Maf Sensor Help Please!!

dplovin

Registered User
right heres the problem.......... my car judders like **** when you excelerate, boost levels are up and down all over the place and it idles like a bag of ****e, so i unplugged the maf sensor and it idle'd fine and took it for a spin and the juddering stopped it drove ok just hardly no boost, but with the maf sensor unplugged that was expected.

so faulty maf??? bought one of ebay £45 from a guy who was breaking an s3, fitted it today and still the ****** same. car juddrering and boost levels all over the show. unplugged Fine.

so either the guy has sold me a faulty maf or could the problem be something else , thats were u guys come in? help please!!!

just to note my cars coilpacks blew a couple of days ago had them all repaced and the problem has occured ever since then
 

A3 T

Lord Of The Rings

dplovin

Registered User
ive only got vcds lite and that hasnt thrown any faults up but it stops halfway through the full scan and says you have to register to go further, sumat like that anyway.

faulty turbo?

dave your right buddy but as i only had £45 in my bank i was desperate. my mate has a leon cupra r would his fit mine? i could just use his just to point out its defanately that
 

s3dave

TFSI Hybrid
Supporter
ive only got vcds lite and that hasnt thrown any faults up but it stops halfway through the full scan and says you have to register to go further, sumat like that anyway.

faulty turbo?

dave your right buddy but as i only had £45 in my bank i was desperate. my mate has a leon cupra r would his fit mine? i could just use his just to point out its defanately that

Yes your mates will fit...
 
Top