1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Lost 40bhp somewhere...

the.buried Oct 25, 2019

  1. the.buried

    the.buried Registered User

    4
    0
    1
    Hi, been a long time lurker and usually found answers to my questions without having to post (or even join to be fair) but I’m a bit stuck.

    Bought my 2005 A4 Avant B7 in June. It’s a 2.0tdi with 130k Miles and has always felt underpowered compared to my A3(2.0tdi) but I put it down to it being a bigger car. I had problems with the EGR (now been deleted) which I assumed was the main cause but and it’s been better but I’ve had it on the rolling road this morning and it’s running 99bhp.

    There’s no lights on the dash, no discernible noises and I get that older cars usually lose some power over time but 40bhp seems quite a bit!

    Anybody else had similar problems or get any recommendations as to where to start looking?
     
  2. Avatar

    snack-media
    Advertisement


  3. Gazwould

    Gazwould Registered User

    7,736
    3,127
    113
    Any attention to the dodgy oil pump drive ?
     
  4. the.buried

    the.buried Registered User

    4
    0
    1
    Not looked at it to be honest...is it a common problem for these?

    just to add to my original post, it feels most under powered below 2k revs in first and second gear. Once the turbo kicks in it’s ok (ish)
     
  5. Gazwould

    Gazwould Registered User

    7,736
    3,127
    113
    Yes serious issue .

    Double issue BLB by any chance ?
     
  6. the.buried

    the.buried Registered User

    4
    0
    1
    Sorry bud, not sure what you mean?
     
  7. Gazwould

    Gazwould Registered User

    7,736
    3,127
    113
    BLB engine code ?
     
  8. jay1601

    jay1601 Registered User

    1,416
    117
    63
    Have a look at the intake manifold see if that’s full of carbon build up/oil

    slight boost leaks

    turbo vains, make sure fully free and moving easily

    Get it remapped, my pd140 always felt sluggish, getting it mapped helped a lot
     
  9. the.buried

    the.buried Registered User

    4
    0
    1
    thanks...I’ll have look (it was remapped while on the Dyno . Up to 130 now but still want my other 40)
     

Share This Page

Do Not Sell My Personal Information