LED Rear Light Retro Fit to Avant

Charlie23

Registered User
Hi Guys,

Some help needed pretty please. I have read probably about 56 different post's on 6 different forums regarding the retro fit of Pre-facelift LED rear lights on a 2009 Avant with Halogen rear lights.

I have read loads of different scenarios needed/fitted etc, people just plug and play with coding, people buying modules, so was wondering what do I actually need?

I have bought the Lights from a 2012 Avant. I'm currently looking for harness adaptors as I'm 99% sure the plugs are different, and the coding is not a problem there is a Audi specialist around the corner from me.

Is that all that is needed?

Only place I can find the correct harness is from Kufatec @ £198

Any help guys and gals would be much appreciated as my eyes are now square from reading so many posts but not getting a real answer?
 

Charlie23

Registered User
:sos:
 

Charlie23

Registered User
Hi guys.

Lights are all fitted and codes with no errors but I’m sure I might have a problem haha

Looking at the lights the inner middle light is constantly on? Looking at other A4 Avants I’m sure this is the brake light but I might be wrong?

Have posted a pic. Is it right, is it wrong or any answer/help much appreciated

Cheers
 

Attachments

  • 3845551D-BBD0-4E49-A047-592D3A4308DD.jpeg
    3845551D-BBD0-4E49-A047-592D3A4308DD.jpeg
    1.5 MB · Views: 87
  • 8A78C204-EB46-4927-A6F3-42053CBDF488.jpeg
    8A78C204-EB46-4927-A6F3-42053CBDF488.jpeg
    1.5 MB · Views: 80

sixpot

Registered User
Should just be the outer LED's lit up when your not braking.
These are what mine look like
19904877_1761471740535824_5456729576760368697_n.jpg
 

Charlie23

Registered User

Charlie23

Registered User
Would it be a coding issue?
 

Charlie23

Registered User
Hopefully coding.

What is the light? Is it brake light that’s on?
 

Audigit

Active Member
VCDS Map User
It looks like the fogs?

That’ll be an adaptation change needed. Easy enough for someone that knows.

What BCM2 module do you have?
 

Steveredman

Registered User
When switching from halogen to led on this model (I had it done on mine and watched closely) there needs to be a wire added to link the tailgate lights with the wing lights, the reason being that the halogens have tail / brake on the wing light and tail only on the tailgate light. The extra wire takes the brake signal to the tailgate lights as well.

When tail lights are on the ring of LEDs should be lit but not 100% brightness. The inner part should be off. When you brake the ring of LEDs should get brighter and the inner part lights up on all 4 parts. The rear fog is a separate halogen bulb.

I hope this helps a bit.


Sent from my iPhone using Tapatalk
 

Charlie23

Registered User
Sorry for the late reply.

All sorted now, it was a coding issue. All works perfectly like it should. :)
 

Attachments

  • audiled.jpg
    audiled.jpg
    27.4 KB · Views: 83

And

Registered User
Have you got a blow by blow account (with ) step or completd wiring pics of the upgrade. Perhaps you also have the various part numbers I'll need to source the parts?
You seem to have found a simple way of doing what needs doing! adding the requried codes would also be really helpful.

thank you
 

Charlie23

Registered User
Hi mate,

Yes I have found an easier way BUT it wasn't me that done the work but my way is a lot easier and cheaper.

1) Source the Lights - £229 from ebay I paid

2) If your on Instagram search - Audiretrofit - Guy from London charged me £150 for fitting etc.

So that's full LED lights for £379 = Bargain
 

Audigit

Active Member
VCDS Map User
The only part of the fit that has any difficulty is removing the tailgate/boot trim to run an extra wire on either side (for the inner indicator LEDs). The rest is just re-pinning the plugs for the outer lights, changing the plug and pin type for the inner lights and coding. You can wire it in such a way that you can use ANY module but this isn't factory and involves disabling the bulb warning for the rear lights.
 
Top