Kenwood DMX8019DABS - A3 8P Install

davemark

Registered User
Hey All

Been toying a while now to upgrade my Stereo in the A3 , i had the RNS-E however while it was great, satnav was a ball / clunky to program and no decent way to stream spotify via bluetooth.

So decided to go down the CarPlay route and get the Kenwood DMX8019DABS

My Car is a A3 2012 8P with Full Bose System

This is the fitting kit i used - https://connects2.com/Product/ProductItem/CTKAU01

And the stereo it self is - https://www.kenwood-electronics.co.uk/car/nav_mm/carplay-mm/DMX8019DABS/?view=details

The install it self is pretty straight forward like many the hardest part was running cables, i wanted to get more custom steering wheel control but for now got everything i needed only one i wanted was a Siri button for carplay but if i had that working then my phone pick up would not (gave up lol) just enabled the Hey Siri mode and works well.

Coupe of little niggles i need to sort out

1. There is a little bit of an alternator hum , need to check grounds , any views on what to make better ? or do i just go and get a Ground loop isolator?
2. Not sure if part of the Bose System is still active as the levels seem to increase on their own sometimes and i get odd hiss now and then , im pretty sure i read somewhere there was something called "GALR" or something like that that may still be active ? Apart from that the Bose system is working well
3. May trim the surround panel in alcantara but we will see :)

Few Pics

4.jpg>


3.jpg


Dab & GPS

1.jpg


Mic

2.jpg


The actual stereo it self is pretty darn good , i would have preferred something more flush with out the buttons sticking out the bottom but i wanted Wireless Carplay and this was a good all rounder and picked up for £399 in some black Friday / super crazy Monday lol deal

Just thought i would stick it up and get some help on the above questions but also if it helps anyone else out or have any questions around bose etc i see quite often Bose issues on here .

i'm likely to completely replace the Bose eventually to something more modern

Overall happy with the install but still got a bit of tinkering to do!

Also once happy i will be selling my RNS-E and the Audi MMI stuff soooooon .. keep eye out on for sale pages :)

Cheers All

Dave
 

Ryan Lodge

Registered User
hello mate nice right up.
Iv got same car and head unit and iv just orded the same kit waiting for it to come.
When u done the Steering wheel controls did u plug in the 3.5 jack as well as the blue/yellow wire from the head unit? Cheers
 

davemark

Registered User
hello mate nice right up.
Iv got same car and head unit and iv just orded the same kit waiting for it to come.
When u done the Steering wheel controls did u plug in the 3.5 jack as well as the blue/yellow wire from the head unit? Cheers

Hey dude thanks ,

The steering wheel control was the single most frustrating part as i spent so long trying to figure out how to get the mode button to work . i managed to do it with the jack in and do some learning but then the call pickup and other buttons would not work so eventually i just used the blue/yellow wire and accepted that Vol up and down works / next and previous track works , and to answer a call is the voice button (if you have it that is) .. the mode now is redundant as its just trying to flick though to the factory blueooth / factory radio. (all which don't exist)

Hope that makes sense , let me know how you get on and if you do some how get a better outcome with the factory control .. what i wanted originaly is the voice button to be siri and the mode button to be answer and hang up call but could never get that to work .. in the end i just enabled the hey siri feature and i just shout at the car when i want to make a call

it seems i can get siri to be the voice button but then other buttons did not work (cant remember what now) i could never get it all working so i accepted to have whats default out the box with the cable rather than the jack plug.


Cheers

Dave
 
Last edited:

Ryan Lodge

Registered User
Ok mate yer I let u no how I get on.
Where did u connect the blue/yellow too wire?
Does the wiring lom come with a manual or any think lol. Cheers
 

davemark

Registered User
The loom on the radio is marked steering control and the car loom adaptor is labelled i just used a bullet connector and popped them together
 

Ryan Lodge

Registered User
Sweet cheers. Yer mine is all installed and working. I connoted the blue/yellow to the key one cable with a bullet like u have. Im happy with it. All the button work apart from the mode button on the left. Does yours work? I can hold the phone button (on the right) and it goes though the sources.
 

CJMC

Registered User
Great work on the head unit, looks decent!

I have just bought a 7018DABS for the wires A3... would I need a canbus to override any battery issue at all? i don't have buttons on the steering wheel so that's not an issue, just looking at what kit i need to get it all installed. Was it plug and play with the kit you listed? (i also don't have Bose)

Thanks in advance - great write up ... cheers!
 

davemark

Registered User
Sweet cheers. Yer mine is all installed and working. I connoted the blue/yellow to the key one cable with a bullet like u have. Im happy with it. All the button work apart from the mode button on the left. Does yours work? I can hold the phone button (on the right) and it goes though the sources.

Ryan did you ever get your steering wheels controls to work and if you did i cant for the love of me get it so the speach button triggers siri ,, only way i have managed to do this is using they "hey siri feature" .. once on a call the voice button short press puts them on hold and long press cuts call which is fine but was hopeing for a one button on the wheel to be siri and it just wont work :p
 
Top