1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Karacher K4

AlS3BE Sep 14, 2019

  1. AlS3BE

    AlS3BE Well-Known Member

    2,899
    1,659
    113
    hi folks
    Any of you had problems with the gun?
    Had mine a few months now and the gun seems to be gripping on the yellow bit inside the lance.
    Annoying as he11 as you need a pair of long nose pliers to get it out and it’s a pain swapping between the attachments like the snow foam bottle.
    Never had a problem like this in my old k2 which lasted years.
    I’ve tried a bit of lube/grease and this didn’t help.
    Any ideas?

    Cheers
    Al
     
  2. Avatar

    snack-media
    Advertisement


  3. Adam14

    Adam14 Well-Known Member Team Glacier Team V6 Audi S5 Coupe

    1,860
    1,683
    113
    Never had this issue (touch wood) and mine is nearly a year old now!

    Can't offer any advice on it but my go to is WD40 when things are supposed to move and don't

    Sent from my SM-G965F using Tapatalk
     
    AlS3BE likes this.
  4. AlS3BE

    AlS3BE Well-Known Member

    2,899
    1,659
    113
    Wd40 was first then silicon grease neither helped
     
    Adam14 likes this.
  5. Rugslasher

    Rugslasher Member

    38
    16
    8
    Send it back under warranty, they sorted mine in 14 days, mine was switching on/off & when it came back I got all new hose & attachments including the old ones
     
    Bishop187 and AlS3BE like this.
  6. jassyo06

    jassyo06 Mr.Grumpy ! S3 Saloon Audi S3 Black Edition Porsche Voodoo Blue

    18,053
    36,894
    113
    Use some scotch brite on the part of the lance that turns in the gun..or even use a file on it
     
    AlS3BE likes this.
  7. AlS3BE

    AlS3BE Well-Known Member

    2,899
    1,659
    113
    See what Kärcher says first before I start attacking it.
    Annoying as it was fine for ages and like a part has expanded somehow and causing attachments to get stuck.
     
  8. AlS3BE

    AlS3BE Well-Known Member

    2,899
    1,659
    113
    Well it’s going back to karcher tomorrow.
    hopefully it comes back quick
     
  9. AlS3BE

    AlS3BE Well-Known Member

    2,899
    1,659
    113
    Well after a few weeks and a failed pickup from karcher I finally got it back. All attachment and lance seems to connect well without ripping each other apart. They also fixed the motor as it was switching itself on and off every so often.
    I don’t need to wash my car like a caveman with a garden hose and a bucket and sponge now :wink:
    upload_2019-10-24_16-42-14.jpeg
     
    Sandra likes this.
  10. Sandra

    Sandra Administrator Staff Member Administrator TeamMisano TFSI Owners Group Audi S3 quattro Platinum Supporter S tronic Audi Main Dealer

    31,318
    14,211
    113
    Weather to be good sat/Sunday Al so you test it out to see it working like it should. :)
     
    AlS3BE likes this.
  11. Rugslasher

    Rugslasher Member

    38
    16
    8
    Glad you got it sorted , when they took mine & bench tested it they replaced everything but the outer case I did wonder why they didn't just replace the whole unit but been good ever since
     
  12. Avatar

    snack-media
    Advertisement


  13. AlS3BE

    AlS3BE Well-Known Member

    2,899
    1,659
    113
    thats was pretty much what the slip inside the box said on mine. New lance and high pressure hose as well and I got an extra attachment with it as well.
     
    Rugslasher and Sandra like this.

Share This Page