1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Interior Light Problem

6833jon Oct 18, 2013

  1. 6833jon

    6833jon Registered User

    54
    4
    8
    I am having a few problems with the interior lights on my a6 estate, and was wondering if anybody could help. It seems that the lights above the rear seat do not work when the doors are open, or if you position the switch to on... they only work if you turn the front light on (although the 2 individual reading lights work off their individual switches. Also the boot light doesnt work - with the exception of this morning when it worked once, but now isn't again!!

    To top it off there is water leaking from the boot light - at a guess I would imagine the aerial is leaking.

    Any ideas gratefully received guys!
     
  2. Avatar

    snack-media
    Advertisement


  3. TYphoon GB

    TYphoon GB Registered User

    386
    27
    28
    First check the power is getting to the light fitting. If your getting water in the roof from the aerial seal and or the roof bar seals the connectors and the switch can corrode. A light coat of silicone sealant on a cotton bud stick (not the cotton end) will sort that.

    Ideally remove the whole light assembly (gently old plastic will break) and check it direct. They are 3 position switches.

    The light in the load area is driven from a microswich on the lock mechanism. Note all the interior lights are driven through the central locking unit. If that's 'damp' more things will fail.

    Remove the cover and try a few manual presses.

    I think its linked to the 12v supply (option) so check all the fuses.

    Multimeter will help.

    [​IMG]

    [​IMG]

    Excuse the split images...
     
  4. 6833jon

    6833jon Registered User

    54
    4
    8
    Thanks for that. Ordered a new seal for the aerial, thanks to tonya4 for the spanner!! Also sorted me out with a different circuit board for the boot light - working ok now and no water from yesterdays / last nights rain so fingers crossed!
     
  5. gtiboy

    gtiboy Registered User

    142
    6
    18
    Just out of intrest where is the circuit board for the boot light ?
     
  6. 6833jon

    6833jon Registered User

    54
    4
    8
    Its on the back of the light. Luckily for me is same light for A4 and A6
     
  7. gtiboy

    gtiboy Registered User

    142
    6
    18
    THANKS ! I have been having the same problem so great threat .
     
  8. 6833jon

    6833jon Registered User

    54
    4
    8
    Just a quick update, changed the light above the rear seat for one off ebay, and it is now working fine - so must of been a fault on the circuit board
     
  9. TYphoon GB

    TYphoon GB Registered User

    386
    27
    28
    Just for reference

    [​IMG]

    Access

    [​IMG]

    Manky seal exposed

    [​IMG]

    PCB on base.
     
  10. gtiboy

    gtiboy Registered User

    142
    6
    18
    Sorry for silly question in advance !
    is the pcb for the light or for the ariel?
    just checking i am assuming its for the ariel (just want to be sure )
    thanks
     
  11. 6833jon

    6833jon Registered User

    54
    4
    8
    Thats the pcb for the aerial. The light pcb is on the back of each light unit P1100116.jpg
     
  12. Avatar

    snack-media
    Advertisement


  13. gtiboy

    gtiboy Registered User

    142
    6
    18
    cheers pal !
    didnt want to nuke anything that didnt need touching. lol
     

Share This Page

Do Not Sell My Personal Information