1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Help Please Install Aftermarket S-Line Badge

FliP0x Feb 13, 2019

  1. FliP0x

    FliP0x New Member

    19
    0
    1
    Hello,

    I own a 2013 B8 Model (apparrently it is a belgian variant, if that matters) and it's a regular fit.

    My intention is to make my own S-Line variant with several upgrades and the parts for the first step have just arrived in the mail today.

    I ordered a aftermarket S-Line badge for the front grille. Mounting should be simple, as you simply push it in and secure with 2 clips on the other side.

    However...

    I happen to have a "wide gap" grille and have no way to mount it the way it is meant to be mounted. I was thinking of maybe glueing it in place with silicone, but I think it would just fall off after a while.

    Below you can see pictures of my front grille. There seem to be attachments to the left side of the grille where the S-Line badge would usually be and they are not present on the right side, but I cannot figure out how to attach it.

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
  2. Avatar

    snack-media
    Advertisement


  3. Riccird1

    Riccird1 New Member

    28
    17
    3
    Looks like you just slide those metal-clips on from "behind" the grill towards the front on those plastic clips and then slide the emblem into the metal-clips from the front
     
  4. FliP0x

    FliP0x New Member

    19
    0
    1
    I tried, but the provided clips are too short. Most likely they were meant for a different front bumper.

    I've been searching around and found several old topics about the same problem.

    The proper clips look like this
    [​IMG]

    I've been searching just for clip replacements, but without success so far. What I might try today is to remove the plastic cover on the front below the hood to get better access to the front grille and see how I could mount the emblem, maybe with zip ties or a sturdy wire.


    Edit:
    Actually, the clips I got are for bumpers in which you simply slot it in from the front. The bumper I have has a mechanism to slide it in from behind, so the provided clips lie too low and are not compatible.
     
  5. Phil.MC

    Phil.MC Active Member Sportback Team Votex Team V6 TDi Audi A4 A7 Owner Group

    169
    34
    28
    I used araldite epoxy resin to attach my Quattro badge to a Votex mesh grill on my B6 A4 years ago...Was a good permanent fix :thumbs up:.
     
  6. FliP0x

    FliP0x New Member

    19
    0
    1
    I have several silicone sealant tubes lying around so what I think I'll do is to attach the back side of the emblem with zip ties and if the front wiggles I will glue it in place with silicone. That could work, at least until I order a proper one.
     
  7. FliP0x

    FliP0x New Member

    19
    0
    1
    Tried, no luck. There is no way to get it to stay in place.

    Will have to order a proper one.

    EDIT:

    Does anyone know where I might be able to get a original one?

    This one might also not fit due to the shark fins and the plastic looks too thick.

    [​IMG]
     
    Last edited: Feb 14, 2019

Share This Page