Help with Air con not working

Stu_b7

Registered User
Hi guys hope everyone is staying cool in this heat as I’m definitely not!
So a few weeks ago I had my air con re gassed and all was great now nothing at all just lukewarm air, I still get hot air but only when on Hi turn it down a couple of degrees and nothing but that may be due to this weather.
I done an OBD and had coolant temp sensor come up so I’ve replaced that and no more codes at all but still no air con?
Haven’t taken it out for a drive since done the sensor only on idle but definitely still not working anything else I can check to narrow it down?
Cheers
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
G65 pressure switch is common issue, does the Econ light turn of when you put aircon on?

Compressor maybe also the issue.
 

Tyrer

Registered User
I had the same problem on my old B7 - turned out to be the compressor unit. Tell tale sign is no issues in relation to leaks and when you press the the button it clicks and you hear the unit but nothing happens.

And today I found that my C6 A6 has just had the same fault happen, so I am in the process of looking to replace the compressor on that.

Budget £2-400 for the compressor unit brand new depending on what make you go for. The whole system needs emptying and cleaning out so the job can cost a fair bit depending on the unit you buy.

Good luck, I’m in the same boat


Sent from my iPhone using Tapatalk
 

Stu_b7

Registered User
G65 pressure switch is common issue, does the Econ light turn of when you put aircon on?

Compressor maybe also the issue.
Yeah the light stays off when I press it and when I turn the unit to low the engine idles different so feels like something is trying to happen
 

Stu_b7

Registered User
I had the same problem on my old B7 - turned out to be the compressor unit. Tell tale sign is no issues in relation to leaks and when you press the the button it clicks and you hear the unit but nothing happens.

And today I found that my C6 A6 has just had the same fault happen, so I am in the process of looking to replace the compressor on that.

Budget £2-400 for the compressor unit brand new depending on what make you go for. The whole system needs emptying and cleaning out so the job can cost a fair bit depending on the unit you buy.

Good luck, I’m in the same boat


Sent from my iPhone using Tapatalk
Ok I hope not I did check my pollen filter and it’s pretty awful so getting a new one put in today as I’ve heard that it can stop it aswell starting with the small things first
 

Attachments

  • 4471D748-4DFE-4CCF-A2F2-8E187F6FDE34.jpeg
    4471D748-4DFE-4CCF-A2F2-8E187F6FDE34.jpeg
    2 MB · Views: 12

Charlie Farley

Chilling out.
Staff member
Moderator
VCDS Map User
Gold Supporter
Ok I hope not I did check my pollen filter and it’s pretty awful so getting a new one put in today as I’ve heard that it can stop it aswell starting with the small things first
looks like mine was, and mine was only 12 months old, and i had a small friend living in it too, cant say it made any difference to the air con operation though, but worth doing it just on the basis it's in need of replacement.
 

Stu_b7

Registered User
G65 pressure switch is common issue, does the Econ light turn of when you put aircon on?

Compressor maybe also the issue.
Would I get a code come up if this was faulty I’ve used my obd eleven and it’s coming up code free?
 

Klt3

New Member
Hi all... Got the same problem... A3 1.8T cabriolet 2008... When I switch the aircon on the light goes out & nothing, got new sensors & it still does the same thing... I was told by 2 people that it might be the compressor...
 

B7Tourer

Active Member
Would I get a code come up if this was faulty I’ve used my obd eleven and it’s coming up code free?
It certainly sounds like your compressor. I had the classic rattly pulley on mine since I got it, though it worked fine. Then last summer I switched it off mostly and when I came to use it fully around Easter it had stopped working - the econ light stayed off too. OBDEleven showed nothing wrong, as well. I had a new compresser fitted for about £200 + labour and it works perfectly now. It's also nice to have no rattle at last too. Make sure you get a new dryer fitted at the same time as the compressor, they are only about 15 quid more.
 
Last edited:

NM07

Active Member
Gold Supporter
It certainly sounds like your compressor. I had the classic rattly pulley on mine since I got it, though it worked fine. Then last summer I switched it off mostly and when I came to use it fully around Easter it had stopped working - the econ light stayed off too. OBDEleven showed nothing wrong, as well. I had a new compresser fitted for about £200 + labour and it works perfectly now. It's also nice to have no rattle at last too. Make sure you get a new dryer fitted at the same time as the compressor, they are only about 15 quid more.
I have exactly the same issue, no codes, everything checks out when scanning. Certain my compressor is dead, so I spoke with Audi who wanted £850 for a replacement (that's just parts!!). Where did you get your compressor from for £200? Would be happy to pay that.
 

B7Tourer

Active Member
I have exactly the same issue, no codes, everything checks out when scanning. Certain my compressor is dead, so I spoke with Audi who wanted £850 for a replacement (that's just parts!!). Where did you get your compressor from for £200? Would be happy to pay that.
Local garage supplied it but if you look at the better Motor Factors online, they are all about that price, OEM included. I have never gone near an Audi dealer since I've had the car. A friend, Peter who is a senior Master mechanic at one, told me he hasn't even seen a B7 in years, at his place. I had a new Heater Matrix fitted at the same time (which I supplied) and both cost, with labour, £500 fitted, with the matrix being by far the lion share of labour costs.
 
  • Like
Reactions: tr7

NM07

Active Member
Gold Supporter
I've just had a little search online and you're right, just seen a Denso OEM unit for just shy of £200 delivered. Crazy what Audi think they can get away with charging for the same part. Will get that ordered next week, be nice to have working A/C again.
 

Stu_b7

Registered User
It certainly sounds like your compressor. I had the classic rattly pulley on mine since I got it, though it worked fine. Then last summer I switched it off mostly and when I came to use it fully around Easter it had stopped working - the econ light stayed off too. OBDEleven showed nothing wrong, as well. I had a new compresser fitted for about £200 + labour and it works perfectly now. It's also nice to have no rattle at last too. Make sure you get a new dryer fitted at the same time as the compressor, they are only about 15 quid more.
Yeah it has to be the compressor which I should have known it was going to be the worst case and most expensive part to go wrong, it is an Audi after all!
Well looks like I’m on the hunt for a new compressor now, any recommendations for makes?
Cheers guys for the help shame it’s come down to something I can’t do myself tho.
 

Stu_b7

Registered User
I've just had a little search online and you're right, just seen a Denso OEM unit for just shy of £200 delivered. Crazy what Audi think they can get away with charging for the same part. Will get that ordered next week, be nice to have working A/C again.
What site was that from as I definitely will need a new one
 

NM07

Active Member
Gold Supporter

NM07

Active Member
Gold Supporter
Going to give them a call tomorrow and see which one they recommend.
 

Charlie Farley

Chilling out.
Staff member
Moderator
VCDS Map User
Gold Supporter
looks like a lot of you guys have been unlucky with the Air con recently.
I allways leave mine on just in case it stops and then wont come back on, may have to invest in a spare compressor just in case.
 

NM07

Active Member
Gold Supporter
It could have chosen a better time to give up the ghost :sweat::blacksunrays:
 

B7Tourer

Active Member
looks like a lot of you guys have been unlucky with the Air con recently.
I allways leave mine on just in case it stops and then wont come back on, may have to invest in a spare compressor just in case.
To be fair I had a good run with mine. I bought the car cheap because, for one reason the aircon didn't work. I took it round the corner re-gassed it for 40 quid and it blew ice cold for nearly 5 years! The rattle bugged me more though. It is very wise advice Rob, to leave the air con on permanently, I find it causes a very small economy penalty. At least it is essential to put it on regularly each week for an hour or so. It is necessary for the system lubrication. BTW I obviously meant to say earlier, 'Last winter I mostly switched it off' not summer, which would make no sense. Now it's staying on, all the time.
 
Top