1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Heater element faulty but runs on output test

86kotek Sep 20, 2018

  1. 86kotek

    86kotek New Member

    16
    0
    1
    So as per title, im getting errors 'heater element faulty' but when i run output tests it works perfect, i bought another aux heater and is doing exactly same thing (although i cant reset codes on it for some reason).
    Anybody have a clue why is that?
    Bad solders maybe?
    2004 8p BKD
     
  2. Avatar

    Google AdSense Advertisement


  3. 86kotek

    86kotek New Member

    16
    0
    1
    And to add to it i just realized that another fault code:

    01207 - Control Module for Auxiliary Heater (J364)

    Is for fuel driven heater which my car does not have installed
    I can acces 7D for the electric one and i have issue with it described in my first post above but trying to access 18 is a no go, i think i would have known if i had one
     
  4. Sandra

    Sandra Administrator Staff Member Administrator TeamMisano TFSI Owners Group Audi S3 quattro Platinum Supporter S tronic Audi Main Dealer

    30,007
    12,828
    113
    @86kotek was the car scanned with vcds? If so can you put up the printout for us.
     
  5. 86kotek

    86kotek New Member

    16
    0
    1
    @Sandra

    Hello, this is today's scan but without Heater Element Faulty, because I installed my old unit on which I resoldered the transistors so there is no code yet, will come back soon. Anyway, it is not working, but output tests are fine it is heating then up until I shut the test off.
    I have the left positioning motor out just to get clear access to the heater element and by mistake, I ran adaptation which threw other codes.
    Originally my heater element (and another I got from ebay) gave this code:

    00361 - Heater Element for Auxiliary Heater (Z35)
    014 - Defective

    Both are able to run output tests. I also have a third defective one which throws above code straight away and is unable to run output tests
    It is interesting I have codes for J364 which is not installed in the car

    Chassis Type: 8P (1K0)
    Scan: 01 03 08 09 15 16 17 19 25 42 44 46 47 52 56 7D

    VIN: WAUZZZ8PX4A125135 Mileage: 362280km-225110miles

    00-Steering Angle Sensor -- Status: OK 0000
    01-Engine -- Status: OK 0000
    03-ABS Brakes -- Status: OK 0000
    08-Auto HVAC -- Status: Malfunction 0010
    09-Cent. Elect. -- Status: Malfunction 0010
    15-Airbags -- Status: Malfunction 0010
    16-Steering wheel -- Status: OK 0000
    17-Instruments -- Status: OK 0000
    19-CAN Gateway -- Status: OK 0000
    25-Immobilizer -- Status: OK 0000
    42-Door Elect, Driver -- Status: OK 0000
    44-Steering Assist -- Status: OK 0000
    46-Central Conv. -- Status: Malfunction 0010
    47-Sound System -- Status: OK 0000
    52-Door Elect, Pass. -- Status: OK 0000
    56-Radio -- Status: OK 0000
    7D-Aux. Heat -- Status: OK 0000

    -------------------------------------------------------------------------------
    Address 01: Engine Labels: 03G-906-016-BKD.lbl
    Part No SW: 03G 906 016 G HW: 028 101 136 4
    Component: R4 2,0L EDC 0210SG 5705
    Revision: 12345678 Serial number: AUX7Z0CDFN40J9
    Coding: 0000072
    Shop #: WSC 06435 000 00000
    VCID: 27B8221356E2442AA4B4E6-8072

    No fault code found.
    Readiness: 0 0 1 1 1

    -------------------------------------------------------------------------------
    Address 03: ABS Brakes Labels: 1K0-907-379-MK60-F.lbl
    Part No: 1K0 907 379 K
    Component: ESP FRONT MK60 0103
    Coding: 0023174
    Shop #: WSC 06435 000 00000
    VCID: 3A9EEB67B550C9C2CB7AD7-806E

    No fault code found.

    -------------------------------------------------------------------------------
    Address 08: Auto HVAC Labels: 8P0-820-043.lbl
    Part No SW: 8P0 820 043 D HW: 8P0 820 043 D
    Component: KlimavollautomatH12 0150
    Revision: 024619 Serial number: 8P0820043D
    Shop #: WSC 00000 000 00000
    VCID: 2DB4D03B741E6E7A5EF8A4-8078

    3 Faults Found:
    01207 - Control Module for Auxiliary Heater (J364)
    004 - No Signal/Communication
    Freeze Frame:
    Fault Status: 01100100
    Fault Priority: 3
    Fault Frequency: 1
    Reset counter: 46
    Mileage: 361866 km
    Time Indication: 0
    Date: 2018.09.10
    Time: 11:34:19

    Freeze Frame:
    ON

    01087 - Basic Setting Not Performed
    005 - No or Incorrect Basic Setting / Adaptation
    Freeze Frame:
    Fault Status: 01100101
    Fault Priority: 3
    Fault Frequency: 1
    Reset counter: 86
    Mileage: 362282 km
    Time Indication: 0
    Date: 2018.09.22
    Time: 12:26:49

    Freeze Frame:

    01841 - Potentiometer/Actuator for Temperature Flap; Left (G220)
    010 - Open or Short to Plus
    Freeze Frame:
    Fault Status: 01101010
    Fault Priority: 3
    Fault Frequency: 1
    Reset counter: 46
    Mileage: 362282 km
    Time Indication: 0
    Date: 2018.09.22
    Time: 11:56:36

    Freeze Frame:
    Voltage: 11.90 V
    (no units): 255.0
    Temperature: 11.5°C


    -------------------------------------------------------------------------------
    Address 09: Cent. Elect. Labels: None
    Part No HW: 8P0 907 279 D*
    Revision: 00028000 Serial number: 00000000407701
    Coding: E5885F00A3141000000000000000000000
    Shop #: WSC 12345 123 12345
    VCID: 554458DB3C0E06BAC668FC-8000

    2 Faults Found:
    01207 - Control Module for Auxiliary Heater (J364)
    004 - No Signal/Communication
    02071 - Local Databus
    004 - No Signal/Communication

    -------------------------------------------------------------------------------
    Address 15: Airbags Labels: 8P0-959-655-84.lbl
    Part No SW: 8P0 959 655 D HW: 8P0 959 655 D
    Component: Airbag 8.4ED H00 0130
    Coding: 0011602
    Shop #: WSC 06435 000 00000
    VCID: 43609683C29A880A989CB2-8016

    2 Faults Found:
    01228 - Airbag Cut-Off Switch for Passenger Side (E224)
    010 - Open or Short to Plus - MIL ON
    01228 - Airbag Cut-Off Switch for Passenger Side (E224)
    010 - Open or Short to Plus - MIL ON

    -------------------------------------------------------------------------------
    Address 16: Steering wheel Labels: 1K0-953-549-MY8.lbl
    Part No SW: 1K0 953 549 A HW: 1K0 953 549 A
    Component: Lenksäulenmodul 012 0030
    Coding: 0000012
    Shop #: WSC 06435 000 00000
    VCID: 308AC94F632C039275DE45-8064

    No fault code found.

    -------------------------------------------------------------------------------
    Address 17: Instruments Labels:
    Part No SW: 8P0 920 980 H HW: 8P0 920 980 H
    Component: KOMBIINSTR. VDO H25 0110
    Coding: 0004443
    Shop #: WSC 00258 898 00000
    VCID: 3C92ED7FBF64F7F2D966C1-8068


    -------------------------------------------------------------------------------
    Address 17: Instruments Labels: 8P0-920-xxx-17-MY7.lbl
    Part No SW: 8P0 920 980 H HW: 8P0 920 980 H
    Component: KOMBIINSTR. VDO H25 0110
    Revision: D07 Serial number: 224DCD07003369
    Coding: 0004443
    Shop #: WSC 00258 898 00000
    VCID: 3C92ED7FBF64F7F2D966C1-8068

    No fault code found.

    -------------------------------------------------------------------------------
    Address 19: CAN Gateway Labels: 1K0-907-530-V1.clb
    Part No SW: 1K0 907 530 B HW: 1K0 907 951
    Component: Gateway H08 0090
    Revision: 08 Serial number: 2400103C05B0DA
    Coding: 3D0F0B42070101
    Shop #: WSC 06435 000 00000
    VCID: 26A62F1751E85D229F42F3-8072

    No fault code found.

    -------------------------------------------------------------------------------
    Address 25: Immobilizer Labels: 1K0-920-xxx-25.clb
    Part No SW: 8P0 920 980 H HW: 8P0 920 980 H
    Component: KOMBIINSTR. VDO H25 0110
    Revision: D07 Serial number: AUX7Z0CDFN40J9
    Shop #: WSC 00460 210 10723
    VCID: 3C92ED7FBF64F7F2D966C1-8068

    No fault code found.

    -------------------------------------------------------------------------------
    Address 42: Door Elect, Driver Labels: 8P0-959-801-MIN1.lbl
    Part No: 8P0 959 801 A
    Component: Tuersteuerger. H10 0010
    Coding: 0000120
    Shop #: WSC 06435 000 00000
    VCID: 399CF46BB056C2DAC20020-806C

    No fault code found.

    -------------------------------------------------------------------------------
    Address 44: Steering Assist Labels: 1Kx-909-14x-44.clb
    Part No: 1K2 909 144 E
    Component: EPS_ZFLS Kl.10 1202
    Shop #: WSC 00000 000 00000
    VCID: 2EB6D7377918156267F2AB-807A

    No fault code found.

    -------------------------------------------------------------------------------
    Address 46: Central Conv. Labels: 8P0-959-433.lbl
    Part No: 8P0 959 433
    Component: KSG H02 0040
    Coding: 008800186D288505485AC67000
    Shop #: WSC 00460 210 10723
    VCID: 791C346BF0D602DA828060-802C

    Subsystem 1 - Component: Sounder No Answer

    Subsystem 2 - Part No: 1K0 907 719
    Component: Neigungssensor 002 0002

    Subsystem 3 - Part No: 8P0 951 177
    Component: Innenraumueberw.H03 0010

    1 Fault Found:
    01134 - Alarm Horn (H12)
    004 - No Signal/Communication

    -------------------------------------------------------------------------------
    Address 47: Sound System Labels: 8Px-035-382.lbl
    Part No SW: 8P3 035 382 HW: 8P3 035 382
    Component: AB2 SUBWOOFERBOXH23 0100
    Revision: 00001 Serial number: 10000001053669
    Shop #: WSC 00000 000 00000
    VCID: 700A094FA3AC4392355E85-8024

    No fault code found.

    -------------------------------------------------------------------------------
    Address 52: Door Elect, Pass. Labels: 8P0-959-802-MIN1.lbl
    Part No: 8P0 959 802 A
    Component: Tuersteuerger. H10 0010
    Coding: 0000120
    Shop #: WSC 06435 000 00000
    VCID: 3A9EEB67B550C9C2CB7AD7-806E

    No fault code found.

    -------------------------------------------------------------------------------
    Address 56: Radio Labels: 8P0-035-1xx-56.lbl
    Part No SW: 8P0 035 186 HW: 8P0 035 186
    Component: concert II EU H53 0060
    Revision: 07S Serial number: AUZ2Z3C1779967
    Coding: 0001001
    Shop #: WSC 06435 000 00000
    VCID: 6F080A33BE925C6A2C649E-803A

    No fault code found.

    -------------------------------------------------------------------------------
    Address 7D: Aux. Heat Labels: 1K0-963-235.lbl
    Part No SW: 1K0 963 235 C HW: 1K0 963 235 C
    Component: PTC-Element 0404
    Revision: 00600000 Serial number:
    Shop #: WSC 00000 000 00000
    VCID: 2BB0DE234A0A604A408C8A-807E

    No fault code found.

    End-------------------------(Elapsed Time: 01:39)--------------------------
     
  6. 86kotek

    86kotek New Member

    16
    0
    1
    Hi could anybody point me in the right direction please? Is it possible that output test would still run despite it not working when it should? It does heat up on output test but will throw the
    00361 - Heater Element for Auxiliary Heater (Z35)
    014 - Defective
    after few startups in cold weather
    As i have a fulty one which throws above code straight away upon plugging in and another one i bought as a working unit from ebay which acts exactly like mine i think the fault is somewhere else but i dont have a clue where to start.
    If anybody can be of assist i would highly appreciate any help, thanks
     
  7. 86kotek

    86kotek New Member

    16
    0
    1
    These are measuring values when engine started cold. Aux off
    Photo_1538143490357.jpg next are 2 screens from output test. First few seconds and after about 10
    Photo_1538143576470.jpg Photo_1538143615891.jpg and the last one measuring values with output test still running
    Photo_1538143653930.jpg anybody can shine some light on that please?
     
  8. labanauskas

    labanauskas Member

    43
    0
    6
    Hello, i fixed mine by resoldering 5 resistors, 3 mosfets and 3 heating element endings. You don't need to replace them, just to renew soldering points. After that I was able to clear fault. Now heater works perfectly! The only problem is to remove the heater :-(
     
  9. 86kotek

    86kotek New Member

    16
    0
    1
    Hi there thanks for your reply. I ended up resoldering whole lot , no joy. And also swapping for identical working unit from my friends golf and i still cant make it to work. It has been few months now and the car is still in pieces so i can have access to it , at this point im just going to give up
     
  10. labanauskas

    labanauskas Member

    43
    0
    6
    So it still says defective?
     
  11. 86kotek

    86kotek New Member

    16
    0
    1
    Yes the same thing but i can still run output test and it heats up right away
     
  12. Avatar

    Google AdSense Advertisement


  13. labanauskas

    labanauskas Member

    43
    0
    6
    And yours fixed heater works in other car?
     
  14. 86kotek

    86kotek New Member

    16
    0
    1
    Yes it does, that made me think that maybe some conditions ( i believe it is over 500rpm and coolant below 70C)are not met to switch it on but when i look in measuring values i can see values change.
    So maybe it is the control module, but im not sure if it is defective or probably not the right model for this car
     
  15. labanauskas

    labanauskas Member

    43
    0
    6
    Econ on, +5c or lower temp outside. Only heater with E letter in the ending.

    Maybe someone could lend you vas diagnostic tool, it can delete this fault.

    Something fishy with your car...


    I've attached my z35 measuring values on just started car.
     

    Attached Files:

  16. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter Team Sprint Audi S3 Manual

    3,022
    609
    113
    It could be worth putting this on Ross-techs forum if its i genuine cable and if your a member .
     
  17. 86kotek

    86kotek New Member

    16
    0
    1
    If i had a qeniuine one i would go there first but figured if i fiddle with a knock off cable before i spending hundreds of £££ and learning along the way would be a good start. If i figure out what it was before selling the car ill definately post it here
     
  18. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter Team Sprint Audi S3 Manual

    3,022
    609
    113
    The site kinda works a policy ( as i am lead to believe ) people who know how to advise on this problem wouldn't help you out like Ross-tech don't as they would be cutting there own throat and encouraging clone cable's.
    Now if you got a Autoscan done with a genuine cable you might find you get different readings which in turn might help better with your problem.
    The site has members who would be willing to Autoscan for you ( usually a few tinnes do ) ( Vcd's map ) so worth a shout
     
    86kotek likes this.
  19. 86kotek

    86kotek New Member

    16
    0
    1
    I totally understand that, supporting genuine creators is crucial to keep them doing good work, and i dont feel particulary proud spending that money towards a knock off. As my whole family owns vag group cars i probably will invest in original one in the near future and since you mentioned i might get different readings from it that makes it very interesting. Thanks for Your time
     
  20. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter Team Sprint Audi S3 Manual

    3,022
    609
    113
    Honestly there not as expensive as you think especially if all family have Vag cars , why not chat to them and all put in to buy a 10vin hex v2 cable about £ 300/ £400 and it would save paying garages whatever they charge for a Scan as Audi are usually £100 a pop
     

Share This Page