Fuel Gauge Fault, where is my fuel sender unit

Jonny_ed_LeMans

New Member
Hi Guys,

I have got myself a 2008 A6 Avant 2.7td LeMans.

Last week the fuel gauge packed up, I went online and found a post about checking/pulling the fuse. (This worked for 3 days) since then it has not worked.

I have been mindful of range as I've got no gauge, but this morning, the car drove a short while then packed up. I had run low on fuel (not empty as I had topped the tank on Friday) so I refilled and it drives.

The error codes from the AA were something to do with instrument cluster and 3 of the glow plugs.

I have investigated possible problems and am led to believe it be something to do with the fuel sender/fuel delivery system atop the tank.

However after removing the rear bench and taking off the 2 inspection panels, I can see no fuel sender!!???? WTAF?

Where is it on my car? As I'd like to check for loose/broken wiring before suffering the main stealer price for a new unit (£400 something)

Please see attached photos
 

Attachments

  • IMG20211122103248.jpg
    IMG20211122103248.jpg
    3.6 MB · Views: 7
  • IMG20211122103240.jpg
    IMG20211122103240.jpg
    3.4 MB · Views: 7

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
Check further back at the beginning of the boot under trim or carpet.
 

Jonny_ed_LeMans

New Member
Check further back at the beginning of the boot under trim or carpet.
Yes I've found it under the tray in the boot. Short of testing it with a multimeter (the car runs when I fill it up) and limiting my distance, what option do I have without going to Audi main dealer. I don't really understand what's going on, far from a weekend mechanic
 
Top