Front wipers not working any help please.

Hi all son has a a3 2007 bmn 2.0 tdi sline 170bhp went to use his wipers this morning and they made a bit of a screech and did not move, he can still use the jets i asked him if the wiper arms were stuck to the screen he said no had a look at the fuse f19 30 amp all looks good tried a new one still nothing can't here any whining of the motor turning. So not sure if the motor has packed up, but i have been looking on the net seems that there is a micro switch in the bonnet sensor that sends a signal which works the wipers can anybody tell me if i am going in the right direction or have i lost the plot. There is no bonnet light on saying that it is open.
So what i would like to try and find out is, does anybody have a way to test the wiper arm motor or is there a way to test this bonnet micro switch.

Thanks for any help.
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
Has he fitted any aftermarket headlight parts?
 
Dont know will have to ask him and get back to you on that just spoke to my son and he said the light shows up on the dash when the bonnet is open without sounding daft is that a way of telling if something is wrong thanks for your help
 
Last edited:

aqibi2000

Registered User
Was the car iced over turned the wipers and turned the wipers on
 
Was the car iced over turned the wipers and turned the wipers on
Well i did asked him if the wipers was still stuck to the screen when he went to use them but he said no, but not so sure after he said that it made a sound like a belt on a car screeching to me it sounds like motor has tried to turn but arms were stuck, i checked the fuse with him and that was fine. And been out to the car and the dashboard does light up when the bonnet is open
 

LEE69

07 170 DSG
I think he's damaged the wiper motor tbh. When you are under the scuttle clean it all out and make sure the drain holes are clear
 
DO NOT EVEN GO DOWN THAT ROAD OMG he car was like a swiming pool drivers side floor we done all that you said and it was still leaking found out that the bonnet cable that sits in the far corner the rubber gromit was a tiny bit worn and the water was coming in there so we had to seal it and had to run a bead of sealant on the top of the scuttle panel where it meets the glass.

Can you take the wiper motor of by nut and bolt or are they pop rivet because i would rather use the linkage that is on the car rather than buy second hand as not sure if you can replace any of the rubber gromits or bushes on the linkage arms so there is no play thanks.
 
Last edited:
Top