fault codes p0441 & p0171

scotty7519

Registered User
Hi guys i have an Audi A6 2.0T Petrol 2006.
The EML came on so we plugged it in and got the P0171 code System too lean ( Bank 1) and P0441 EVAP Emission control system purge flow fault.


Are both those codes connected to the same issue?
Where is bank 1 ? the P0441 EVAP error what would I be looking for I have seen some say that there could be a leak in the system what pipes should I check, what else should I check for kinda hoping that the P0441 code issue throws up the P0171 code so that's where I want to start as that came up 1st on the fault reader.

We cleared all the codes but I know they will come back.


Cheers

Scott
 

toporivskiy

Registered User
Hello! I have the same faults on my Audi A6. Your post was published over two years ago. I guess you already fixed them.
Please tell me how did you repair the car?
 

toporivskiy

Registered User
I will write about my experience with faults too.

Audi A6 C6 (4F) - 2.0 TFSI 2007

I had two major faults P0171 (System too lean (Bank 1)) and P0441 (Evaporative Emission Control System Incorrect Purge Flow), but sometimes P0299 (Boost Pressure Regulation, Control Range Not Reached) also appeared.
On disassembling American cars, I bought for $10 used original spare part 06E906517A (fuel vent valve).
After replacing this valve and resetting errors, CEL did not light up !!!

However, fault P0299 still appears. I think I need to replace the turbocharger valve 06H145710D.

Thank you very much @scotty7519 for answering me and helping me fix the problem.
 
Top