1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine holding revs when releasing accelerator

Poobear Oct 29, 2018

  1. Poobear

    Poobear New Member

    6
    1
    3
    Strange one,

    1.9tdi 130 , 02 Audi b6

    Just this week the car holds revs for around a second before dropping when you release the accelerator. Feels very similar to leaving the cruise control on for a split second and happens at all speeds

    The car also suffers from a lumpy idle and just recently the revs shoot up to around 2k then goes down straight away to Idle level when starting the car. This is when the car is warm although pretty cold weather.

    The egr has oil residue. Could giving it a clean / changing have an affect ?

    Thanks in advance
     
  2. Avatar

    Google AdSense Advertisement


  3. QuattroCalum

    QuattroCalum Well-Known Member saloon Audi A4 Black Edition Saloon Manual

    1,870
    679
    113
    Holding revs while changing gear is usually the clutch switch, no idea with the other problem.

    Sent from my ANE-LX1 using Tapatalk
     
  4. Leo Komninos

    Leo Komninos Member

    76
    18
    8
    Is it drive by wire? If so, then acc pedal. Might be worth checking throttle positioning with vcds or alike.

    Sent from my G3121 using Tapatalk
     
  5. SemedoB6

    SemedoB6 Black and white a4

    453
    121
    43
    Clutch switch will resolve your rev problems.
    As for the lumpy idle, when it happened to me it was the temperature sensor at the back of the block. Once I swapped it it went back to normal.

    Sent from my SM-N960F using Tapatalk
     
  6. Poobear

    Poobear New Member

    6
    1
    3
    Thanks for your replys.

    The revs hold without changing gear, i could be in 4th and release the accelerator and still have the issue. I do not have to press the clutch down for this to happen.

    In terms of idle , it pretty much sits at 1200 rpm.
     
  7. SemedoB6

    SemedoB6 Black and white a4

    453
    121
    43
    Yeah. That's the clutch switch buddy. I bought one new from Audi for £20.

    And the idle I'd put my money on the temperature sensor. If you scan it I'm pretty sure you'll have the same info.
    Mine used to go up and down, rev normally and rev itself up again.
    All was cured with a new temp sensor.
    But do scan it first and be sure what's the problem.

    Sent from my SM-N960F using Tapatalk
     
  8. Poobear

    Poobear New Member

    6
    1
    3
    Thanks for the info, appreciate it .Any risk in deicing the car for now before getting the clutch switch changed?
     
  9. SemedoB6

    SemedoB6 Black and white a4

    453
    121
    43
    No. The clutch switch is just a sensor.
    You'll have the rev hang and it'll prevent you from enabling cruise control if you have it on your car.
    Everything else will work and you'll have the annoying rev hang. But no harm done to the car.
    Mine wasn't working for 2 years. And only found it wasn't working when I retrofitted the cruise control.

    Sent from my SM-N960F using Tapatalk
     
  10. Poobear

    Poobear New Member

    6
    1
    3
    Strange, the cruise control still works though. So might not be the issue
     
  11. SemedoB6

    SemedoB6 Black and white a4

    453
    121
    43
    Yeah. I was sure it was the clutch switch..
    I don't know what else it could be then. Try to get it scanned. Best option to pinpoint the exact problem.

    Sent from my SM-N960F using Tapatalk
     
  12. Avatar

    Google AdSense Advertisement


  13. Just Rob.

    Just Rob. Moderator Staff Member Moderator Team Brilliant Black Team Daytona TFSI Owners Group Team V8 VCDS Map User Audi RS4 Audi A4 Audi Avant Owner Group quattro S-line owners group Manual

    7,863
    4,128
    113
    Clutch switch , just replaced mine on a B7 , solved the issue straight away.
     

Share This Page