1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Engine fault light - help required - vcds scanned

Fatbloke Dec 11, 2019

  1. Fatbloke

    Fatbloke Registered User

    414
    135
    43
    Hi All

    A3 2016 150tdi a-line 41,000 miles.

    Engine error light came on earlier but everything seemed ok.

    Parked the car up for a couple of hours and when I went back to it the cooling fan was running. Car was very slow turnover and difficult to start. Engine warning light still on and a lights error came up too. It also said the battery was low but maybe the cooling fan had been running for a while. It wasn't doing a regen when I stopped.

    Initially thought battery or alternator.

    Scanned it when I got home and a couple of issues........


    Address 01: Engine (J623-CRLB) Labels:. 04L-907-309-V1.clb
    Part No SW: 04L 906 026 BQ HW: 04L 907 309 R
    Component: R4 2,0L EDC H23 1199
    Revision: B5H23---
    Coding: 02190012032701082000
    Shop #: WSC 06314 790 00021
    ASAM Dataset: EV_ECM20TDI01104L906026BQ 002002
    ROD: EV_ECM20TDI01104L906026BN_002.rod
    VCID: 7AFA7044FD2DD39FE9-802E

    1 Fault Found:
    4631 - ECM Power Relay Load Circuit
    P068B 00 [174] - Opens Too Late
    MIL ON - Intermittent - Confirmed - Tested Since Memory Clear
    Freeze Frame:
    Fault Status: 00000001
    Fault Priority: 2
    Fault Frequency: 3
    Mileage: 0 km
    Date: 2000.00.00
    Time: 00:00:00
    Engine speed: 0.00 /min
    Normed load value: 0.0 %
    Vehicle speed: 0 km/h
    Coolant temperature: -40 °C
    Intake air temperature: -40 °C
    Ambient air pressure: 0 mbar
    Voltage terminal 30: 0.000 V
    Unlearning counter according OBD: 40
    Accelerator pedal travel: raw value: 0.00 %
    Starter control: Interlock- or P/N-signal-Bits 0-7: 0
    Engine status: COENG_STANDBY
    Engine status-Test_Program_Co Eng st COMPU VERB UBYTE: 0
    Readiness: 1 1 0 0 0



    Address 6C: Back-up Cam. (J772) Labels:| 5Q0-980-556.clb
    Part No SW: 5Q0 980 556 B HW: 5Q0 980 556 B
    Component: RVC Compact H15 0231
    Coding: 0273100102002007400040
    Shop #: WSC 12345 123 12345
    ASAM Dataset: EV_CamSysRVRVCPANAMQBAB 006009
    ROD: EV_CamSysRVRVCPANAMQBAB_006_VW37.rod
    VCID: 3978AF48B8AB1887A0-806C
    2 Faults Found:
    10489856 - No Basic Setting
    B2010 00 [009] - -
    [New feature! Extended UDS fault detail is only supported by current gen. interfaces]
    Confirmed - Tested Since Memory Clear
    Freeze Frame:
    Fault Status: 00000001
    Fault Priority: 5
    Fault Frequency: 1
    Reset counter: 113
    Mileage: 59153 km
    Date: 2019.08.15
    Time: 13:27:35
    passive
    13705478 - Databus
    U1121 00 [009] - Missing Message
    [New feature! Extended UDS fault detail is only supported by current gen. interfaces]
    Confirmed - Tested Since Memory Clear
    Freeze Frame:
    Fault Status: 00000001
    Fault Priority: 6
    Fault Frequency: 1
    Reset counter: 113
    Mileage: 59153 km
    Date: 2019.08.15
    Time: 13:27:36
    passive


    Any ideas? It's only 6 weeks out of warranty.
     
  2. Avatar

    snack-media
    Advertisement


  3. DJAlix

    DJAlix VAG Car Coding™ Limited Site Sponsor Gold Supporter VCDS Map User VAG Can Professional ODIS (Offboard Diagnostic System)

    6,707
    5,128
    113
    Possible Engine Control module issue. Need to get this checked by a specialist. Re the camera, looks like basic settings have been lost, which should not affect overall functionality. The missing message is probably due to your having a camera installed without any parking sensors and is to be expected.
     
  4. Fatbloke

    Fatbloke Registered User

    414
    135
    43
  5. DJAlix

    DJAlix VAG Car Coding™ Limited Site Sponsor Gold Supporter VCDS Map User VAG Can Professional ODIS (Offboard Diagnostic System)

    6,707
    5,128
    113
    Book in with DH and I will give the ECU a scan for you.
     
    Fatbloke likes this.
  6. Fatbloke

    Fatbloke Registered User

    414
    135
    43
    Update...... the engine fault light reset itself yesterday morning. Absolutely no issues now. Car starts and runs perfectly.

    The only thing I can think of that it was extremely wet on the way home the other evening before the fault light came on later in the evening. Could there have been some water penetration that caused the issue?
     

Share This Page

Do Not Sell My Personal Information