1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enabling TPMS for A3 S3 8V *Experimental*

veeeight Apr 30, 2014

  1. Silky-S3

    Silky-S3 Is loving his new 8V S3!

    1,407
    343
    83
    Great work mate. Do you want my ABS coding? I'll try to have play this weekend.
     
  2. Avatar

    Google AdSense Advertisement


  3. veeeight

    veeeight I am a very pretty girl VCDS Map User Black Edition

    6,842
    4,751
    113
    Yes please, the more we have, the more of a correlation we can work out !
     
  4. lewart_waw

    lewart_waw New Member

    10
    0
    1
    o the TPMS is not much radio / nav.
    as I coded ABS indicator lamp is lit it. the MMI does not have access to reset the TPMS.
    if you need additional encode nav?
     
  5. aymensallam

    aymensallam New Member

    26
    2
    3
    I can't seem to find the vehicle function extension tire pressure system in the 5F module. I've managed to get the indicator on the speedo lit and the menu on my MMI but for some reason it doesn't detect loss of pressure.
    can someone help me?
     
  6. veeeight

    veeeight I am a very pretty girl VCDS Map User Black Edition

    6,842
    4,751
    113
    Have you checked for "active" in the 4 separate places in the 5F module?

    Can you then see the TPMS menu in. The MMI ?WHAT IS YOUR CAR, A3, S3, Quattro, what options, Hold Assist etc.

    What are you doing to try and detect loss of pressure?
     
  7. aymensallam

    aymensallam New Member

    26
    2
    3
    I can only see two of the four. And yes I can see the menu on the mmi. I have an A3 with hold assist but basic mmi without sat nav. I save the pressure then I set one of the wheels less then the rest. I've been driving like this for two days and nothing shows up. I'm not home now but I can post my auto scan later the day if that can show more with the issue.
    I'm kind of new with vcds O:)
     
  8. veeeight

    veeeight I am a very pretty girl VCDS Map User Black Edition

    6,842
    4,751
    113
    Ah. My posts are based on Tech Pack, I don't know how to do it with basic MMI. I would have though you would still have to find it in all 4 places on the 5F module.

    And if you reduce 1 tyre by 5psi, it will alarm within 5 miles.

    Check that you have modified all 3 modules
    ABS
    Instruments
    MMI
     
  9. Silky-S3

    Silky-S3 Is loving his new 8V S3!

    1,407
    343
    83
    Gonna have a try try with this now!
     
  10. Silky-S3

    Silky-S3 Is loving his new 8V S3!

    1,407
    343
    83
    My ABS coding:

    Address 03: ABS Brakes (J104) Labels: 5Q0-907-379.clb
    Part No SW: 5Q0 907 379 AB HW: 5Q0 907 379 H
    Component: ESC H31 0557
    Revision: 00000000 Serial number: 62853000000374
    Coding: 32F193A254282A74037A070541C3694CC92A54C0E08296F7F84150080508
    Shop #: WSC 06314 790 00021
    ASAM Dataset: EV_Brake1UDSContiMK100IPB 033001
    ROD: EV_Brake1UDSContiMK100IPB_AU37.rod
    VCID: 7CFC8F17F73225DA29-8029
     
  11. Silky-S3

    Silky-S3 Is loving his new 8V S3!

    1,407
    343
    83
    Well, that wasn't very successful!

    Changed 08 to 38 and 05 to 86 resulted in hill hold error and parking brake error

    Changing 08 to 38 and 05 to 85 seems to get the TPMS light on the dash, and no errors.

    Made sure everything was active in the 5F and 17 module. But no new menu in the MMI? Do I need to reset the MMI somehow?

    Any help anyone?

    Thanks
     
  12. Avatar

    Google AdSense Advertisement


  13. Silky-S3

    Silky-S3 Is loving his new 8V S3!

    1,407
    343
    83
    Scrap the above, just reset the MMI and have the new menu there! :)

    Just saved the pressures and everything looks good. Might try to let a tyre down now!

    Cheers guys
     
    veeeight likes this.
  14. veeeight

    veeeight I am a very pretty girl VCDS Map User Black Edition

    6,842
    4,751
    113
    Yes, you have to do the 3 finger MMI reset after coding ! :)
     
  15. Schizophonic

    Schizophonic Well-Known Member

    1,041
    532
    113
    What model engine has this been tested on? Have we gathered what are the basic requirements are?
     
  16. Silky-S3

    Silky-S3 Is loving his new 8V S3!

    1,407
    343
    83
    Let a tire down about 10psi and got the message on the DIS. Happy days! TPMS for free :)

    Cheers guys
     
    veeeight likes this.
  17. lukappaseidue

    lukappaseidue New Member

    27
    1
    3
    Can I Activate on my A3 8VA 1.6 TDi SportBack with MMI no touch or plus?
     
  18. Alan Porter

    Alan Porter New Member

    28
    2
    3
    Awesome.

    Is anyone able to write a step by step guide for us to try? I'm very risk averse with these things....
     
  19. virus88n

    virus88n New Member

    1
    0
    1
    hello this is my long coding of my audi s3!i have stronic acc and TPMS! but i don't have a auto-hold function...

    for auto-holdiI would like to activate it .. you know how to do ??

    my long coding:32F16BA254202A6C017F070441C9694CD62A5480E08296F6F84150788608
     
  20. veeeight

    veeeight I am a very pretty girl VCDS Map User Black Edition

    6,842
    4,751
    113
  21. Phil-1

    Phil-1 Well-Known Member Regional Rep

    2,138
    781
    113
    I know this is an old thread but do we have a definet step by step guide to enabling this?

    I would like this on my 2013 TDi S-Line.

    Thanks
    Phil
     
    RYuill likes this.
  22. ChiYoung

    ChiYoung Active Member

    148
    41
    28
    Since there is a lot of trouble in this thread and everything is a bit messy I'll just post the instructions a bit more clearly.
    TPMS Instructions:

    Module 5F

    Activate these next ones (just choose active):
    (56) vehicle_menu-operation-menu_display_rdk
    (13) vehicle_function list BAP; extension-tire_pressure_system_0x07

    Module 17 Instruments
    Coding -> Long coding.
    Byte 4 check bit 0

    Module 03 ABS/Brakes
    (dont know if necesary) security code 20103
    Coding.
    heres the dificult part
    example of the original code
    12F162A224250A720178060841CC2548462450806082A4F2004100080508
    New code should look like these
    12F162A224250A720178060841CC2548462450806082A4F2004100388508
    Just changing those 2 numbers at the end will be all you need to change.
    Then save the new code.

    Resete MMI (Menu + OK + Right up button) press them it the order shown and release immidiately

    Start engine, leave it 1 min, then turn off ignition.

    Go to Menu -> Car -> Sistems -> Service y control -> (it should be there)
     
    cbotved and Phil-1 like this.
  23. visionthing

    visionthing Active Member VCDS Map User

    210
    91
    28
    32F193A254232A740179070741C8694CC92A5480E08296F6024100080608

    S3 sportback, S-tronic, basic Nav

    No ACC, Hold-Assist or TPMS
     
  24. ChiYoung

    ChiYoung Active Member

    148
    41
    28
    Then your code for TPMS should be
    32F193A254232A740179070741C8694CC92A5480E08296F6024100388608

    Plus you would have to activate the menus at module 5F and check the byte 4 bit 0 in Module 17 Instruments.
     
  25. andrew kay

    andrew kay New Member

    5
    0
    1
    Module 03
    From
    10F18AA2242512710179060441C8290851244880608294F2002100080608

    To

    10F18AA2242512710179060441C8290851244880608294F2002100388608

    2014 s-line 1.4
     
  26. andrew kay

    andrew kay New Member

    5
    0
    1
    Sorry meant to add above these are the changes made to enable TPMS in module 3. All the other listed changes in previous articles also had to be applied in modules 5F and 17
     
  27. Phil-1

    Phil-1 Well-Known Member Regional Rep

    2,138
    781
    113
    Would it be possible for someone to put this all in a single post so I can print it off and try it on my car?

     
  28. CunniBlingus

    CunniBlingus New Member

    8
    2
    3
    I don't suppose this would work on a mk7 golf would it?
     
  29. Cruiser89

    Cruiser89 Advanced In Car Tech

    1,481
    220
    63
    Post number 60 by ChiYoung pal :)
     
  30. Phil-1

    Phil-1 Well-Known Member Regional Rep

    2,138
    781
    113
    Hi Tim

    Thanks I must have read it wrong I thought a step was missing
     
  31. RYuill

    RYuill Well-Known Member Audi RS3 Audi S3

    806
    538
    93
    Just another one to add to the list .

    I followed the same steps as this
    [​IMG]

    Except my long code was different, so here is a copy of mine.

    [​IMG]

    I have a 2014 S3 S-tronic, non teck pack. With hold assist.
     
    veeeight likes this.
  32. RYuill

    RYuill Well-Known Member Audi RS3 Audi S3

    806
    538
    93
    Did anyone else see a fault on the dis after hitting do it.

    Today I changed the long code from 28 To 38 and on the DIS it showed ACC not activated and Pre sense system fault.

    I switched the car off and on again, there was no faults showing. I went for a drive and ACC and pre sense was working fine.
     
  33. Avatar

    Google AdSense Advertisement


  34. ChiYoung

    ChiYoung Active Member

    148
    41
    28
    That's why at the end of the instructions it says reset MMI and turn on and off engine :)
     
    RYuill likes this.
  35. /dev/null

    /dev/null Active Member

    244
    46
    28
    Ok, here is my long coding.

    13F18AA224210A72017A060841C329C851245080608294F2006100080608

    63 plate A3 Saloon S-Line, 2.0 TDi Manual.
    Car does not have TPMS or hold assist, it has the tech pack but not the "full" one I don't think - it has HD sat nav, but not audi connect.
     
    Last edited: Dec 29, 2014
  36. /dev/null

    /dev/null Active Member

    244
    46
    28
    Ok, so I just tried this on my car... and it appears to have worked! Well, I have the option on the menu and when I select to store tyre pressures it says successfully stored. As above, my long coding was slightly different but I just changed those two values. I don't fancy letting a tyre down a bit and trying it out at the moment because the roads are quite icy around here but might give it a go when conditions are better!
    All in all though quite happy with that (assuming it works! :)) - that's with my £12 cable bought from China off the internet for all the non-oem haters out there! :p
     
  37. Phil-1

    Phil-1 Well-Known Member Regional Rep

    2,138
    781
    113
    Just had this enabled on my A3 8V S-Line 184. Thanks Helifela.
    My code was also slightly different but worked ok.
     
  38. Schizophonic

    Schizophonic Well-Known Member

    1,041
    532
    113
    is this thread still alive, I'm struggling to get mine to work :(
     
    Kalashnikov likes this.
  39. Phil-1

    Phil-1 Well-Known Member Regional Rep

    2,138
    781
    113
    What's your problem getting it to work?
     
  40. veeeight

    veeeight I am a very pretty girl VCDS Map User Black Edition

    6,842
    4,751
    113
    What's the original long code

    and whats the modified long code you tried?
     
  41. Phil-1

    Phil-1 Well-Known Member Regional Rep

    2,138
    781
    113
    I have a friend that did mine. Will ask him to post here

    @Helifella
     
  42. Schizophonic

    Schizophonic Well-Known Member

    1,041
    532
    113
    Followed the instructions once again and ran into a number of issues.

    Following the instructions from ChiYoung

    Step1
    Module 5F
    Activate these next ones (just choose active):
    (56) vehicle_menu-operation-menu_display_rdk
    (13) vehicle_function list BAP; extension-tire_pressure_system_0x07

    Done, no errors when doing so

    Step2
    Module 17 Instruments
    Coding -> Long coding.
    Byte 4 check bit 0

    Noticed my Tire Pressure icon showing on my dash so no problems there

    Step3

    Module 03 ABS/Brakes
    (dont know if necesary) security code 20103
    Coding.
    heres the dificult part
    example of the original code
    12F162A224250A720178060841CC2548462450806082A4F2004100080508
    New code should look like these
    12F162A224250A720178060841CC2548462450806082A4F2004100388508
    Just changing those 2 numbers at the end will be all you need to change.
    Then save the new code.

    So my standard long code is
    [​IMG]
    I changed the last part of the coding to 288805 based on Ryhill, that showed me my ABS sensor and Tire Spinning icon.

    When doing this I changed the code

    Step4
    Reset MMI (Menu + OK + Right up button) press them it the order shown and release immidiately
    Start engine, leave it 1 min, then turn off ignition.
    Go to Menu -> Car -> Sistems -> Service y control -> (it should be there)

    Left that on and did a reset and it eventually disappeared but when going into the MMI menus to set the values of the tire pressure its greyed out and I can't get into or change any details.

    Next I tried to take ChiYoung's long code and change to 308805 and resulted in the dash saying stop start unavailable and hold hill is unavailable.

    My car is an 2013 build, Sportback Sport with standard sat nav MMI. Any ideas what I can try and do? What I'm confused is the greyed out options for my TPMS on my MMI, why is that not giving me any options to change or add any values?
     
  43. ChiYoung

    ChiYoung Active Member

    148
    41
    28
    I think your last numbers of the coding may be 208805 and you have to have your car Engine running to use this function

    Good luck

    Edit: wait wait did those errors with the code 308805 dissappear after running the engine again? Do you still have the time pressure menu in the mmi with the 308805 code?
     

Share This Page