Eibach Pro Kit - Binding / Clunking

Deezer-D

Registered User
I’ve the Eibach Pro Kit fitted to my 2015 S3 and I’m getting a bang / clunk sound usually on full lock when reversing. Sounds like the front spring binding when rotating then releasing whit a bang if that makes sense?
Anyone else experiencing similar issues?


Sent from my iPhone using Tapatalk Pro
 

-Ju-

Well-Known Member
VCDS Map User
I had the same setup on my 2015 S3, no issues for me.
I'd check the springs are properly seated in the seats and that the top mounts are also seated/fitted correc8
 

Deezer-D

Registered User
I had the same setup on my 2015 S3, no issues for me.
I'd check the springs are properly seated in the seats and that the top mounts are also seated/fitted correc8

Could well be a seating issue. Will get it checked.


Sent from my iPhone using Tapatalk Pro
 

-Ju-

Well-Known Member
VCDS Map User
Could well be a seating issue. Will get it checked.


Sent from my iPhone using Tapatalk Pro
I know it's a bind (pardon the pun lol) but its something that has to be checked.
Did you reuse the old top mounts, I generally do and dont have issues!

Sent from my SM-N960F using Tapatalk
 

Deezer-D

Registered User
I know it's a bind (pardon the pun lol) but its something that has to be checked.
Did you reuse the old top mounts, I generally do and dont have issues!

Sent from my SM-N960F using Tapatalk

Old top mounts were reused. Car only had 38K when the springs were done so wouldn’t expect to need to replace the top mounts at that kind of mileage


Sent from my iPhone using Tapatalk Pro
 
Top