1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dual climate control - passenger side cold

kpm278 Oct 17, 2018

  1. kpm278

    kpm278 Member

    80
    6
    8
    Hi

    I'm trying to diagnose a problem with a cold passenger side. Car is UK model. I plugged in VCDS....

    With both controls set at 22 degrees:
    Left front vent temp = 15 degrees
    Left specified temperature = 22 degrees
    Right front vent temp = 22 degrees
    Right specified temperature = 15 degrees

    So it seems the right dial is only calling for 15 degrees despite what the screen says, and it puts out 15 degrees on the left vent....?

    I tried at different temperatures on the display and right specified temperature remained at 15 and left vents remained cold.

    I don't know the plug setup on the back of the CC unit - is it possible the plugs are in the wrong place? Or car thinks its a left hand drive model?

    Thanks, Kristian
     
  2. Avatar

    Google AdSense Advertisement


  3. ch1z64

    ch1z64 C'mon you's bhoy's in Green Team Imola TFSI Owners Group Silver Supporter Team Sprint Audi S3 Manual

    2,860
    580
    113
    Firstly i am guessing for what u have put in post you have a RHD and looks like your car could be set up for LHD .
    If i mind in a post ( Q3 climate control a3 / s3 8p section ) there was something in that post that explained how you could change it over . So might be worth a read . With out knowing what your CC looks like its hard to say if plugs are in the wrong place , i do know when i did the Q3 retrofit in my S3 8p i had to remove old back off 8p CC and put on new CC so the plugs fitted .
     
  4. kpm278

    kpm278 Member

    80
    6
    8
    Hi, the cross-reading seems to have sorted itself out with a vcds update, now it reads:

    With both controls set at 22 degrees:
    Left front vent temp = 15 degrees
    Left specified temperature = 15 degrees
    Right front vent temp = 22 degrees
    Right specified temperature = 22 degrees

    The car has been into the garage today and they've been unable to diagnose the problem. Not sure where to look now. Is it worth swapping the vent sensors over? I suspect not as the left hand side is reading the temperature correctly. Flap values are apparently fine. They suggested the arm may have come away from the motor but were unable to sight this without pulling more dashboard apart. I've had a look myself and where I was expecting to see multicoloured arms and motors, I think I can see one motor and no coloured arms. I pushed them to flush the system and they remarked the heater matrix was getting hot as expected with no other signs of a blocked matrix.

    Does anyone know the internals of the heater matrix? Is there one hot air feed into the car or two? If there's two its possible one is blocked I suppose.

    Thanks
     
  5. kpm278

    kpm278 Member

    80
    6
    8
    to add.... the passenger side temperature can go as low as 9.5 and it will show signs of heating up when you crank the dial up, but it only gets to around 16/17 and goes no higher.
     

Share This Page